I have a 2950 switch that I want to create two vlans on and put the first 12 ports in vlan 67 and the last 12 in vlan 68. I want to connect the switch to my 2951xm router and trunk the two vlans across the link. I have created the vlans, put the ports in the appropriate vlans with these commands in the switch:
interface FastEthernet0/1
description Link to router; FA0/0
switchport trunk allowed vlan 67,68
switchport mode trunk
no ip address
duplex full
speed 100
As for the ports themselves I used the 'switchport access vlan' command to put the ports in the appropriate vlans. Won't bother showing all of that here.
On the router I have these commands for the other end of the trunk:
interface FastEthernet0/0
description Link to OKONETASUB-SW1; Port FA0/1
no ip address
no ip redirects
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/0.67
description Link to okonetasub-sw1 for local AEP connections
encapsulation dot1Q 67
ip address 10.120.67.254 255.255.255.0
no ip redirects
ip pim sparse-dense-mode
!
interface FastEthernet0/0.68
description Link to okonetasub-sw1 for Adesta connections
encapsulation dot1Q 68
ip address 10.120.68.254 255.255.255.0
no ip redirects
ip pim sparse-dense-mode
There must be something wrong here because from the switch I cannot ping the router and vice versa. Why can't I talk between the two. Show vlans on the switch shows both vlans to be 'active', and the sh interface command shows all of these interfaces to be up up. What am I missing? I am new at this, so, I would not be surprised to be missing alot, but any advice would be appreciated. Need more info, let me know. Thanks in advance.
Mike in Tulsa
interface FastEthernet0/1
description Link to router; FA0/0
switchport trunk allowed vlan 67,68
switchport mode trunk
no ip address
duplex full
speed 100
As for the ports themselves I used the 'switchport access vlan' command to put the ports in the appropriate vlans. Won't bother showing all of that here.
On the router I have these commands for the other end of the trunk:
interface FastEthernet0/0
description Link to OKONETASUB-SW1; Port FA0/1
no ip address
no ip redirects
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/0.67
description Link to okonetasub-sw1 for local AEP connections
encapsulation dot1Q 67
ip address 10.120.67.254 255.255.255.0
no ip redirects
ip pim sparse-dense-mode
!
interface FastEthernet0/0.68
description Link to okonetasub-sw1 for Adesta connections
encapsulation dot1Q 68
ip address 10.120.68.254 255.255.255.0
no ip redirects
ip pim sparse-dense-mode
There must be something wrong here because from the switch I cannot ping the router and vice versa. Why can't I talk between the two. Show vlans on the switch shows both vlans to be 'active', and the sh interface command shows all of these interfaces to be up up. What am I missing? I am new at this, so, I would not be surprised to be missing alot, but any advice would be appreciated. Need more info, let me know. Thanks in advance.
Mike in Tulsa