I have never really setup VLANs before from scratch. I have a Cisco 881 Router and 2 Cisco Switches (SG200-50 and SF300-48P). I need to have two vlans. Vlan1 (10.100.20.0) and Vlan21 (10.100.21.0). Both these should be able to talk to each other for various reasons. The Cisco router is configured with two interfaces. FA0 using VLAN1 and FA1 using VLAN21 currently. I have VLAN1 plugged into G1 on the SG200-50. I have VLAN2 plugged into G4 on SF300-48P. Now, I know this probably isn't a good setup. Each VLAN will work on their own switch, but I want to be able to use both VLANs on each switch. I tried linking the switches together, but that ended up in no connectivity. It may have been due to a loop since VLAN1 and VLAN21 can talk to each other. Can someone help me figure out the best way of doing this. It should be simple for someone experienced in networking. I have attached a diagram to help make sense of the matter. Thanks!
881w Router Config (Main Things)
!
interface FastEthernet0
description .20 Interface
switchport mode trunk
no ip address
!
interface FastEthernet1
description .21 Interface
switchport access vlan 21
no ip address
!
interface Vlan1
description .20 Interface
ip address 10.100.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
ip tcp adjust-mss 1452
!
interface Vlan21
description .21 Interface
ip address 10.100.21.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
!
881w Router Config (Main Things)
!
interface FastEthernet0
description .20 Interface
switchport mode trunk
no ip address
!
interface FastEthernet1
description .21 Interface
switchport access vlan 21
no ip address
!
interface Vlan1
description .20 Interface
ip address 10.100.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
ip tcp adjust-mss 1452
!
interface Vlan21
description .21 Interface
ip address 10.100.21.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security in-zone
!