I have 2 routers connected together via Serial port. One end of the eth0 Router1 connected to home-router (192.168.1.1). from Router 1, I am able to ping 192.168.1.1. One end of eth0 Router2 connected to TFTP server (10.1.1.1). From Router2, I am able to ping 10.1.1.1. From Router 1, I am also able to ping eth0 of Router2 (10.1.1.102) but not able to ping 10.1.1.1 vice versa from Router2, I am able to ping eth0 of Router1 (192.168.1.60) but not able to ping 192.168.1.1. Both Routers are 2511. Any help would be greatly appreciated. Please see below ping & configuration info. Thanks.
Hung
===========
Ping from Router1:
Router1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/20 ms
Router1#ping 10.1.1.102
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.102, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/36 ms
Router1#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router1#
====================
Ping from Router2:
Router2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router2#ping 192.168.1.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/47/48 ms
Router2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router2#
===============
Router1 Configuration:
Router1#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
enable password c
!
!
interface Ethernet0
ip address 192.168.1.60 255.255.255.0
no ip split-horizon
!
interface Serial0
ip address 192.167.3.14 255.255.255.0
no ip split-horizon
clockrate 64000
!
interface Serial1
ip address 192.167.3.15 255.255.255.0
no ip split-horizon
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.167.2.0
network 192.167.3.0
!
ip classless
!
!
line con 0
line 1 16
no exec
modem DTR-active
transport input all
dispatch-timeout 50
dispatch-character 10
dispatch-character 35
dispatch-character 58
dispatch-character 62
line aux 0
transport input all
line vty 0 3
exec-timeout 0 0
password c
login
line vty 4
no exec
password c
login
line vty 5 15
no exec
password c
login
!
end
Router1#
==============
Router2 Configuration:
Router2#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Router2
!
enable password c
!
!
interface Ethernet0
ip address 10.1.1.102 255.255.255.0
no ip split-horizon
!
interface Serial0
ip address 192.167.2.12 255.255.255.0
no ip split-horizon
!
interface Serial1
ip address 192.167.3.13 255.255.255.0
no ip split-horizon
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.167.2.0
network 192.167.3.0
!
ip default-gateway 10.1.1.1
ip classless
ip route 10.0.0.0 255.0.0.0 10.1.1.0
ip route 10.0.0.0 255.0.0.0 10.1.1.1
!
!
line con 0
exec-timeout 0 0
length 0
line 1 16
no exec
modem DTR-active
transport input all
dispatch-timeout 50
dispatch-character 10
dispatch-character 35
dispatch-character 58
dispatch-character 62
line aux 0
exec-timeout 0 0
length 0
transport input all
line vty 0 4
exec-timeout 0 0
password c
login
!
end
Hung
===========
Ping from Router1:
Router1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/20 ms
Router1#ping 10.1.1.102
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.102, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/36 ms
Router1#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router1#
====================
Ping from Router2:
Router2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router2#ping 192.168.1.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/47/48 ms
Router2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router2#
===============
Router1 Configuration:
Router1#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
enable password c
!
!
interface Ethernet0
ip address 192.168.1.60 255.255.255.0
no ip split-horizon
!
interface Serial0
ip address 192.167.3.14 255.255.255.0
no ip split-horizon
clockrate 64000
!
interface Serial1
ip address 192.167.3.15 255.255.255.0
no ip split-horizon
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.167.2.0
network 192.167.3.0
!
ip classless
!
!
line con 0
line 1 16
no exec
modem DTR-active
transport input all
dispatch-timeout 50
dispatch-character 10
dispatch-character 35
dispatch-character 58
dispatch-character 62
line aux 0
transport input all
line vty 0 3
exec-timeout 0 0
password c
login
line vty 4
no exec
password c
login
line vty 5 15
no exec
password c
login
!
end
Router1#
==============
Router2 Configuration:
Router2#sh run
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Router2
!
enable password c
!
!
interface Ethernet0
ip address 10.1.1.102 255.255.255.0
no ip split-horizon
!
interface Serial0
ip address 192.167.2.12 255.255.255.0
no ip split-horizon
!
interface Serial1
ip address 192.167.3.13 255.255.255.0
no ip split-horizon
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.167.2.0
network 192.167.3.0
!
ip default-gateway 10.1.1.1
ip classless
ip route 10.0.0.0 255.0.0.0 10.1.1.0
ip route 10.0.0.0 255.0.0.0 10.1.1.1
!
!
line con 0
exec-timeout 0 0
length 0
line 1 16
no exec
modem DTR-active
transport input all
dispatch-timeout 50
dispatch-character 10
dispatch-character 35
dispatch-character 58
dispatch-character 62
line aux 0
exec-timeout 0 0
length 0
transport input all
line vty 0 4
exec-timeout 0 0
password c
login
!
end