Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Two routers, two WAN links 4

Status
Not open for further replies.

JayNEC

IS-IT--Management
Jun 5, 2002
942
0
16
US
I feel like this should be easier than I'm making it.
I've got two routers (1941's) each with 3 ethernet ports. 1 for the LAN, and two others that are WAN links (ethernet handoff) to another identical router.

/ GE0/1 WIFI link----------LAN - GE0/0/0 1941- -1941 GE0/0/0 - LAN
\ GE 0/0 Ethernet WAN link-/

Each ethernet port has an IP address assigned (no unnumbered interfaces), the LAN subnets, and two separate IP subnets for each of the WAN links.
Right now there are two static routes with metrics. The problem is that if the WiFi goes down, the ethernet port doesn't go down of course, and the route stays up.

So, I want to really failover from one to the other. If the WIFI link goes down I want to use the Ethernet WAN.
I was going to use IP SLA tracking objects but find I need an additional license. So, I guess I need to use OSPF or some such. However I'm way rusty with OSPF.

Is there a better way? How can I do this simply with OSPF?
 
Too bad I can't edit a post, that was a mess.
Here's a picture

Gn2dH.png
 
easy...
Code:
!R1
interface GigabitEthernet 0/0
 ip address 172.16.1.1 255.255.255.252
 ip ospf network point-to-point
 bandwidth 100000                      ! Makes OSPF think its 100Mbps
!
interface GigabitEthernet 0/1
 ip address 172.16.2.1 255.255.255.252
 ip ospf network point-to-point
 bandwidth 10000                       ! Makes OSPF think its 10Mbps
!
router ospf 10
 network 172.16.1.1 0.0.0.0 area 0
 network 172.16.2.1 0.0.0.0 area 0
 network 10.1.1.1 0.0.0.0 area 0
 passive-interface GigabitEthernet0/0/0
!

!R2
interface GigabitEthernet 0/0
 ip address 172.16.1.2 255.255.255.252
 ip ospf network point-to-point
 bandwidth 100000                      ! Makes OSPF think its 100Mbps
!
interface GigabitEthernet 0/1
 ip address 172.16.2.2 255.255.255.252
 ip ospf network point-to-point
 bandwidth 10000                       ! Makes OSPF think its 10Mbps
!
router ospf 10
 network 172.16.1.2 0.0.0.0 area 0
 network 172.16.2.2 0.0.0.0 area 0
 network 10.1.2.1 0.0.0.0 area 0
 passive-interface GigabitEthernet0/0/0
!

This will make your wireless link preferred, if the link fails the OSPF adjacency will fail and routing will fallback to the other link.
You should ideally have some /32 loopback interfaces so the router will use this as the OSPF RID, or manually set the RID under the OSPF process.

Andy
 
Understand that it will take up to 40 seconds for OSPF to detect the failure. if the interface doesn't go down, then you have to wait for the dead-timer to kick in. You should use bidirectional forwarding detection (BFD) in addition to this perfect OSPF config provided by Andy, or tweak your OSPF timers.

 
If you tweak the timers you get it down to sub-second failover with the interface command 'ip ospf dead-interval minimal hello-multiplier xx' where 'xx' is the number of Hellos sent within 1 second. If you set this to 5 then failover will happen in less than 1-second. This results in more network 'control' traffic however it is a tiny amount that is prioritised by default by the router.
If you do tune your timers down its likely you won't see failures as the recovery will happen so quickly therefore you need a management system that will tell you a failure has occurred.

Good luck
Andy
 
(been on the road a few days)

Holy Crap! Way above and beyond the call of duty ADB100. Thanks!

Stars for everyone!
 
Ok, so one other piece.
R1 is the default gateway for R2 and it has a next hop of a firewall at R1's site.

So, can I just add

network 0.0.0.0 0.0.0.0 area 0

in there?
 
Nevermind the above. Found the right command.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top