fieryhail
IS-IT--Management
- Mar 12, 2010
- 92
I'm having a very difficult time establishing NAT connectivity to resources on the PIX inside interface from the internet. At one point, had things working fine, but had a bunch of Layer-2 switches connected to separate interfaces on the PIX. Now the separate networks are on a Layer 3 switch, and connected to the PIX via the "inside" interface. When logged into the PIX, I can fully access all resources connected to the layer 3 switch. I've tried everything I can think of, but must be missing something, probably a NAT misconfiguration. I'll post a "clean" version of PIX config here. A symptom is, when I try to access a PATted resource from the internet, the connection times out. I have a media server that is accessed using custom port 420 that translates to private port 80. Packet-tracer allows traffic fine to the outside routable IP, but I get dropped on phase 6 "rpf-check" when I try to go to the private inside address. Any suggestions? At this point I'm just trying to get NAT setup correctly then will tighten the PIX down further. I'm going to be ommitting the VPN parts of the config as I don't believe them to be relevant to this, if I am mistaken I'll post them also, just trying to make the post a little smaller. Thanks in advance for any suggestions.
PIX Version 8.0(4)
!
hostname PIX0
domain-name rcserveny.com
enable password 7U6F27URx059dL3Q encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0
nameif OUTSIDE
security-level 0
ip address 96.xx.xx.174 xx.xx.xx.xx
!
interface Ethernet1
speed 100
duplex full
nameif INSIDE
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet3
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet4
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet5
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet6
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet7
shutdown
no nameif
security-level 100
no ip address
!
interface Ethernet8
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet9
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
dns server-group DefaultDNS
domain-name rcserveny.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit icmp any any
access-list outside_access_in extended permit icmp any any
access-list OUTSIDE_access_in extended permit ip any any
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq smtp
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq 2080
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq https
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq lotusnotes
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.171 eq www
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.171 eq lotusnotes
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.171 eq https
access-list OUTSIDE_access_in extended permit object-group TCPUDP any eq domain host 96.xx.xx.173 eq domain
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.173 eq www
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.173 eq ftp
access-list INSIDE_access_in extended permit ip 192.168.0.0 255.255.0.0 any
access-list INSIDE_access_in extended permit ip 172.16.0.0 255.255.255.0 any
access-list rcsinternal_splitTunnelAcl standard permit 192.168.110.0 255.255.255.0
access-list rcsinternal_splitTunnelAcl standard permit 192.168.10.0 255.255.255.0
access-list rcsinternal_splitTunnelAcl standard permit 192.168.20.0 255.255.255.0
access-list rcsinternal_splitTunnelAcl standard permit 172.16.0.0 255.255.255.0
access-list INSIDE_nat0_outbound extended permit ip 192.168.110.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list INSIDE_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list INSIDE_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list INSIDE_nat0_outbound extended permit ip 172.16.0.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list OUTSIDE_IN extended permit ip any any
pager lines 24
logging enable
logging asdm warnings
mtu OUTSIDE 1500
mtu INSIDE 1500
ip local pool RCSVOICE 192.168.110.221-192.168.110.230 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm-61551.bin
no asdm history enable
arp timeout 14400
global (OUTSIDE) 101 interface
nat (INSIDE) 0 access-list INSIDE_nat0_outbound
nat (INSIDE) 101 0.0.0.0 0.0.0.0
static (INSIDE,OUTSIDE) udp 96.xx.xx.173 domain 192.168.20.5 domain netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.173 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.173 ftp 192.168.20.5 ftp netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 2080 192.168.10.2 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 smtp 192.168.10.2 smtp netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.171 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 lotusnotes 192.168.10.2 lotusnotes netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.171 https 192.168.10.4 https netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7080 192.168.10.6 7080 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7443 192.168.10.6 7443 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7090 192.168.10.6 7090 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7444 192.168.10.6 7444 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 18180 192.168.10.6 18180 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 18443 192.168.10.6 18443 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 11100 192.168.10.6 11100 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 11099 192.168.10.6 11099 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp interface 420 netmask 255.255.255.255
access-group OUTSIDE_access_in in interface OUTSIDE
access-group INSIDE_access_in in interface INSIDE
!
!
route OUTSIDE 0.0.0.0 0.0.0.0 96.xx.xx.169 1
route INSIDE 192.168.10.0 255.255.255.0 192.168.0.2 1
route INSIDE 192.168.20.0 255.255.255.0 192.168.0.2 1
route INSIDE 192.168.110.0 255.255.255.0 192.168.0.2 1
aaa authentication ssh console LOCAL
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:13b90c05b926368a274eb4e8ed8de4f3
: end
PIX Version 8.0(4)
!
hostname PIX0
domain-name rcserveny.com
enable password 7U6F27URx059dL3Q encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0
nameif OUTSIDE
security-level 0
ip address 96.xx.xx.174 xx.xx.xx.xx
!
interface Ethernet1
speed 100
duplex full
nameif INSIDE
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet3
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet4
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet5
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet6
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet7
shutdown
no nameif
security-level 100
no ip address
!
interface Ethernet8
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet9
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
dns server-group DefaultDNS
domain-name rcserveny.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit icmp any any
access-list outside_access_in extended permit icmp any any
access-list OUTSIDE_access_in extended permit ip any any
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq smtp
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq 2080
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq https
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.172 eq lotusnotes
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.171 eq www
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.171 eq lotusnotes
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.171 eq https
access-list OUTSIDE_access_in extended permit object-group TCPUDP any eq domain host 96.xx.xx.173 eq domain
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.173 eq www
access-list OUTSIDE_access_in extended permit tcp any host 96.xx.xx.173 eq ftp
access-list INSIDE_access_in extended permit ip 192.168.0.0 255.255.0.0 any
access-list INSIDE_access_in extended permit ip 172.16.0.0 255.255.255.0 any
access-list rcsinternal_splitTunnelAcl standard permit 192.168.110.0 255.255.255.0
access-list rcsinternal_splitTunnelAcl standard permit 192.168.10.0 255.255.255.0
access-list rcsinternal_splitTunnelAcl standard permit 192.168.20.0 255.255.255.0
access-list rcsinternal_splitTunnelAcl standard permit 172.16.0.0 255.255.255.0
access-list INSIDE_nat0_outbound extended permit ip 192.168.110.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list INSIDE_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list INSIDE_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list INSIDE_nat0_outbound extended permit ip 172.16.0.0 255.255.255.0 192.168.110.192 255.255.255.192
access-list OUTSIDE_IN extended permit ip any any
pager lines 24
logging enable
logging asdm warnings
mtu OUTSIDE 1500
mtu INSIDE 1500
ip local pool RCSVOICE 192.168.110.221-192.168.110.230 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm-61551.bin
no asdm history enable
arp timeout 14400
global (OUTSIDE) 101 interface
nat (INSIDE) 0 access-list INSIDE_nat0_outbound
nat (INSIDE) 101 0.0.0.0 0.0.0.0
static (INSIDE,OUTSIDE) udp 96.xx.xx.173 domain 192.168.20.5 domain netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.173 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.173 ftp 192.168.20.5 ftp netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 2080 192.168.10.2 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 smtp 192.168.10.2 smtp netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.171 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 lotusnotes 192.168.10.2 lotusnotes netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.171 https 192.168.10.4 https netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7080 192.168.10.6 7080 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7443 192.168.10.6 7443 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7090 192.168.10.6 7090 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 7444 192.168.10.6 7444 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 18180 192.168.10.6 18180 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 18443 192.168.10.6 18443 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 11100 192.168.10.6 11100 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp 96.xx.xx.172 11099 192.168.10.6 11099 netmask 255.255.255.255
static (INSIDE,OUTSIDE) tcp interface 420 netmask 255.255.255.255
access-group OUTSIDE_access_in in interface OUTSIDE
access-group INSIDE_access_in in interface INSIDE
!
!
route OUTSIDE 0.0.0.0 0.0.0.0 96.xx.xx.169 1
route INSIDE 192.168.10.0 255.255.255.0 192.168.0.2 1
route INSIDE 192.168.20.0 255.255.255.0 192.168.0.2 1
route INSIDE 192.168.110.0 255.255.255.0 192.168.0.2 1
aaa authentication ssh console LOCAL
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:13b90c05b926368a274eb4e8ed8de4f3
: end