LingaringBell
IS-IT--Management
This is the first time I've tried to use wireless on a Cisco Router and everything seems to be working fine except DHCP. The DHCP server is on a different subnet, so I put in a helper-address, but that has no effect. I also tried making the 1811 the DHCP server, but that didn't work either. The wireless SSID is bonded with vlan 25. If I plug a computer into one of the FastEthernet interfaces that is on vlan 25, it gets DHCP fine. Any ideas? I'm sure I'm just missing something silly. Here is my config:
!
interface FastEthernet2
switchport access vlan 20
duplex full
speed 100
!
interface FastEthernet3
switchport access vlan 20
!
interface FastEthernet4
switchport access vlan 20
!
interface FastEthernet5
switchport access vlan 20
!
interface FastEthernet6
switchport access vlan 25
!
interface FastEthernet7
switchport access vlan 25
!
interface FastEthernet8
switchport access vlan 25
!
interface FastEthernet9
switchport access vlan 25
!
interface Dot11Radio0
no ip address
ip helper-address 192.168.22.251
shutdown
!
encryption mode ciphers tkip
!
encryption vlan 25 mode ciphers tkip
!
ssid CDIA_289_FirstFloor2
vlan 25
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 0 password
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.25
encapsulation dot1Q 25 native
ip helper-address 192.168.22.251
no snmp trap link-status
no cdp enable
!
interface Dot11Radio1
no ip address
shutdown
speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
ip tcp adjust-mss 1452
!
interface Vlan25
ip address 192.168.25.3 255.255.255.0
ip helper-address 192.168.22.251
!
interface Vlan20
ip address 10.10.12.9 255.255.255.0
ip helper-address 192.168.22.251
ip nat inside
ip virtual-reassembly
!
!
interface FastEthernet2
switchport access vlan 20
duplex full
speed 100
!
interface FastEthernet3
switchport access vlan 20
!
interface FastEthernet4
switchport access vlan 20
!
interface FastEthernet5
switchport access vlan 20
!
interface FastEthernet6
switchport access vlan 25
!
interface FastEthernet7
switchport access vlan 25
!
interface FastEthernet8
switchport access vlan 25
!
interface FastEthernet9
switchport access vlan 25
!
interface Dot11Radio0
no ip address
ip helper-address 192.168.22.251
shutdown
!
encryption mode ciphers tkip
!
encryption vlan 25 mode ciphers tkip
!
ssid CDIA_289_FirstFloor2
vlan 25
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 0 password
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.25
encapsulation dot1Q 25 native
ip helper-address 192.168.22.251
no snmp trap link-status
no cdp enable
!
interface Dot11Radio1
no ip address
shutdown
speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
ip tcp adjust-mss 1452
!
interface Vlan25
ip address 192.168.25.3 255.255.255.0
ip helper-address 192.168.22.251
!
interface Vlan20
ip address 10.10.12.9 255.255.255.0
ip helper-address 192.168.22.251
ip nat inside
ip virtual-reassembly
!