I cant believe what a hard time I am having figuring this out. Here is the scenario. I have a home cisco lab with a couple routers and switches. I have a lab router plugged into my home production network dumb switch getting an ip from dhcp. I can NOT telnet from any of my home computers into the router. What gives?
<<<Router CONFIG>>>
router1#show run
Building configuration...
Current configuration : 1124 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jZVI$L9StoMdzdjhKqTHGVaMqw.
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
!
!
!
interface FastEthernet0/0
description Link to Switch 1 f0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed 100
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
description Link to home network switch
ip address dhcp
ip nat outside
speed 100
full-duplex
no cdp enable
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.1.1 0.0.0.0 area 0
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
no ip http server
!
access-list 1 permit any
banner motd ^C
This is Router 1
^C
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password telnet
login
!
!
end
<<<debug output from inside cisco router on f0/1>>>
router1#
*Mar 1 00:22:33.051: IP: tableid=0, s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), routed via RIB
*Mar 1 00:22:33.051: IP: s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), len 48, rcvd 3
*Mar 1 00:22:33.051: TCP src=3794, dst=23, seq=2081413630, ack=0, win=65535 SYN
*Mar 1 00:22:33.055: IP: tableid=0, s=192.168.10.109 (local), d=192.168.10.5 (FastEthernet0/1), routed via FIB
*Mar 1 00:22:33.055: IP: s=192.168.10.109 (local), d=192.168.10.5 (FastEthernet0/1), len 44, sending
*Mar 1 00:22:33.055: TCP src=23, dst=3794, seq=369665432, ack=2081413631, win=4128 ACK SYN
router1#
*Mar 1 00:22:33.059: IP: tableid=0, s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), routed via RIB
*Mar 1 00:22:33.059: IP: s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), len 40, rcvd 3
*Mar 1 00:22:33.059: TCP src=3794, dst=23, seq=2081413631, ack=2081413631, win=0 RST
router1#
<<<<<<<<<WireShark Capture on home computer trying to establish telnet with lab router>>>>>>>>
No. Time Source Destination Protocol Info
1 0.000000 IntelCor_b0:70:be Broadcast ARP Who has 192.168.10.109? Tell 192.168.10.5
Frame 1 (42 bytes on wire, 42 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Address Resolution Protocol (request)
No. Time Source Destination Protocol Info
2 0.001078 Cisco_ee:19:e1 IntelCor_b0:70:be ARP 192.168.10.109 is at 00:04:dd:ee:19:e1
Frame 2 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Address Resolution Protocol (reply)
No. Time Source Destination Protocol Info
3 0.001089 192.168.10.5 192.168.10.109 TCP sitewatch > telnet [SYN] Seq=0 Win=65535 Len=0 MSS=1260
Frame 3 (62 bytes on wire, 62 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: telnet (23), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
4 0.009139 192.168.10.109 192.168.10.5 TCP compressnet > sitewatch [SYN, ACK] Seq=0 Ack=0 Win=4128 Len=0 MSS=1260
Frame 4 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Internet Protocol, Src: 192.168.10.109 (192.168.10.109), Dst: 192.168.10.5 (192.168.10.5)
Transmission Control Protocol, Src Port: compressnet (3), Dst Port: sitewatch (3792), Seq: 0, Ack: 0, Len: 0
No. Time Source Destination Protocol Info
5 0.009155 192.168.10.5 192.168.10.109 TCP sitewatch > compressnet [RST] Seq=0 Win=0 Len=0
Frame 5 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: compressnet (3), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
6 2.906577 192.168.10.5 192.168.10.109 TCP sitewatch > telnet [SYN] Seq=0 Win=65535 Len=0 MSS=1260
Frame 6 (62 bytes on wire, 62 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: telnet (23), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
7 2.914317 192.168.10.109 192.168.10.5 TCP compressnet > sitewatch [SYN, ACK] Seq=2667685270 Ack=0 Win=4128 Len=0 MSS=1260
Frame 7 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Internet Protocol, Src: 192.168.10.109 (192.168.10.109), Dst: 192.168.10.5 (192.168.10.5)
Transmission Control Protocol, Src Port: compressnet (3), Dst Port: sitewatch (3792), Seq: 2667685270, Ack: 0, Len: 0
No. Time Source Destination Protocol Info
8 2.914338 192.168.10.5 192.168.10.109 TCP sitewatch > compressnet [RST] Seq=0 Win=0 Len=0
Frame 8 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: compressnet (3), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
9 8.935036 192.168.10.5 192.168.10.109 TCP sitewatch > telnet [SYN] Seq=0 Win=65535 Len=0 MSS=1260
Frame 9 (62 bytes on wire, 62 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: telnet (23), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
10 8.942767 192.168.10.109 192.168.10.5 TCP compressnet > sitewatch [SYN, ACK] Seq=3998878986 Ack=0 Win=4128 Len=0 MSS=1260
Frame 10 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Internet Protocol, Src: 192.168.10.109 (192.168.10.109), Dst: 192.168.10.5 (192.168.10.5)
Transmission Control Protocol, Src Port: compressnet (3), Dst Port: sitewatch (3792), Seq: 3998878986, Ack: 0, Len: 0
No. Time Source Destination Protocol Info
11 8.942786 192.168.10.5 192.168.10.109 TCP sitewatch > compressnet [RST] Seq=0 Win=0 Len=0
Frame 11 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: compressnet (3), Seq: 0, Len: 0
<<<Router CONFIG>>>
router1#show run
Building configuration...
Current configuration : 1124 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jZVI$L9StoMdzdjhKqTHGVaMqw.
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
!
!
!
interface FastEthernet0/0
description Link to Switch 1 f0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed 100
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
description Link to home network switch
ip address dhcp
ip nat outside
speed 100
full-duplex
no cdp enable
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.1.1 0.0.0.0 area 0
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
no ip http server
!
access-list 1 permit any
banner motd ^C
This is Router 1
^C
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password telnet
login
!
!
end
<<<debug output from inside cisco router on f0/1>>>
router1#
*Mar 1 00:22:33.051: IP: tableid=0, s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), routed via RIB
*Mar 1 00:22:33.051: IP: s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), len 48, rcvd 3
*Mar 1 00:22:33.051: TCP src=3794, dst=23, seq=2081413630, ack=0, win=65535 SYN
*Mar 1 00:22:33.055: IP: tableid=0, s=192.168.10.109 (local), d=192.168.10.5 (FastEthernet0/1), routed via FIB
*Mar 1 00:22:33.055: IP: s=192.168.10.109 (local), d=192.168.10.5 (FastEthernet0/1), len 44, sending
*Mar 1 00:22:33.055: TCP src=23, dst=3794, seq=369665432, ack=2081413631, win=4128 ACK SYN
router1#
*Mar 1 00:22:33.059: IP: tableid=0, s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), routed via RIB
*Mar 1 00:22:33.059: IP: s=192.168.10.5 (FastEthernet0/1), d=192.168.10.109 (FastEthernet0/1), len 40, rcvd 3
*Mar 1 00:22:33.059: TCP src=3794, dst=23, seq=2081413631, ack=2081413631, win=0 RST
router1#
<<<<<<<<<WireShark Capture on home computer trying to establish telnet with lab router>>>>>>>>
No. Time Source Destination Protocol Info
1 0.000000 IntelCor_b0:70:be Broadcast ARP Who has 192.168.10.109? Tell 192.168.10.5
Frame 1 (42 bytes on wire, 42 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Address Resolution Protocol (request)
No. Time Source Destination Protocol Info
2 0.001078 Cisco_ee:19:e1 IntelCor_b0:70:be ARP 192.168.10.109 is at 00:04:dd:ee:19:e1
Frame 2 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Address Resolution Protocol (reply)
No. Time Source Destination Protocol Info
3 0.001089 192.168.10.5 192.168.10.109 TCP sitewatch > telnet [SYN] Seq=0 Win=65535 Len=0 MSS=1260
Frame 3 (62 bytes on wire, 62 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: telnet (23), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
4 0.009139 192.168.10.109 192.168.10.5 TCP compressnet > sitewatch [SYN, ACK] Seq=0 Ack=0 Win=4128 Len=0 MSS=1260
Frame 4 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Internet Protocol, Src: 192.168.10.109 (192.168.10.109), Dst: 192.168.10.5 (192.168.10.5)
Transmission Control Protocol, Src Port: compressnet (3), Dst Port: sitewatch (3792), Seq: 0, Ack: 0, Len: 0
No. Time Source Destination Protocol Info
5 0.009155 192.168.10.5 192.168.10.109 TCP sitewatch > compressnet [RST] Seq=0 Win=0 Len=0
Frame 5 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: compressnet (3), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
6 2.906577 192.168.10.5 192.168.10.109 TCP sitewatch > telnet [SYN] Seq=0 Win=65535 Len=0 MSS=1260
Frame 6 (62 bytes on wire, 62 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: telnet (23), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
7 2.914317 192.168.10.109 192.168.10.5 TCP compressnet > sitewatch [SYN, ACK] Seq=2667685270 Ack=0 Win=4128 Len=0 MSS=1260
Frame 7 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Internet Protocol, Src: 192.168.10.109 (192.168.10.109), Dst: 192.168.10.5 (192.168.10.5)
Transmission Control Protocol, Src Port: compressnet (3), Dst Port: sitewatch (3792), Seq: 2667685270, Ack: 0, Len: 0
No. Time Source Destination Protocol Info
8 2.914338 192.168.10.5 192.168.10.109 TCP sitewatch > compressnet [RST] Seq=0 Win=0 Len=0
Frame 8 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: compressnet (3), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
9 8.935036 192.168.10.5 192.168.10.109 TCP sitewatch > telnet [SYN] Seq=0 Win=65535 Len=0 MSS=1260
Frame 9 (62 bytes on wire, 62 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: telnet (23), Seq: 0, Len: 0
No. Time Source Destination Protocol Info
10 8.942767 192.168.10.109 192.168.10.5 TCP compressnet > sitewatch [SYN, ACK] Seq=3998878986 Ack=0 Win=4128 Len=0 MSS=1260
Frame 10 (60 bytes on wire, 60 bytes captured)
Ethernet II, Src: Cisco_ee:19:e1 (00:04:dd:ee:19:e1), Dst: IntelCor_b0:70:be (00:13:20:b0:70:be)
Internet Protocol, Src: 192.168.10.109 (192.168.10.109), Dst: 192.168.10.5 (192.168.10.5)
Transmission Control Protocol, Src Port: compressnet (3), Dst Port: sitewatch (3792), Seq: 3998878986, Ack: 0, Len: 0
No. Time Source Destination Protocol Info
11 8.942786 192.168.10.5 192.168.10.109 TCP sitewatch > compressnet [RST] Seq=0 Win=0 Len=0
Frame 11 (54 bytes on wire, 54 bytes captured)
Ethernet II, Src: IntelCor_b0:70:be (00:13:20:b0:70:be), Dst: Cisco_ee:19:e1 (00:04:dd:ee:19:e1)
Internet Protocol, Src: 192.168.10.5 (192.168.10.5), Dst: 192.168.10.109 (192.168.10.109)
Transmission Control Protocol, Src Port: sitewatch (3792), Dst Port: compressnet (3), Seq: 0, Len: 0