telnettech
Vendor
Does anyone have a working configuration for getting T38 to work when faxing outbound/inbound using an analog voice port on a Cisco IAD2431-8FXS. We are using 12.4.12 IOS software. I have included my current configuration for this device below. I am able to fax fine except when it is longer than 3 pages, the fax fails everytime.
Lab_Test_IAD#sho run
Building configuration...
Current configuration : 4325 bytes
!
! Last configuration change at 19:56:36 UTC Fri Aug 5 2011 by admin
! NVRAM config last updated at 19:36:52 UTC Fri Aug 5 2011 by admin
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_Test_IAD
!
boot-start-marker
boot system slot0:c2430-is-mz.124-12.bin
boot-end-marker
!
card type t1 1
logging buffered 409600 debugging
logging monitor informational
enable secret 5 $1$QqGH$yfvIhxYjO.gJdXHQi9iU0/
enable password xxxxxxxxxx
!
no aaa new-model
no network-clock-participate T1 1/0
!
!
ip name-server 999.999.3.65
ip name-server 999.999.2.65
!
!
!
voice-card 0
!
!
!
voice service voip
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711ulaw
modem passthrough nse codec g711ulaw redundancy maximum-sessions 5
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729br8
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /\+1\(.*\)/ /\1/
!
!
voice translation-profile Incoming_Calling_Party_Num
translate calling 1
!
!
username admin secret 5 $1$7Ral$9fHto9rOXB.Sd.L61Fzbo.
!
!
controller T1 1/0
framing esf
clock source internal
linecode b8zs
channel-group 1 timeslots 1-24
!
class-map match-any AutoQoS-VoIP-Remark
match ip dscp ef
match ip dscp cs3
match ip dscp af31
class-map match-any AutoQoS-VoIP-Control-UnTrust
match access-group name AutoQoS-VoIP-Control
class-map match-any AutoQoS-VoIP-RTP-UnTrust
match protocol rtp audio
match access-group name AutoQoS-VoIP-RTCP
!
!
policy-map AutoQoS-Policy-UnTrust
class AutoQoS-VoIP-RTP-UnTrust
priority percent 70
set precedence 4
class AutoQoS-VoIP-Control-UnTrust
bandwidth percent 5
set dscp af31
class AutoQoS-VoIP-Remark
set dscp default
class class-default
fair-queue
!
!
!
!
interface FastEthernet0/0
ip address 999.999.999.249 255.255.255.0
no ip route-cache
duplex full
speed 100
!
interface Serial1/0:1
no ip address
encapsulation ppp
auto qos voip
service-policy output AutoQoS-Policy-UnTrust
!
ip default-gateway 999.999.999.1
ip http server
!
ip route 0.0.0.0 0.0.0.0 999.999.999.1
!
!
!
ip access-list extended AutoQoS-VoIP-Control
permit tcp any any eq 1720
permit tcp any any range 11000 11999
permit udp any any eq 2427
permit tcp any any eq 2428
permit tcp any any range 2000 2002
permit udp any any eq 1719
permit udp any any eq 5060
ip access-list extended AutoQoS-VoIP-RTCP
permit udp any any range 16384 32767
dialer-list 1 protocol ip permit
snmp-server community S1mpl3RO RO
snmp-server host 999.999.999.999 version 2c S1mpl3RO
!
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.1081.1083 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
!
voice-port 2/0
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/1
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/2
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/3
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/4
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/5
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/6
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/7
input gain 2
no vad
timeouts initial 20
timeouts interdigit 3
impedance 900r
description Fax Configuration
caller-id alerting ring 4
!
!
!
!
dial-peer voice 111 pots
destination-pattern 5025551212
progress_ind alert enable 8
fax rate fax
port 2/0
authentication username 5025551212 password 01465656095F5259771A18
!
dial-peer voice 100 voip
translation-profile incoming Incoming_Calling_Party_Num
destination-pattern .T
voice-class codec 1
session protocol sipv2
session target ipv4:999.999.999.999
dtmf-relay rtp-nte
playout-delay minimum low
no vad
!
sip-ua
set pstn-cause 3 sip-status 486
registrar ipv4:999.999.999.999 expires 3600
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxxxx
login local
length 0
!
ntp clock-period 17180014
ntp server 129.6.15.29
ntp server 24.56.178.140
end
Thanks in advance
To error is human.....if the machine doesnt work, then KICK IT !!!!!!!!!!!!!
Lab_Test_IAD#sho run
Building configuration...
Current configuration : 4325 bytes
!
! Last configuration change at 19:56:36 UTC Fri Aug 5 2011 by admin
! NVRAM config last updated at 19:36:52 UTC Fri Aug 5 2011 by admin
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_Test_IAD
!
boot-start-marker
boot system slot0:c2430-is-mz.124-12.bin
boot-end-marker
!
card type t1 1
logging buffered 409600 debugging
logging monitor informational
enable secret 5 $1$QqGH$yfvIhxYjO.gJdXHQi9iU0/
enable password xxxxxxxxxx
!
no aaa new-model
no network-clock-participate T1 1/0
!
!
ip name-server 999.999.3.65
ip name-server 999.999.2.65
!
!
!
voice-card 0
!
!
!
voice service voip
fax protocol t38 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711ulaw
modem passthrough nse codec g711ulaw redundancy maximum-sessions 5
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729br8
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /\+1\(.*\)/ /\1/
!
!
voice translation-profile Incoming_Calling_Party_Num
translate calling 1
!
!
username admin secret 5 $1$7Ral$9fHto9rOXB.Sd.L61Fzbo.
!
!
controller T1 1/0
framing esf
clock source internal
linecode b8zs
channel-group 1 timeslots 1-24
!
class-map match-any AutoQoS-VoIP-Remark
match ip dscp ef
match ip dscp cs3
match ip dscp af31
class-map match-any AutoQoS-VoIP-Control-UnTrust
match access-group name AutoQoS-VoIP-Control
class-map match-any AutoQoS-VoIP-RTP-UnTrust
match protocol rtp audio
match access-group name AutoQoS-VoIP-RTCP
!
!
policy-map AutoQoS-Policy-UnTrust
class AutoQoS-VoIP-RTP-UnTrust
priority percent 70
set precedence 4
class AutoQoS-VoIP-Control-UnTrust
bandwidth percent 5
set dscp af31
class AutoQoS-VoIP-Remark
set dscp default
class class-default
fair-queue
!
!
!
!
interface FastEthernet0/0
ip address 999.999.999.249 255.255.255.0
no ip route-cache
duplex full
speed 100
!
interface Serial1/0:1
no ip address
encapsulation ppp
auto qos voip
service-policy output AutoQoS-Policy-UnTrust
!
ip default-gateway 999.999.999.1
ip http server
!
ip route 0.0.0.0 0.0.0.0 999.999.999.1
!
!
!
ip access-list extended AutoQoS-VoIP-Control
permit tcp any any eq 1720
permit tcp any any range 11000 11999
permit udp any any eq 2427
permit tcp any any eq 2428
permit tcp any any range 2000 2002
permit udp any any eq 1719
permit udp any any eq 5060
ip access-list extended AutoQoS-VoIP-RTCP
permit udp any any range 16384 32767
dialer-list 1 protocol ip permit
snmp-server community S1mpl3RO RO
snmp-server host 999.999.999.999 version 2c S1mpl3RO
!
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.1081.1083 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
!
voice-port 2/0
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/1
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/2
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/3
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/4
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/5
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/6
no vad
timeouts initial 20
timeouts interdigit 3
caller-id alerting ring 4
!
voice-port 2/7
input gain 2
no vad
timeouts initial 20
timeouts interdigit 3
impedance 900r
description Fax Configuration
caller-id alerting ring 4
!
!
!
!
dial-peer voice 111 pots
destination-pattern 5025551212
progress_ind alert enable 8
fax rate fax
port 2/0
authentication username 5025551212 password 01465656095F5259771A18
!
dial-peer voice 100 voip
translation-profile incoming Incoming_Calling_Party_Num
destination-pattern .T
voice-class codec 1
session protocol sipv2
session target ipv4:999.999.999.999
dtmf-relay rtp-nte
playout-delay minimum low
no vad
!
sip-ua
set pstn-cause 3 sip-status 486
registrar ipv4:999.999.999.999 expires 3600
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxxxx
login local
length 0
!
ntp clock-period 17180014
ntp server 129.6.15.29
ntp server 24.56.178.140
end
Thanks in advance
To error is human.....if the machine doesnt work, then KICK IT !!!!!!!!!!!!!