Hi All,
i have a range of internet ip address given by ISP (x.x.x.1 to x.x.x.31), i use the subnet 255.255.255.128 to mypix1 (use nat) outside interface.
now i have myPIX2 (no nat, VPN IPSEC site to site with 3rd party network), the outside interface should be attach to the same network as mypix1's outside interface.
so i divide the subnet for myPix2 into 2:
255.255.255.128 outside
255.255.255.252 inside:
subnet:x.x.x.28
webserverX: x.x.x.29
inside interface: x.x.x.30
broadcast: x.x.x.31
the result:
webserverX can access other boxes via IPSEC VPN...
but none of hosts inside myPix1, and hosts outside myPix1 and myPix2 could accesss webserverX.
Need your help guys, to identified the problem:
1. does the problem cause by subnet overlap that has been defined in mypix2 ? if yes how to resolve this ? do i need new ip range ?
2. or if this problems cause by the VPN IPSEC Tunnel ?, can i use the same interface being used for VPN Tunnel as the proxy for webserver ?
3. or it is simple command issues ?
thanks heaps for your suggestion.
below the config file:
: Saved
:
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password .... encrypted
passwd ..... encrypted
hostname mypix2
domain-name xxxxxx
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name ....
name .....
name ....
access-list acl-out permit icmp x.x.x.x 255.255.255.0 any echo-reply
access-list acl-out permit icmp x.x.x.x 255.255.255.0 any echo
access-list acl-out permit icmp x.x.x.x 255.255.255.0 any unreachable
access-list acl-out permit tcp any host b-ext eq https
access-list acl-out permit tcp any host b-ext eq www
access-list acl-out permit ip host b1 host boi-ext
access-list acl-out permit ip host b2 host boi-ext
access-list acl-out permit ip host b3 host boi-ext
access-list acl-out permit ip host b5 host boi-ext
access-list outside_cryptomap_20 permit ip any host bnz1
access-list outside_cryptomap_20 permit ip any host bnz2
access-list outside_cryptomap_20 permit ip any host bnz3
access-list outside_cryptomap_20 permit ip any host bnz5
access-list acl-in permit tcp host b-ext eq 1997 bnz-net 255.255.255.0 log
access-list acl-in permit icmp host b-ext bnz-net 255.255.255.0 log
access-list acl-in permit ip host b-ext bnz-net 255.255.255.0
access-list acl-in permit tcp host b-ext host x.x.x.27 eq smtp
pager lines 24
logging on
logging timestamp
logging trap warnings
logging history warnings
logging host outside x.x.x.x 17/1470
no logging message 111001
icmp permit x.x.x.x 255.255.255.128 outside
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.12 255.255.255.128
ip address inside x.x.x.30 255.255.255.252
ip audit info action alarm
ip audit attack action alarm
no pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 0.0.0.0 0.0.0.0 0 0
static (inside,outside) b-ext b-ext netmask 255.255.255.255 0 0
access-group acl-out in interface outside
access-group acl-in in interface inside
route outside 0.0.0.0 0.0.0.0 x.x.x.62 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer x.x.x.x
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ***** address x.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh x.x.x.x 255.255.255.255 outside
ssh x.x.x.x 255.255.255.128 outside
ssh timeout 60
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:28ca87518d5910aaf50c0b82842c0a8e
: end
i have a range of internet ip address given by ISP (x.x.x.1 to x.x.x.31), i use the subnet 255.255.255.128 to mypix1 (use nat) outside interface.
now i have myPIX2 (no nat, VPN IPSEC site to site with 3rd party network), the outside interface should be attach to the same network as mypix1's outside interface.
so i divide the subnet for myPix2 into 2:
255.255.255.128 outside
255.255.255.252 inside:
subnet:x.x.x.28
webserverX: x.x.x.29
inside interface: x.x.x.30
broadcast: x.x.x.31
the result:
webserverX can access other boxes via IPSEC VPN...
but none of hosts inside myPix1, and hosts outside myPix1 and myPix2 could accesss webserverX.
Need your help guys, to identified the problem:
1. does the problem cause by subnet overlap that has been defined in mypix2 ? if yes how to resolve this ? do i need new ip range ?
2. or if this problems cause by the VPN IPSEC Tunnel ?, can i use the same interface being used for VPN Tunnel as the proxy for webserver ?
3. or it is simple command issues ?
thanks heaps for your suggestion.
below the config file:
: Saved
:
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password .... encrypted
passwd ..... encrypted
hostname mypix2
domain-name xxxxxx
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name ....
name .....
name ....
access-list acl-out permit icmp x.x.x.x 255.255.255.0 any echo-reply
access-list acl-out permit icmp x.x.x.x 255.255.255.0 any echo
access-list acl-out permit icmp x.x.x.x 255.255.255.0 any unreachable
access-list acl-out permit tcp any host b-ext eq https
access-list acl-out permit tcp any host b-ext eq www
access-list acl-out permit ip host b1 host boi-ext
access-list acl-out permit ip host b2 host boi-ext
access-list acl-out permit ip host b3 host boi-ext
access-list acl-out permit ip host b5 host boi-ext
access-list outside_cryptomap_20 permit ip any host bnz1
access-list outside_cryptomap_20 permit ip any host bnz2
access-list outside_cryptomap_20 permit ip any host bnz3
access-list outside_cryptomap_20 permit ip any host bnz5
access-list acl-in permit tcp host b-ext eq 1997 bnz-net 255.255.255.0 log
access-list acl-in permit icmp host b-ext bnz-net 255.255.255.0 log
access-list acl-in permit ip host b-ext bnz-net 255.255.255.0
access-list acl-in permit tcp host b-ext host x.x.x.27 eq smtp
pager lines 24
logging on
logging timestamp
logging trap warnings
logging history warnings
logging host outside x.x.x.x 17/1470
no logging message 111001
icmp permit x.x.x.x 255.255.255.128 outside
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.12 255.255.255.128
ip address inside x.x.x.30 255.255.255.252
ip audit info action alarm
ip audit attack action alarm
no pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 0.0.0.0 0.0.0.0 0 0
static (inside,outside) b-ext b-ext netmask 255.255.255.255 0 0
access-group acl-out in interface outside
access-group acl-in in interface inside
route outside 0.0.0.0 0.0.0.0 x.x.x.62 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer x.x.x.x
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ***** address x.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh x.x.x.x 255.255.255.255 outside
ssh x.x.x.x 255.255.255.128 outside
ssh timeout 60
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:28ca87518d5910aaf50c0b82842c0a8e
: end