Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations IamaSherpa on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Static routes betwen 3 Cisco 1720 routers over frame relay

Status
Not open for further replies.

r00tcanal

Technical User
Apr 4, 2001
6
CA
Hello,

I'm brand new to Cisco routers, and am working on configuring 3 1720 series routers over frame relay. I have (what I think) is a simple static routing question.

The scenario:

Router_1
interface FastEthernet0
ip address 192.168.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.200.1 255.255.255.0
encapsulation frame-relay ietf
frame-relay map ip 192.168.200.2 18
frame-relay map ip 192.168.200.3 17
frame-relay lmi-type cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.200.2
ip route 192.168.200.2 255.255.255.255 Serial0

This segment has ADSL coming into a 3COM firewall/NAT on 192.168.1.254, also DHCP and domain controller (for LAN only).

Router_2
interface FastEthernet0
ip address 192.168.0.1 255.255.255.0
!
interface Serial0
ip address 192.168.200.2 255.255.255.0
encapsulation frame-relay ietf
frame-relay map ip 192.168.200.1 16
frame-relay map ip 192.168.200.3 17
frame-relay lmi-type cisco
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.200.1
ip route 192.168.2.0 255.255.255.0 192.168.200.3
ip route 192.168.200.1 255.255.255.255 Serial0
ip route 192.168.200.3 255.255.255.255 Serial0

This segment has LAN and WAN services ie. mail, file/print also domain controller and DHCP for LAN only.

Router_3
interface FastEthernet0
ip address 192.168.2.1 255.255.255.0
!
interface Serial0
ip address 192.168.200.3 255.255.255.0
encapsulation frame-relay ietf
frame-relay map ip 192.168.200.1 16
frame-relay map ip 192.168.200.2 18
frame-relay lmi-type cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.200.2
ip route 192.168.200.2 255.255.255.255 Serial0

This segment is a small LAN w/DHCP and domain controller for LAN only.

Based on the routes above I know there is something wrong, I just don't know what. I can't determine how Internet bound traffic should be routed to the firewall. I've thought of things like ip route 0.0.0.0 0.0.0.0 192.168.1.254, but can I use this AFTER all the other routes? Does the router use the order in which the routes are entered as a guide or should I identify a metric?

Argh! Very frustrating! The kicker is that these units must be pre-configured for VERY remote sites.

Any comments and/or advice on the above configs would be greatly appreciated. If I've left any important info out, let me know and I'll include it.

Thanks,
Jeff
 
First of all, you need a routing protocol (RIP, EIGRP etc.)

I recommend RIP because it's easy to configure. In global config. mode:

router rip
network 192.168.0.0

Secondly, you must remove the static route for 0.0.0.0 (no ip route 0.0.0.0 etc.) and add one for the route to the Internet (ip route 0.0.0.0 0.0.0.0 192.168.1.254)

Lastly, I don't think you need the static routes to the serial0 interface, but if you use it, I recommend that you use (ip route 192.168.200.0 255.255.255.0 serial0) instead.

A good idea when you are configuring routers for a remote location is to setup and test a modem connected to the AUX port of the routers and send the modems with the routers. That way you'll be able to dial-in & modify the configs if something goes wrong. I always send my own pre-tested modems because I know they'll work - Cisco routers don't work with every modem (which I found out the hard way B-) )
 
Whoaa here.. You not "need" a routing protocol for routers to work. I know of many simple sites where it's all static mapped and works just fine. And for the small network I see in this config, statics are fine assuming they want to maintain them. RIP is not an optimal choice if you take the large picture and think about it. If you need to talk routes with any outside group like an ISP, then OSPF is preferred as it's an open protocol and very tuneable unlike RIP. If the network is not to share routing info then either OSPF or EIGRP will work just fine and EIRGP is arguable the easier of the two two configure. My personal choice would OSPF only because I like the open standard and the other fact of it forcing you to use IP only on the backbone. If you must route something like IPX, then EIGRP is the routing protocol for you.

If you decide to go to the big time then your protocol of choice might be BPG but that exceeds what many people really want to do on their network. It's normally used at sites that have their own internet presence and name servers.

The IP ROUTE 0.0.0. 0.0.0.0 something will be the default route for anything the router does not have either an explicd route for or a "learned" route. I have configured stub routers with nothing but that and it works fine.

I agree to remove the "ip route 0.0.0.0 0.0.0.0 192.168.200.2" and replace it with a new one pointing to the internet hop. This says that if I, the router, do not know where this subnet is, then send it to the next hop which would be the internet connection.

I would also strong suggest to tighten up the subnet mask on the serial links to limit who can get on that link. Normally I would go point to point with the frame and run a 255.255.255.252 mask which says only 2 hosts on the link.. one for each serial port and thats it. Just an idea.

The modem on the AUX port is a very good idea and I wish more used it. It would save a trip or two many times.

Mike S
"Diplomacy; the art of saying 'nice doggie' till you can find a rock" Wynn Catlin
 
I'll admit I only scanned the above posts...

If you are going 3 routers over frame relay, use RIP. Simple and easy. OSPF is for HUGE networks to limit boradcast domains and reduce overhead with routing table updates, but we are only talking about 3 routers here.

Static routing will work, can work but it's a pain in the butt if something goes down or you want to add new sites in the future.

KISS = Keep it simple stupid! If you are new to setting it up, go with the easy solution!

AidanEnos
 
Many thanks for the responses! A couple more things:

These units are on 128k link. Add MS Win2000 chatter, Exhcange2000 chatter and possibly citrix, and man there will be a traffic jam. Even RIP will consume modest bandwidth, and this is a small network, so I think static is a good way to go.

Nonetheless, taking into account the info above (once again thanks for the advice), does this seem reasonable?

Router_1

ip route 192.168.0.0 255.255.255.0 192.168.200.2; Router_2 LAN bound traffic
ip route 192.168.2.0 255.255.255.0 192.168.200.2; Router_3 LAN bound traffic
ip route 192.168.200.0 255.255.255.248 Serial0; WAN router traffic
ip route 0.0.0.0 0.0.0.0 192.168.1.254; Internet bound traffic

Router_2

ip route 192.168.1.0 255.255.255.0 192.168.200.1; Router_1 LAN bound traffic
ip route 192.168.2.0 255.255.255.0 192.168.200.3; Router_3 LAN bound traffic
ip route 192.168.200.0 255.255.255.248 Serial0; WAN router traffic
ip route 0.0.0.0 0.0.0.0 192.168.1.254; Internet bound traffic

Router_3

ip route 192.168.0.0 255.255.255.0 192.168.200.2; Router_2 LAN bound traffic
ip route 192.168.1.0 255.255.255.0 192.168.200.2; Router_1 LAN bound traffic
ip route 192.168.200.0 255.255.255.248 Serial0; WAN router traffic
ip route 0.0.0.0 0.0.0.0 192.168.1.254; Internet bound traffic

Last can you recommend a modem? I've got some antique USR Courier v.34 modems.

Thanks again for the help!

-Jeff



 
Huge networks? OSPF? say it aint so ;-) I dunno about that, I run OSPF on a small network of 10 routers because they are always changing things around. THe hellos are every 10 second and route updates as needed. RIP is every 30 seconds and the entire route table is broadcast whether it's needed or not. It also gets very messy when running sub-interfaces which is part of Cisco's best practices for deploying frame relay. Right now I'm working a network that has over 300 routers running RIP and it's an unholy mess. We are converting them to EIGRP and IPX EIGRP to dump RIP as much as we can within a Novell world.

Yes it's three routers now.. what about 1, 2 or 5 years from now? What if the boss decides to bring a different brand of router/switch. While many vendors will support RIP in a pinch, they would much rather see you use OSPF in order to pass route tables back and forth. A good case study was a hospital I was at where the 7507 uses OSPF to pass it's route table over the 3com layer 3 3500 switch.

So I guess the upshot of all this writing is that I repectfully disagree with the statement that OSPF is only for large networks. It's for any network that has the business and technical requirements that demand it. As does RIP, EIGRP, IRGP, BGP, IS-IS etc...etc...

And a excellent point was made that on a low speed link, route updates do matter.. alot.

I happen use some old US Robotics..28.8 modems... as speed is not a real issue and I have found that the older modems with the "old" switch settings work pretty well. I expect there are others that work fine but that is what I have.

Mike S
"Diplomacy; the art of saying 'nice doggie' till you can find a rock" Wynn Catlin
 
hi!

i am seeking information on static and dynamic routers. i shall obligue if you could please help me in this regard.

thanks
pranav
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top