Hi,
i have to set up site to site with one side have dynamic ip.
i have this config that works great for site to site with static ip. what can i change to get it to work for dynamic setup?
access-list 100 extended permit ip 192.168.1.0 255.255.255.0 192.168.4.0 255.255.255.0
!
access-list nonat extended permit ip 192.168.1.0 255.255.255.0 192.168.4.0 255.255.255.0
!
nat-control
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 192.168.1.0 255.255.255.0
!
sysopt connection permit-ipsec
!
crypto isakmp enable outside
crypto isakmp identity address
crypto isakmp policy 11 hash md5
crypto isakmp policy 11 authentication pre-share
crypto isakmp policy 11 encryption 3des
crypto isakmp policy 11 group 2
crypto isakmp policy 11 lifetime 86400
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto ipsec df-bit clear-df outside
!
crypto map boras 1 match address 100
crypto map boras 1 set pfs group2
crypto map boras 1 set peer *.*.*.*
crypto map boras 1 set transform-set myset
crypto map boras interface outside
!
tunnel-group remotesite type ipsec-l2l
tunnel-group remotesite ipsec-attributes
pre-shared-key my_key
isakmp keepalive threshold 10 retry 2
!
//:EkkE
i have to set up site to site with one side have dynamic ip.
i have this config that works great for site to site with static ip. what can i change to get it to work for dynamic setup?
access-list 100 extended permit ip 192.168.1.0 255.255.255.0 192.168.4.0 255.255.255.0
!
access-list nonat extended permit ip 192.168.1.0 255.255.255.0 192.168.4.0 255.255.255.0
!
nat-control
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 192.168.1.0 255.255.255.0
!
sysopt connection permit-ipsec
!
crypto isakmp enable outside
crypto isakmp identity address
crypto isakmp policy 11 hash md5
crypto isakmp policy 11 authentication pre-share
crypto isakmp policy 11 encryption 3des
crypto isakmp policy 11 group 2
crypto isakmp policy 11 lifetime 86400
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto ipsec df-bit clear-df outside
!
crypto map boras 1 match address 100
crypto map boras 1 set pfs group2
crypto map boras 1 set peer *.*.*.*
crypto map boras 1 set transform-set myset
crypto map boras interface outside
!
tunnel-group remotesite type ipsec-l2l
tunnel-group remotesite ipsec-attributes
pre-shared-key my_key
isakmp keepalive threshold 10 retry 2
!
//:EkkE