I am trying to set up a Cisco 2811 as a voice gateway with a VWIC2-1MFT-T1/E1 and Verizon PRI. I believe the PRI is actually syncing with the router but I cannot get the gateway to register with CallManager 4.1(3)sr3c. I have entered only a basic config as I am new to this. Here is the router config:
Building configuration...
Current configuration : 1509 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PD_2811
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
!
!
ip domain name Building configuration...
Current configuration : 1509 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811-PD
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
!
!
ip domain name GTOWN-PD-2811
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0/0
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 10.10.11.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
ccm-manager redundant-host 10.10.210.12
ccm-manager mgcp
ccm-manager config server 10.10.210.11
ccm-manager config
!
mgcp
mgcp call-agent 10.10.210.11 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
!
!
dial-peer voice 999000 pots
service mgcp
destination-pattern 9T
incoming called-number ....
direct-inward-dial
port 0/0/0:23
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0/0
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 10.10.11.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
ccm-manager redundant-host 10.10.210.12
ccm-manager mgcp
ccm-manager config server 10.10.210.11
ccm-manager config
!
mgcp
mgcp call-agent 10.10.210.11 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
!
!
dial-peer voice 999000 pots
service mgcp
destination-pattern 9T
incoming called-number ....
direct-inward-dial
port 0/0/0:23
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
I have the CallManager configured:
Product: Cisco 2811
Protocol: MGCP
MGCP: GTOWN-PD-2811
Domain Name: GTOWN-PD-2811
Description: PD PSTN
Cisco Callmanager Group: CMG
Module in Slot 0: NM-VWIC-MBRD
Subunit 0: VWIC2-1MFT-T1/E1-T1 0/0/0
Global ISDN Switch Type: NI2
Switchback Timing: Graceful
Switchback Uptime-delay: 10
Switchback schedule: 12:00
Endpoint Configuration:
Product: Cisco 2811
Gateway: S0/SU0/DS1-0@GTOWN-PD-2811
Device Protocol: Digital Access PRI
Registration: Unknown
IP Address:
Endpoint name:S0/SU0/DS1-0@GTOWN-PD-2811
I think everything else on this page is just pertaining to the PRI and not necessarily to the registration with Call Manager. If you need more info please tell me and I will be glad to post it. Please tell me what I am doing wrong. Like I said before I am new to this so any tips or hints would be greatly appreciated.
Thanks,
Chad
Building configuration...
Current configuration : 1509 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PD_2811
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
!
!
ip domain name Building configuration...
Current configuration : 1509 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811-PD
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
!
!
ip domain name GTOWN-PD-2811
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0/0
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 10.10.11.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
ccm-manager redundant-host 10.10.210.12
ccm-manager mgcp
ccm-manager config server 10.10.210.11
ccm-manager config
!
mgcp
mgcp call-agent 10.10.210.11 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
!
!
dial-peer voice 999000 pots
service mgcp
destination-pattern 9T
incoming called-number ....
direct-inward-dial
port 0/0/0:23
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0/0
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 10.10.11.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
ccm-manager redundant-host 10.10.210.12
ccm-manager mgcp
ccm-manager config server 10.10.210.11
ccm-manager config
!
mgcp
mgcp call-agent 10.10.210.11 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
!
!
dial-peer voice 999000 pots
service mgcp
destination-pattern 9T
incoming called-number ....
direct-inward-dial
port 0/0/0:23
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
I have the CallManager configured:
Product: Cisco 2811
Protocol: MGCP
MGCP: GTOWN-PD-2811
Domain Name: GTOWN-PD-2811
Description: PD PSTN
Cisco Callmanager Group: CMG
Module in Slot 0: NM-VWIC-MBRD
Subunit 0: VWIC2-1MFT-T1/E1-T1 0/0/0
Global ISDN Switch Type: NI2
Switchback Timing: Graceful
Switchback Uptime-delay: 10
Switchback schedule: 12:00
Endpoint Configuration:
Product: Cisco 2811
Gateway: S0/SU0/DS1-0@GTOWN-PD-2811
Device Protocol: Digital Access PRI
Registration: Unknown
IP Address:
Endpoint name:S0/SU0/DS1-0@GTOWN-PD-2811
I think everything else on this page is just pertaining to the PRI and not necessarily to the registration with Call Manager. If you need more info please tell me and I will be glad to post it. Please tell me what I am doing wrong. Like I said before I am new to this so any tips or hints would be greatly appreciated.
Thanks,
Chad