vdalehubbard
IS-IT--Management
I have two DSL lines coming into a 2811 router. Due to helping out with bandwidth, I need to seperate groups of internel IP addresses and assign them to different gateways (DSL lines). I want to ask what commands I need to use to do this. Here is my configuration on the router:
!version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ***
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
username *** privilege 15 password 0 ***
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address **.**.**.*21 255.255.255.240
ip nat outside
load-interval 30
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.1.2 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/0/0
no ip address
!
interface FastEthernet0/0/1
no ip address
shutdown
!
interface FastEthernet0/0/2
no ip address
shutdown
!
interface FastEthernet0/0/3
no ip address
shutdown
!
interface Vlan1
no ip address
ip nat outside
!
ip classless
ip route 0.0.0.0 0.0.0.0 **.**.**.*22
ip route 0.0.0.0 0.0.0.0 **.**.**.*09
ip http server
ip http authentication local
ip nat pool overload **.**.**.*14 **.**.**.*15 netmask 255.255.255.240
ip nat inside source list 7 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.3 20 **.**.**.*10 20 extendable
ip nat inside source static tcp 192.168.1.3 21 **.**.**.*10 21 extendable
ip nat inside source static tcp 192.168.1.3 25 **.**.**.*10 25 extendable
ip nat inside source static tcp 192.168.1.3 80 **.**.**.*10 80 extendable
ip nat inside source static tcp 192.168.1.1 3389 **.**.**.*11 3389 extendable
ip nat inside source static udp 192.168.1.1 3389 **.**.**.*11 3389 extendable
ip nat inside source static tcp 192.168.1.4 1723 **.**.**.*12 1723 extendable
ip nat inside source static tcp 192.168.1.4 3389 **.**.**.*12 3389 extendable
ip nat inside source static udp 192.168.1.4 3389 **.**.**.*12 3389 extendable
ip nat inside source static tcp 192.168.1.5 3389 **.**.**.*13 3389 extendable
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
I have the feeling it has to do with the ip route commands and changing them to reflect my internal ip ranges to what route I want. Any help is appricated.
!version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ***
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
username *** privilege 15 password 0 ***
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address **.**.**.*21 255.255.255.240
ip nat outside
load-interval 30
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.1.2 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/0/0
no ip address
!
interface FastEthernet0/0/1
no ip address
shutdown
!
interface FastEthernet0/0/2
no ip address
shutdown
!
interface FastEthernet0/0/3
no ip address
shutdown
!
interface Vlan1
no ip address
ip nat outside
!
ip classless
ip route 0.0.0.0 0.0.0.0 **.**.**.*22
ip route 0.0.0.0 0.0.0.0 **.**.**.*09
ip http server
ip http authentication local
ip nat pool overload **.**.**.*14 **.**.**.*15 netmask 255.255.255.240
ip nat inside source list 7 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.3 20 **.**.**.*10 20 extendable
ip nat inside source static tcp 192.168.1.3 21 **.**.**.*10 21 extendable
ip nat inside source static tcp 192.168.1.3 25 **.**.**.*10 25 extendable
ip nat inside source static tcp 192.168.1.3 80 **.**.**.*10 80 extendable
ip nat inside source static tcp 192.168.1.1 3389 **.**.**.*11 3389 extendable
ip nat inside source static udp 192.168.1.1 3389 **.**.**.*11 3389 extendable
ip nat inside source static tcp 192.168.1.4 1723 **.**.**.*12 1723 extendable
ip nat inside source static tcp 192.168.1.4 3389 **.**.**.*12 3389 extendable
ip nat inside source static udp 192.168.1.4 3389 **.**.**.*12 3389 extendable
ip nat inside source static tcp 192.168.1.5 3389 **.**.**.*13 3389 extendable
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
I have the feeling it has to do with the ip route commands and changing them to reflect my internal ip ranges to what route I want. Any help is appricated.