Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Mike Lewis on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

SDSL and Cisco 1803 1

Status
Not open for further replies.

adamc1115

IS-IT--Management
May 19, 2007
51
Anyone have any configs of this? I have an SDSL line and a cisco 1803, I've never configured DSL on a cisco router, any advice/samples?
 
Sure...this is my C837 at home...it should work, with your own parameters, of course. I also have mine configured as a vpn server as well...


!
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service sequence-numbers
!
hostname xxxxxx
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
security authentication failure rate 2 log
enable secret 5 $1$KXHn$yD2bAGGGeG.2KR6zX2oDf.
enable password xxxxxxxxxx
!
username xxxxxxxxxxx privilege 15 password xxxxxxxxxxxxxxxxxxxxxx
clock timezone CET 1
clock summer-time CST recurring last Sun Mar 2:00 last Sun Oct 3:00
clock save interval 8
aaa new-model
!
!
aaa authentication login my_vpn_xuath local
aaa authorization network my_vpn_group local
aaa session-id common
ip subnet-zero
no ip source-route
!
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool xxxxxxxxxxxx
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server x.x.x.x x.x.x.x
lease 7
!
!
ip cef
ip domain name local
ip name-server x.x.x.x
ip name-server x.x.x.x
no ip bootp server
ip ips notify SDEE
ip ips po max-events 100
ip ips name my_ips
login on-failure
no ftp-server write-enable
!
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp xauth timeout 15

!
crypto isakmp client configuration group xxxxxxxxxxxxx
key xxxxxxxxxxxxxxxxx
pool my_vpn_pool_1
max-users 2
netmask 255.0.0.0
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map vpn_dynamic_map_1 1
set transform-set ESP-3DES-SHA
reverse-route
!
!
crypto map CMAP_1 client authentication list my_vpn_xauth
crypto map CMAP_1 isakmp authorization list my_vpn_group
crypto map CMAP_1 client configuration address respond
crypto map CMAP_1 65535 ipsec-isakmp dynamic vpn_dynamic_map_1
!
!
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip nat inside
ip ips my_ips in
ip virtual-reassembly
hold-queue 100 out
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
no ip redirects
no ip unreachables
no ip proxy-arp
pvc 0/35
oam-pvc manage
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Virtual-Template1
no ip address
ip ips my_ips in
ip virtual-reassembly
!
interface Dialer0
no ip address
no cdp enable
!
interface Dialer1
description Connected to ADSL Circuit
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip ips my_ips in
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname xxxxxxxxxxxxxxx
ppp chap password xxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxxxxxxx password xxxxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request
crypto map CMAP_1
hold-queue 224 in
!
ip local pool my_vpn_pool_1 10.0.0.15 10.0.0.16
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
no ip http secure-server
!
ip nat inside source static tcp 10.0.0.69 21 interface Dialer1 21
ip nat inside source route-map stay_out_of_my_network interface Dialer1 overload
!
access-list 102 remark what???
access-list 102 deny ip any 10.0.0.0 0.0.0.31
access-list 102 permit ip 10.0.0.0 0.255.255.255 any
dialer-list 1 protocol ip permit
!
route-map stay_out_of_my_network permit 1
match ip address 102
!
!
control-plane
!
banner motd * _________-----_____
_____------ __ ----_
___---- ___------ \
----________ ---- \
-----__ | _____)
__- / \
_______----- ___-- \ /)\
------_______ ---____ \__/ /
-----__ \ -- _ /\
--__--__ \_____/ \_/\
----| / |
| |___________|
| | ((_(_)| )_)
| \_((_(_)|/(_)
\ (
\_____________)

!!!!!Uh oh...better turn back around there, boy...I log all hacking attempts!!!!!!

*
!
line con 0
exec-timeout 300 0
password xxxxxxxxxxxxxxxxx
logging synchronous
no modem enable
transport output telnet
stopbits 1
line aux 0
transport output telnet
stopbits 1
line vty 0 4
session-timeout 15 output
exec-timeout 300 0
password xxxxxxxxxxxxxxxxxxxxxxxxxxx
transport input telnet ssh
!
no scheduler max-task-time
scheduler interval 500
end

Burt
 
Oh, man---every time I copy and paste that config, the flaming skull gets goofed up...trust me---it looks pretty cool!lol

Burt
 
Thanks, but is that adsl or sdsl? I think they are different, sdsl using a controller card with an ATM sub interface..
 
This is straight out of working 1803 (IP address and passwords removed).


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 1803sdsl
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxx
enable password xxxxxxxxxxxxx
!
no aaa new-model
!
resource policy
!
no ip source-route
!
ip cef
!
!
!
!
!
!
!
controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto
!
!
!
!
!
interface FastEthernet0
ip address x.x.x.x 255.255.255.240
speed auto
half-duplex
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
shutdown
!
interface FastEthernet5
shutdown
!
interface FastEthernet6
shutdown
!
interface FastEthernet7
shutdown
!
interface FastEthernet8
shutdown
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Vlan1
no ip address
shutdown
!
interface Dialer1
ip unnumbered FastEthernet0
no ip proxy-arp
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname hostname.btclick.com
ppp chap password 0 chappassword
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxx
login
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top