Ok, I found a config to enable my 2611 to route the cable modem to my internal network.
Everything works, it gets the dhcp address, it assigns them.
But it doesnt route. I cant even ping outside addresses from the router.
Here is the config
-=-=-=-=-=--=-=-=-=-=-
! [---Begin Config---]
!
version 12.1
!
!
hostname PyroElectric
!
clock timezone MNT -7
ip subnet-zero
!
! Just point to your provider's name servers if you don't have local DNS:
!
ip name-server 24.71.223.144
ip name-server 24.71.223.145
!
! Use the router as a DHCP server:
! [--Begin DHCP server config--]
!
! Must do this if you are not logging conflicts:
!
no ip dhcp conflict logging
!
! Exclude a range for the router, print servers, etc.:
!
ip dhcp excluded-address 192.168.0.100 192.168.0.109
!
! Define the address pool & DHCP parameters for inside DHCP clients:
!
ip dhcp pool DHCP-Pool
network 192.168.0.0 255.255.255.0
domain-name PES
dns-server 24.71.223.144 24.71.223.145
default-router 192.168.0.1
!
! [--End DHCP server config--]
!
interface Ethernet0/0
description Outside Cable Line - Get DHCP Address
no shutdown
! mac-address 00A0.C9F1.A68E
ip address dhcp
ip nat outside
!
interface Ethernet0/1
no shutdown
description Inside interface - Assign DHCP Addresses
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
! [---End Config---]
Everything works, it gets the dhcp address, it assigns them.
But it doesnt route. I cant even ping outside addresses from the router.
Here is the config
-=-=-=-=-=--=-=-=-=-=-
! [---Begin Config---]
!
version 12.1
!
!
hostname PyroElectric
!
clock timezone MNT -7
ip subnet-zero
!
! Just point to your provider's name servers if you don't have local DNS:
!
ip name-server 24.71.223.144
ip name-server 24.71.223.145
!
! Use the router as a DHCP server:
! [--Begin DHCP server config--]
!
! Must do this if you are not logging conflicts:
!
no ip dhcp conflict logging
!
! Exclude a range for the router, print servers, etc.:
!
ip dhcp excluded-address 192.168.0.100 192.168.0.109
!
! Define the address pool & DHCP parameters for inside DHCP clients:
!
ip dhcp pool DHCP-Pool
network 192.168.0.0 255.255.255.0
domain-name PES
dns-server 24.71.223.144 24.71.223.145
default-router 192.168.0.1
!
! [--End DHCP server config--]
!
interface Ethernet0/0
description Outside Cable Line - Get DHCP Address
no shutdown
! mac-address 00A0.C9F1.A68E
ip address dhcp
ip nat outside
!
interface Ethernet0/1
no shutdown
description Inside interface - Assign DHCP Addresses
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
! [---End Config---]