Hello,
On remote site I have Cisco ASA 5505, on cental site I have Cisco 2811 router, site-to-site VPN tunnel working without problems. Internet access working on both sides.
How can I route some traffic (to public host on Internet) from a remote site through a site-to-site vpn ?
I tried add host Ip to protected network but it does not work (ACL 119 on central site and inside_nat0_outbound_1 on ASA).
ASA log (icmp and http traffic):
6 Feb 06 2012 06:25:59 302020 66.39.41.1 10.110.17.11 Built outbound ICMP connection for faddr public_host_IP/0 gaddr 10.110.17.11/512 laddr 10.110.17.11/512
6 Feb 06 2012 06:26:47 302021 66.39.41.1 10.110.17.11 Teardown ICMP connection for faddr public_host_IP/0 gaddr 10.110.17.11/512 laddr 10.110.17.11/512
6 Feb 07 2012 00:05:25 302013 public_host_IP 10.110.17.11 Built outbound TCP connection 278843 for outside
ublic_host_IP/80 (public_host_IP/80) to inside:10.110.17.11/3936 (10.110.17.11/3936)
6 Feb 07 2012 00:05:55 302014 public_host_IP 10.110.17.11 Teardown TCP connection 278843 for outside
ublic_host_IP/80 to inside:10.110.17.11/3936 duration 0:00:30 bytes 0 SYN Timeout
Cisco ASA 5505 on remote site :
Outside interface - ISP Internet
Inside interface - 10.110.17.1 (local lan. 10.110.17.0/24)
Central site :
FastEthernet0/0 - 10.110.0.1 (local lan 10.110.0.0/24)
FastEthernet0/1- ISP Internet
Cisco ASA configuration :
object-group network DM_INLINE_NETWORK_1
network-object 10.110.0.0 255.255.255.0
network-object host public_host_IP
access-list outside_1_cryptomap extended permit ip 10.110.17.0 255.255.255.0 object-group DM_INLINE_NETWORK_1
access-list inside_nat0_outbound_1 extended permit ip 10.110.17.0 255.255.255.0 10.110.0.0 255.255.255.0
access-list inside_nat0_outbound_1 extended permit ip 10.110.17.0 255.255.255.0 host public_host_IP
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 101 0.0.0.0 0.0.0.0
access-group 121 in interface inside
route outside 0.0.0.0 0.0.0.0 ISP_gateway_IP 1
Central site :
access-list 119 remark IPSec Rule
access-list 119 permit ip 10.110.0.0 0.0.0.255 10.110.17.0 0.0.0.255
access-list 119 permit ip host public_host_IP 10.110.17.0 0.0.0.255
crypto map SDM_CMAP_1 16 ipsec-isakmp
set peer remote_site_public_IP
set transform-set ESP-DES-SHA
match address 119
interface FastEthernet0/0
ip address 10.110.0.1 255.255.255.0
ip access-group 121 in
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
no mop enabled
!
interface FastEthernet0/1
ip address Public_IP
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache flow
no mop enabled
crypto map SDM_CMAP_1
route-map SDM_RMAP_1 permit 1
match ip address 101
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0/1 overload
route-map SDM_RMAP_1 permit 1
match ip address 101
access-list 101 deny ip 10.110.0.0 0.0.0.255 10.110.17.0 0.0.0.255
access-list 101 permit ip 10.110.0.0 0.0.0.255 any
Any help is much appreciated.
Thanks.
On remote site I have Cisco ASA 5505, on cental site I have Cisco 2811 router, site-to-site VPN tunnel working without problems. Internet access working on both sides.
How can I route some traffic (to public host on Internet) from a remote site through a site-to-site vpn ?
I tried add host Ip to protected network but it does not work (ACL 119 on central site and inside_nat0_outbound_1 on ASA).
ASA log (icmp and http traffic):
6 Feb 06 2012 06:25:59 302020 66.39.41.1 10.110.17.11 Built outbound ICMP connection for faddr public_host_IP/0 gaddr 10.110.17.11/512 laddr 10.110.17.11/512
6 Feb 06 2012 06:26:47 302021 66.39.41.1 10.110.17.11 Teardown ICMP connection for faddr public_host_IP/0 gaddr 10.110.17.11/512 laddr 10.110.17.11/512
6 Feb 07 2012 00:05:25 302013 public_host_IP 10.110.17.11 Built outbound TCP connection 278843 for outside
6 Feb 07 2012 00:05:55 302014 public_host_IP 10.110.17.11 Teardown TCP connection 278843 for outside
Cisco ASA 5505 on remote site :
Outside interface - ISP Internet
Inside interface - 10.110.17.1 (local lan. 10.110.17.0/24)
Central site :
FastEthernet0/0 - 10.110.0.1 (local lan 10.110.0.0/24)
FastEthernet0/1- ISP Internet
Cisco ASA configuration :
object-group network DM_INLINE_NETWORK_1
network-object 10.110.0.0 255.255.255.0
network-object host public_host_IP
access-list outside_1_cryptomap extended permit ip 10.110.17.0 255.255.255.0 object-group DM_INLINE_NETWORK_1
access-list inside_nat0_outbound_1 extended permit ip 10.110.17.0 255.255.255.0 10.110.0.0 255.255.255.0
access-list inside_nat0_outbound_1 extended permit ip 10.110.17.0 255.255.255.0 host public_host_IP
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 101 0.0.0.0 0.0.0.0
access-group 121 in interface inside
route outside 0.0.0.0 0.0.0.0 ISP_gateway_IP 1
Central site :
access-list 119 remark IPSec Rule
access-list 119 permit ip 10.110.0.0 0.0.0.255 10.110.17.0 0.0.0.255
access-list 119 permit ip host public_host_IP 10.110.17.0 0.0.0.255
crypto map SDM_CMAP_1 16 ipsec-isakmp
set peer remote_site_public_IP
set transform-set ESP-DES-SHA
match address 119
interface FastEthernet0/0
ip address 10.110.0.1 255.255.255.0
ip access-group 121 in
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
no mop enabled
!
interface FastEthernet0/1
ip address Public_IP
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache flow
no mop enabled
crypto map SDM_CMAP_1
route-map SDM_RMAP_1 permit 1
match ip address 101
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0/1 overload
route-map SDM_RMAP_1 permit 1
match ip address 101
access-list 101 deny ip 10.110.0.0 0.0.0.255 10.110.17.0 0.0.0.255
access-list 101 permit ip 10.110.0.0 0.0.0.255 any
Any help is much appreciated.
Thanks.