Hi,
I'm replacing an older Cisco Router which was being used for DHCP Pools, NAT, ACL in favor of Ubuntu Linux Server.
I've loaded the SW, started configuring, but had a few questions.
1) My Cisco DHCP Pools & Sub-Interfaces were setup due to Vlan traffic isolation per Client. On my Linux server, do I have to recreate the same sub-interfaces?
2) See Cisco configs below...Vlans/Interfaces = 500-999
ip dhcp pool vlan500
network 50.50.50.0 255.255.255.240
dns-server 10.15.12.100 10.10.1.10
default-router 50.50.50.1
domain-name abc.efg.com
lease 10
!
ip dhcp pool vlan501
network 50.50.50.16 255.255.255.240
dns-server 10.15.12.100 10.10.1.10
default-router 50.50.50.17
domain-name abc.efg.com
lease 10
!
interface GigabitEthernet5/0.500
encapsulation dot1Q 500
ip address 50.50.50.1 255.255.255.240
ip access-group 100 in
ip nat inside
!
interface GigabitEthernet5/0.501
encapsulation dot1Q 501
ip address 50.50.50.17 255.255.255.240
ip access-group 100 in
ip nat inside
!
3) See Ubuntu Linux configs below:
/etc/network# cat interfaces
ETH0.500
# The primary network interface
auto eth0
# iface eth0 inet dhcp
iface eth0 inet static
address 10.15.12.11
netmask 255.255.255.0
network 10.15.12.0
broadcast 10.15.12.255
gateway 10.15.12.1
auto eth0:500
iface eth0:500 inet static
address 10.115.50.1
netmask 255.255.255.240
network 10.115.50.0
broadcast 10.115.50.255
gateway 10.115.50.1
/etc/dhcp3# cat dhcpd.conf
# A slightly different configuration for an internal subnet.
subnet 10.115.0.0 netmask 255.255.255.240 {
range 10.115.50.2 10.115.50.14;
# option domain-name-servers ns1.internal.example.org;
option domain-name "dvlab.acterna.com";
option routers 10.115.1.1;
option broadcast-address 10.115.1.255;
default-lease-time 600;
max-lease-time 7200;
Thanks!
I'm replacing an older Cisco Router which was being used for DHCP Pools, NAT, ACL in favor of Ubuntu Linux Server.
I've loaded the SW, started configuring, but had a few questions.
1) My Cisco DHCP Pools & Sub-Interfaces were setup due to Vlan traffic isolation per Client. On my Linux server, do I have to recreate the same sub-interfaces?
2) See Cisco configs below...Vlans/Interfaces = 500-999
ip dhcp pool vlan500
network 50.50.50.0 255.255.255.240
dns-server 10.15.12.100 10.10.1.10
default-router 50.50.50.1
domain-name abc.efg.com
lease 10
!
ip dhcp pool vlan501
network 50.50.50.16 255.255.255.240
dns-server 10.15.12.100 10.10.1.10
default-router 50.50.50.17
domain-name abc.efg.com
lease 10
!
interface GigabitEthernet5/0.500
encapsulation dot1Q 500
ip address 50.50.50.1 255.255.255.240
ip access-group 100 in
ip nat inside
!
interface GigabitEthernet5/0.501
encapsulation dot1Q 501
ip address 50.50.50.17 255.255.255.240
ip access-group 100 in
ip nat inside
!
3) See Ubuntu Linux configs below:
/etc/network# cat interfaces
ETH0.500
# The primary network interface
auto eth0
# iface eth0 inet dhcp
iface eth0 inet static
address 10.15.12.11
netmask 255.255.255.0
network 10.15.12.0
broadcast 10.15.12.255
gateway 10.15.12.1
auto eth0:500
iface eth0:500 inet static
address 10.115.50.1
netmask 255.255.255.240
network 10.115.50.0
broadcast 10.115.50.255
gateway 10.115.50.1
/etc/dhcp3# cat dhcpd.conf
# A slightly different configuration for an internal subnet.
subnet 10.115.0.0 netmask 255.255.255.240 {
range 10.115.50.2 10.115.50.14;
# option domain-name-servers ns1.internal.example.org;
option domain-name "dvlab.acterna.com";
option routers 10.115.1.1;
option broadcast-address 10.115.1.255;
default-lease-time 600;
max-lease-time 7200;
Thanks!