I have a question regarding the network which is attached. I have IBGP running as my core routing protocol
and EIGRP for my remote site. I am advertising 192.168.5.0/24 via EIGRP which is redistributed into IBGP.
192.168.200.0/26 is also being redistributed into EIGRP. My problem is EIGRP is injecting 192.168.200.0/26
into IBGP again. I know i have to use filters for this subnet for it not to get injected into IBGP. But my
question is how? Meaning should i use distribute list or route map on both RTRB and RTRC to filter the
subnet? I want to filter the subnet based on how the majority of the networking industry would do it
(Real life scenarios). Im also seeing routing feedback since my EIGRP peering from RRTR to both RTRB keeps
on flapping.
Any advice on how fix these problems?
Thanks
Here are the configs:
RTRA
!
router bgp 6500
no synchronization
bgp log-neighbor-changes
network 192.168.200.0 mask 255.255.255.192
neighbor 10.100.0.2 remote-as 6500
neighbor 10.100.0.6 remote-as 6500
no auto-summary
!
ip classless
RTRB:
!
router eigrp 10000
redistribute bgp 6500
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.5.5.0 0.0.0.3
network 10.100.0.0 0.0.0.255
default-metric 1000 100 250 100 1500
no auto-summary
!
router bgp 6500
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
redistribute eigrp 10000
neighbor 10.100.0.1 remote-as 6500
neighbor 10.100.0.10 remote-as 6500
no auto-summary
!
ip classless
RTRC:
!
router eigrp 10000
redistribute bgp 6500
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.5.6.0 0.0.0.3
network 10.100.0.0 0.0.0.255
default-metric 1000 100 250 100 1500
no auto-summary
!
router bgp 6500
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
redistribute eigrp 10000
neighbor 10.100.0.5 remote-as 6500
neighbor 10.100.0.9 remote-as 6500
no auto-summary
!
ip classless
RRTR:
!
router eigrp 10000
network 10.5.5.0 0.0.0.255
network 10.5.6.0 0.0.0.255
network 192.168.5.0
no auto-summary
!