Guys I am going to be sitting the ICND here pretty soon and was running through some exam sims and ran into a problem configuring ospf. I finally got it but my question is will any of the ways that the Sybex book by Todd Lammle explained on how to configure ospf work on the ICND? For example routerA E0: 192.168.33.1 /24, S0: 192.168.100.5/30. When asked to configure ospf on this router I would just do router ospf 1, network 192.168.33.1 0.0.0.0 area 0, and network 192.168.100.5 0.0.0.0 area 0 for the other, or I would have done 192.168.33.0 0.0.0.255 area 0,and 192.168.100.0 0.0.0.255 area 0. Both of these were in the Lammle book and I remember that the book said that the 0.0.0.255 or 0.0.0.0 wild card would be fine. I am enclosing a router console sim I did and you will see that when I ran the 0.0.0.255 wild card the route table would not populate but when I changed it to match the way ospf was configured on the others it worked fine. Is it just this sim or will the ICND sim be picky and want it configured the same way as the others to keep consistent? Maybe it is just my anxiety. Sorry if it is too long. Here is the config:
Alpha>en
Password:xxxx
Alpha#sh run
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Alpha
!
!
enable password how2pass
!
ip subnet-zero
!
!
interface Ethernet0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
!
interface Serail0
ip address 192.168.100.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 192.168.100.4 0.0.0.255 area 1 (this was the problem)
network 192.168.33.0 0.0.0.255 area 0
!
!
no ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Alpha#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
Alpha#config t
Enter configuration commands, one per line. End with CNTL/Z.
Alpha(config)#no router ospf 1 (removed ospf config)
Alpha(config)#router ospf 1
% Invalid input detected.
Alpha(config)#router ospf 1
Alpha(config-router)#network 192.168.33.0 0.0.0.255 area 0 (can do it like this or full ip followed with all 0's area 0 in Sybex)
Alpha(config-router)#network 192.168.100.0 0.0.0.255 area 0 (same here)
Alpha(config-router)#exit
Alpha(config)#exit
Alpha#sh run
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Alpha
!
!
enable password how2pass
!
ip subnet-zero
!
!
interface Ethernet0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
!
interface Serail0
ip address 192.168.100.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 192.168.33.0 0.0.0.255 area 0 (now in correct ospf area)
network 192.168.100.0 0.0.0.255 area 0
!
!
no ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
(No ospf in table)
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
Alpha#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
I did a show run again to verify my config
Alpha#sh run
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Alpha
!
!
enable password how2pass
!
ip subnet-zero
!
!
interface Ethernet0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
!
interface Serail0
ip address 192.168.100.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 192.168.33.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
!
!
no ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
At first I thought that it may be just the router taking time to populate tables so I checked the route table again.
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
Nothing again so I checked interfaces to make sure they were up ok
Alpha#sh int e0
Ehternet0 is up, line protocol is up
Hardware is HD64570
Description:
Internet address is 192.168.33.1
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 252/255, load 1/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Alpha#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Description:
Internet address is 192.168.100.5
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=down DSR=down DTR=down RTS=down CTS=down
Went to the directly connected router and looked at there config and
Alpha#config t
Enter configuration commands, one per line. End with CNTL/Z.
Alpha(config)#no router ospf 1
Alpha(config)#router ospf 1
Alpha(config-router)#network 192.168.33.0 0.0.0.255 area 0
Alpha(config-router)#network 192.168.100.4 0.0.0.3 area 0 (why this way works but not config above)
Alpha(config-router)#exit
Alpha(config)#exit
The desired result.
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
O 192.168.100.8/30 [110/64] via 192.168.100.6, 00:00:35, Serial0
O 192.168.34.0/24 [110/64] via 192.168.100.6, 00:00:35, Serial0
O 192.168.35.0/24 [110/128] via 192.168.100.6, 00:00:35, Serial0
Comptek
A+, Network+
Alpha>en
Password:xxxx
Alpha#sh run
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Alpha
!
!
enable password how2pass
!
ip subnet-zero
!
!
interface Ethernet0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
!
interface Serail0
ip address 192.168.100.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 192.168.100.4 0.0.0.255 area 1 (this was the problem)
network 192.168.33.0 0.0.0.255 area 0
!
!
no ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Alpha#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
Alpha#config t
Enter configuration commands, one per line. End with CNTL/Z.
Alpha(config)#no router ospf 1 (removed ospf config)
Alpha(config)#router ospf 1
% Invalid input detected.
Alpha(config)#router ospf 1
Alpha(config-router)#network 192.168.33.0 0.0.0.255 area 0 (can do it like this or full ip followed with all 0's area 0 in Sybex)
Alpha(config-router)#network 192.168.100.0 0.0.0.255 area 0 (same here)
Alpha(config-router)#exit
Alpha(config)#exit
Alpha#sh run
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Alpha
!
!
enable password how2pass
!
ip subnet-zero
!
!
interface Ethernet0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
!
interface Serail0
ip address 192.168.100.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 192.168.33.0 0.0.0.255 area 0 (now in correct ospf area)
network 192.168.100.0 0.0.0.255 area 0
!
!
no ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
(No ospf in table)
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
Alpha#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
I did a show run again to verify my config
Alpha#sh run
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Alpha
!
!
enable password how2pass
!
ip subnet-zero
!
!
interface Ethernet0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
!
interface Serail0
ip address 192.168.100.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 192.168.33.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
!
!
no ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
At first I thought that it may be just the router taking time to populate tables so I checked the route table again.
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
Nothing again so I checked interfaces to make sure they were up ok
Alpha#sh int e0
Ehternet0 is up, line protocol is up
Hardware is HD64570
Description:
Internet address is 192.168.33.1
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 252/255, load 1/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Alpha#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Description:
Internet address is 192.168.100.5
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=down DSR=down DTR=down RTS=down CTS=down
Went to the directly connected router and looked at there config and
Alpha#config t
Enter configuration commands, one per line. End with CNTL/Z.
Alpha(config)#no router ospf 1
Alpha(config)#router ospf 1
Alpha(config-router)#network 192.168.33.0 0.0.0.255 area 0
Alpha(config-router)#network 192.168.100.4 0.0.0.3 area 0 (why this way works but not config above)
Alpha(config-router)#exit
Alpha(config)#exit
The desired result.
Alpha#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C 192.168.100.4/30 is directly connected. Serial0
C 192.168.33.0/24 is directly connected. Ethernet0
O 192.168.100.8/30 [110/64] via 192.168.100.6, 00:00:35, Serial0
O 192.168.34.0/24 [110/64] via 192.168.100.6, 00:00:35, Serial0
O 192.168.35.0/24 [110/128] via 192.168.100.6, 00:00:35, Serial0
Comptek
A+, Network+