NettableWalker
IS-IT--Management
I am trying to implement QoS (CBWFQ) on my main internet router.
I've set up 4 different classes and allocated bandwidth etc but i only seem to get results from 2 of the queues.
I need all my Citrix traffic to take priority, then Me!, then bit torrent stuff is cut right down to 8Kbps, and the rest is fair-queue.
Am i doing this correctly? QoS seems to be very confusing!
Am i right in thinking that unless there is any congestion it all goes through FIFO and wouldn't show in any queues?
thanks for your help.
Ray
class-map match-any citrix
match protocol citrix
match protocol telnet
class-map match-all Ray
match access-group 189
class-map match-all torrent
match access-group 188
!
!
policy-map speedy
class torrent
bandwidth 8
random-detect
class citrix
bandwidth 500
random-detect
class Ray
bandwidth 242
random-detect
class class-default
fair-queue
random-detect
interface Dialer1
.......OUTPUT CUT........
service-policy output speedy
access-list 188 permit ip 10.0.99.0 0.0.0.255 any
access-list 189 permit ip host 10.0.0.27 any
access-list 189 permit ip host 10.0.0.24 any
2611XM#sh policy-map interface d1
Dialer1
Service-policy output: speedy
Class-map: torrent (match-all)
0 packets, 0 bytes
1 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 188
Queueing
Output Queue: Conversation 265
Bandwidth 8 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 0/0 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: citrix (match-any)
1132298 packets, 120551440 bytes
1 minute offered rate 0 bps, drop rate 0 bps
Match: protocol citrix
1126132 packets, 119845142 bytes
1 minute rate 0 bps
Match: protocol telnet
263 packets, 12535 bytes
1 minute rate 0 bps
Queueing
Output Queue: Conversation 266
Bandwidth 500 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 3697/443087 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: Ray (match-all)
0 packets, 0 bytes
1 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 189
Queueing
Output Queue: Conversation 267
Bandwidth 242 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 0/0 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: class-default (match-any)
18929295 packets, 6078766538 bytes
1 minute offered rate 25000 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/0/0
exponential weight: 9
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 92625/16413662 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 1277/156090 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
MCP,CCA,CCNA,CCNP,Net+.
I've set up 4 different classes and allocated bandwidth etc but i only seem to get results from 2 of the queues.
I need all my Citrix traffic to take priority, then Me!, then bit torrent stuff is cut right down to 8Kbps, and the rest is fair-queue.
Am i doing this correctly? QoS seems to be very confusing!
Am i right in thinking that unless there is any congestion it all goes through FIFO and wouldn't show in any queues?
thanks for your help.
Ray
class-map match-any citrix
match protocol citrix
match protocol telnet
class-map match-all Ray
match access-group 189
class-map match-all torrent
match access-group 188
!
!
policy-map speedy
class torrent
bandwidth 8
random-detect
class citrix
bandwidth 500
random-detect
class Ray
bandwidth 242
random-detect
class class-default
fair-queue
random-detect
interface Dialer1
.......OUTPUT CUT........
service-policy output speedy
access-list 188 permit ip 10.0.99.0 0.0.0.255 any
access-list 189 permit ip host 10.0.0.27 any
access-list 189 permit ip host 10.0.0.24 any
2611XM#sh policy-map interface d1
Dialer1
Service-policy output: speedy
Class-map: torrent (match-all)
0 packets, 0 bytes
1 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 188
Queueing
Output Queue: Conversation 265
Bandwidth 8 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 0/0 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: citrix (match-any)
1132298 packets, 120551440 bytes
1 minute offered rate 0 bps, drop rate 0 bps
Match: protocol citrix
1126132 packets, 119845142 bytes
1 minute rate 0 bps
Match: protocol telnet
263 packets, 12535 bytes
1 minute rate 0 bps
Queueing
Output Queue: Conversation 266
Bandwidth 500 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 3697/443087 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: Ray (match-all)
0 packets, 0 bytes
1 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 189
Queueing
Output Queue: Conversation 267
Bandwidth 242 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 0/0 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: class-default (match-any)
18929295 packets, 6078766538 bytes
1 minute offered rate 25000 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/0/0
exponential weight: 9
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 92625/16413662 0/0 0/0 20 40 1/10
1 0/0 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 26 40 1/10
4 0/0 0/0 0/0 28 40 1/10
5 0/0 0/0 0/0 30 40 1/10
6 1277/156090 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
MCP,CCA,CCNA,CCNP,Net+.