xp
Technical User
- Jul 19, 2001
- 25
Hi,
I have a problem configuring my 2520 to dial the internet using an external
modem connected to serial3. The router will not talk to the modem. I have
included the modem information from the .inf file . All help appreciated.
Brian
cheetah Modem settings as follows:
HKR, Init, 1,, "AT<cr>"
HKR, Init, 2,, "AT&FE0V1S0=0&C1&D2+MR=2;+DR=1;+ER=1;W0<cr>"
HKR, Monitor, 1,, "ATS0=0<cr>"
HKR, Monitor, 2,, "None"
HKR, Hangup, 1,, "ATH<cr>"
HKR, Answer, 1,, "ATA<cr>"
HKR, , Reset,, "ATZ<cr>"
HKR, Settings, Prefix,, "AT"
HKR, Settings, Terminator,, "<cr>"
HKR, Settings, DialPrefix,, "D"
HKR, Settings, DialSuffix,, ";"
HKR, Settings, SpeakerVolume_Low,, "L0"
HKR, Settings, SpeakerVolume_Med,, "L2"
HKR, Settings, SpeakerVolume_High,, "L3"
HKR, Settings, SpeakerMode_Off,, "M0"
HKR, Settings, SpeakerMode_Dial,, "M1"
HKR, Settings, SpeakerMode_On,, "M2"
HKR, Settings, SpeakerMode_Setup,, "M3"
HKR, Settings, FlowControl_Off,, "+IFC=0,0;"
HKR, Settings, FlowControl_Hard,, "+IFC=2,2;"
HKR, Settings, FlowControl_Soft,, "+IFC=1,1;"
HKR, Settings, Pulse,, "P"
HKR, Settings, Tone,, "T"
HKR, Settings, Blind_Off,, "X4"
HKR, Settings, Blind_On,, "X3"
HKR, Settings, CallSetupFailTimer,, "S7=<#>"
HKR, Settings, ErrorControl_On,, "+ES=3,0,2;"
HKR, Settings, ErrorControl_Off,, "+ES=1,0,1;"
HKR, Settings, ErrorControl_Forced,, "+ES=3,2,4;"
HKR, Settings, Compression_On,, "+DS=3;"
HKR, Settings, Compression_Off,, "+DS=0;"
Router config as follows:
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Sydney-r-2520
!
enable password cisco
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
modemcap entry cheetah:AT&FE0V1S0=0&C1&D2+MR=2;+DR=1;+ER=1;
!
interface Dialer 1
description connected to Internet
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer idle-timeout 120
dialer string 0198308888
dialer hold-queue 10
dialer-group 1
pulse-time 3
ppp authentication chap pap callin
ppp chap hostname xxxxxxx
ppp chap password storm
ppp pap sent-username xxxxxxx password xxxxxxx
no cdp enable
!
interface Ethernet 0
no shutdown
description connected to SydLAN
ip address 192.168.2.2 255.255.255.0
ip nat inside
keepalive 10
!
cut
!
interface Serial 3
physical-layer async
no shutdown
description connected to Internet
no ip address
async mode dedicated
dialer rotary-group 1
!
! Access Control List 1
!
no access-list 1
access-list 1 permit 192.168.101.0 0.0.0.3
access-list 1 permit 192.168.102.0 0.0.0.3
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.100.0 0.0.0.3
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 192.168.3.0 0.0.0.255
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Dialer 1 overload
!
router rip
version 2
network 192.168.2.0
network 192.168.101.0
network 192.168.102.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
banner motd # Sydney 2520#
!
line console 0
exec-timeout 0 0
password xxxxxxx
login
!
line vty 0 4
password xxxxxxx
login
!
line 3
modem InOut
modem autoconfigure type cheetah
transport input all
stopbits 1
speed 38400
flowcontrol hardware
!
end
I have a problem configuring my 2520 to dial the internet using an external
modem connected to serial3. The router will not talk to the modem. I have
included the modem information from the .inf file . All help appreciated.
Brian
cheetah Modem settings as follows:
HKR, Init, 1,, "AT<cr>"
HKR, Init, 2,, "AT&FE0V1S0=0&C1&D2+MR=2;+DR=1;+ER=1;W0<cr>"
HKR, Monitor, 1,, "ATS0=0<cr>"
HKR, Monitor, 2,, "None"
HKR, Hangup, 1,, "ATH<cr>"
HKR, Answer, 1,, "ATA<cr>"
HKR, , Reset,, "ATZ<cr>"
HKR, Settings, Prefix,, "AT"
HKR, Settings, Terminator,, "<cr>"
HKR, Settings, DialPrefix,, "D"
HKR, Settings, DialSuffix,, ";"
HKR, Settings, SpeakerVolume_Low,, "L0"
HKR, Settings, SpeakerVolume_Med,, "L2"
HKR, Settings, SpeakerVolume_High,, "L3"
HKR, Settings, SpeakerMode_Off,, "M0"
HKR, Settings, SpeakerMode_Dial,, "M1"
HKR, Settings, SpeakerMode_On,, "M2"
HKR, Settings, SpeakerMode_Setup,, "M3"
HKR, Settings, FlowControl_Off,, "+IFC=0,0;"
HKR, Settings, FlowControl_Hard,, "+IFC=2,2;"
HKR, Settings, FlowControl_Soft,, "+IFC=1,1;"
HKR, Settings, Pulse,, "P"
HKR, Settings, Tone,, "T"
HKR, Settings, Blind_Off,, "X4"
HKR, Settings, Blind_On,, "X3"
HKR, Settings, CallSetupFailTimer,, "S7=<#>"
HKR, Settings, ErrorControl_On,, "+ES=3,0,2;"
HKR, Settings, ErrorControl_Off,, "+ES=1,0,1;"
HKR, Settings, ErrorControl_Forced,, "+ES=3,2,4;"
HKR, Settings, Compression_On,, "+DS=3;"
HKR, Settings, Compression_Off,, "+DS=0;"
Router config as follows:
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Sydney-r-2520
!
enable password cisco
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
modemcap entry cheetah:AT&FE0V1S0=0&C1&D2+MR=2;+DR=1;+ER=1;
!
interface Dialer 1
description connected to Internet
ip address negotiated
ip nat outside
encapsulation ppp
dialer in-band
dialer idle-timeout 120
dialer string 0198308888
dialer hold-queue 10
dialer-group 1
pulse-time 3
ppp authentication chap pap callin
ppp chap hostname xxxxxxx
ppp chap password storm
ppp pap sent-username xxxxxxx password xxxxxxx
no cdp enable
!
interface Ethernet 0
no shutdown
description connected to SydLAN
ip address 192.168.2.2 255.255.255.0
ip nat inside
keepalive 10
!
cut
!
interface Serial 3
physical-layer async
no shutdown
description connected to Internet
no ip address
async mode dedicated
dialer rotary-group 1
!
! Access Control List 1
!
no access-list 1
access-list 1 permit 192.168.101.0 0.0.0.3
access-list 1 permit 192.168.102.0 0.0.0.3
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.100.0 0.0.0.3
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 192.168.3.0 0.0.0.255
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Dialer 1 overload
!
router rip
version 2
network 192.168.2.0
network 192.168.101.0
network 192.168.102.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
banner motd # Sydney 2520#
!
line console 0
exec-timeout 0 0
password xxxxxxx
login
!
line vty 0 4
password xxxxxxx
login
!
line 3
modem InOut
modem autoconfigure type cheetah
transport input all
stopbits 1
speed 38400
flowcontrol hardware
!
end