I am having a problem pinging through a router configuration I just built. Within the Cisco console I can ping from fastethernet interface to interface. From a machine in the same subnet as the router I can ping the fastethernet interface but can go no further. I have enclosed my routing configuration in case you can spot something I have missed.
2650main#show run
Building configuration...
Current configuration : 1278 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2650main
!
enable secret
enable password
!
ip subnet-zero
!
!
!
!
controller T1 0/1
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/2
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
!
!
interface FastEthernet0/0
ip address 172.18.1.20 255.255.255.0
ip helper-address 172.18.1.1
speed auto
full-duplex
!
interface Serial0/0
description connected to branch office
ip address 172.20.2.24 255.255.255.0
encapsulation ppp
no keepalive
no fair-queue
service-module t1 clock source internal
service-module t1 remote-alarm-enable
!
interface Serial0/1:0
description connected to Nap Office
ip unnumbered FastEthernet0/0
!
interface Serial0/2:0
description Connected to San Office
ip unnumbered FastEthernet0/0
!
router rip
network 172.18.0.0
network 172.19.0.0
network 172.20.0.0
network 172.21.0.0
!
ip classless
ip route 172.20.1.0 255.255.255.0 172.20.2.20
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
password
login
!
no scheduler allocate
end
Second router
2650Branch#show run
Building configuration...
Current configuration : 895 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2650Branch
!
enable secret
enable password
!
ip subnet-zero
!
!
ip domain-name aooanwot.com
ip name-server 172.18.1.1
!
interface FastEthernet0/0
description connected to the Branch office
ip address 172.20.1.20 255.255.255.0
ip helper-address 172.18.1.1
duplex auto
speed auto
!
interface Serial0/0
description connected to the main office
ip address 172.20.2.20 255.255.255.0
encapsulation ppp
no keepalive
fair-queue
service-module t1 remote-alarm-enable
!
router rip
version 2
network 172.20.0.0
no auto-summary
!
ip classless
ip route 172.18.1.0 255.255.255.0 172.20.2.24
no ip http server
ip pim bidir-enable
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password
login
!
end
2650Branch#
2650main#show run
Building configuration...
Current configuration : 1278 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2650main
!
enable secret
enable password
!
ip subnet-zero
!
!
!
!
controller T1 0/1
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/2
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
!
!
interface FastEthernet0/0
ip address 172.18.1.20 255.255.255.0
ip helper-address 172.18.1.1
speed auto
full-duplex
!
interface Serial0/0
description connected to branch office
ip address 172.20.2.24 255.255.255.0
encapsulation ppp
no keepalive
no fair-queue
service-module t1 clock source internal
service-module t1 remote-alarm-enable
!
interface Serial0/1:0
description connected to Nap Office
ip unnumbered FastEthernet0/0
!
interface Serial0/2:0
description Connected to San Office
ip unnumbered FastEthernet0/0
!
router rip
network 172.18.0.0
network 172.19.0.0
network 172.20.0.0
network 172.21.0.0
!
ip classless
ip route 172.20.1.0 255.255.255.0 172.20.2.20
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
password
login
!
no scheduler allocate
end
Second router
2650Branch#show run
Building configuration...
Current configuration : 895 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2650Branch
!
enable secret
enable password
!
ip subnet-zero
!
!
ip domain-name aooanwot.com
ip name-server 172.18.1.1
!
interface FastEthernet0/0
description connected to the Branch office
ip address 172.20.1.20 255.255.255.0
ip helper-address 172.18.1.1
duplex auto
speed auto
!
interface Serial0/0
description connected to the main office
ip address 172.20.2.20 255.255.255.0
encapsulation ppp
no keepalive
fair-queue
service-module t1 remote-alarm-enable
!
router rip
version 2
network 172.20.0.0
no auto-summary
!
ip classless
ip route 172.18.1.0 255.255.255.0 172.20.2.24
no ip http server
ip pim bidir-enable
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password
login
!
end
2650Branch#