I'm trying to get a router to work behind an Alcatel Speedtouch adsl modem. The router is a cisco 1720 with two ethernet interfaces. The modem is "tweaked" and does NAT and sets up the vpn connection.
I can ping from the PC to the inside address of the modem (192.168.1.1) but not to the internet or the outside address of the modem (213.84.100.121). It looks something like this:
internet Alcatel rtr 1720 pc
| | | |
213.84.100.121<->192.168.1.1/192.168.1.2<->192.168.2.1<->192.168.2.7
I assume that (since I get request timed out) I have the route to the internet working but the route back is wrong. Do I have to do something in the routing table of the modem? I'm lost here.....
Thanks!
Alcatel IP route table
Destination Source Gateway Intf
192.168.2.0/24 213.84.104.21/32 192.168.1.2 eth0
192.168.2.0/24 192.168.1.0/24 192.168.1.2 eth0
192.168.1.0/24 192.168.1.0/24 192.168.1.1 eth0
213.84.104.21/32 any 213.84.104.21 MXS
172.16.1.1/32 any 172.16.1.1 cip0
127.0.0.1/32 any 127.0.0.1 loop
192.168.2.0/24 any 192.168.1.2 eth0
192.168.1.0/24 any 192.168.1.1 eth0
172.16.1.0/24 any 172.16.1.1 cip0
default 10.0.0.150/0 213.84.104.21 MXS
Cisco1720#show running-config
Building configuration...
Current configuration : 987 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1720
!
no logging buffered
logging rate-limit console 10 except errors
enable password 7 091weD1wew
!
memory-size iomem 25
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Ethernet0
description connected to EthernetLAN_1
ip address 192.168.1.2 255.255.255.0
half-duplex
!
interface FastEthernet0
description connected to EthernetLAN
ip address 192.168.2.1 255.255.255.0
speed auto
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
!
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password 7 03526109
login
transport input none
line aux 0
line vty 0 4
password 7 1532595F
login
!
no scheduler allocate
end
I can ping from the PC to the inside address of the modem (192.168.1.1) but not to the internet or the outside address of the modem (213.84.100.121). It looks something like this:
internet Alcatel rtr 1720 pc
| | | |
213.84.100.121<->192.168.1.1/192.168.1.2<->192.168.2.1<->192.168.2.7
I assume that (since I get request timed out) I have the route to the internet working but the route back is wrong. Do I have to do something in the routing table of the modem? I'm lost here.....
Thanks!
Alcatel IP route table
Destination Source Gateway Intf
192.168.2.0/24 213.84.104.21/32 192.168.1.2 eth0
192.168.2.0/24 192.168.1.0/24 192.168.1.2 eth0
192.168.1.0/24 192.168.1.0/24 192.168.1.1 eth0
213.84.104.21/32 any 213.84.104.21 MXS
172.16.1.1/32 any 172.16.1.1 cip0
127.0.0.1/32 any 127.0.0.1 loop
192.168.2.0/24 any 192.168.1.2 eth0
192.168.1.0/24 any 192.168.1.1 eth0
172.16.1.0/24 any 172.16.1.1 cip0
default 10.0.0.150/0 213.84.104.21 MXS
Cisco1720#show running-config
Building configuration...
Current configuration : 987 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1720
!
no logging buffered
logging rate-limit console 10 except errors
enable password 7 091weD1wew
!
memory-size iomem 25
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Ethernet0
description connected to EthernetLAN_1
ip address 192.168.1.2 255.255.255.0
half-duplex
!
interface FastEthernet0
description connected to EthernetLAN
ip address 192.168.2.1 255.255.255.0
speed auto
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
!
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password 7 03526109
login
transport input none
line aux 0
line vty 0 4
password 7 1532595F
login
!
no scheduler allocate
end