Good morning,
After a bit of research on the topic I've enabled some QoS between a 1721 and 2610 for VoIP, but the customer is still saying some calls are noisy. I've listed the commands and output of "sh policy-map int e0" from the 1721, the 2610 has the same settings and output. I'm thinking the point to point wireless link is a bit dodgy and dropping the voice UDP but am unable to prove this.
Basic network diagram is VoIPPBX <-> 1721 <-> WirelessAP <-> WirelessAP <-> 2610 <-> PoE switch with IP handsets.
Any ideas? I can see in the "sh pol int e0" that the link is getting congested and class-default traffic is getting dropped intentionally
!
!
class-map match-any VoiceTraffic
match access-group 100
!
!
policy-map VOIP
class VoiceTraffic
priority 2000 100000
class class-default
fair-queue
!
!
interface Ethernet0
ip address 10.0.8.4 255.255.255.248
half-duplex
service-policy output VOIP
!
interface FastEthernet0
ip address 10.0.2.1 255.255.255.0
speed auto
full-duplex
!
router eigrp 1
network 10.0.0.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.2.254
no ip http server
!
!
access-list 100 permit ip any any dscp af41
access-list 100 permit ip any any dscp ef
!
sh pol int e0
Ethernet0
Service-policy output: VOIP
Class-map: VoiceTraffic (match-any)
2346565 packets, 171280838 bytes
5 minute offered rate 5000 bps, drop rate 0 bps
Match: access-group 100
2346565 packets, 171280838 bytes
5 minute rate 5000 bps
Weighted Fair Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 2000 (kbps) Burst 100000 (Bytes)
(pkts matched/bytes matched) 8308/607390
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
9151587 packets, 7780780143 bytes
5 minute offered rate 27000 bps, drop rate 0 bps
Match: any
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/4277437/0
After a bit of research on the topic I've enabled some QoS between a 1721 and 2610 for VoIP, but the customer is still saying some calls are noisy. I've listed the commands and output of "sh policy-map int e0" from the 1721, the 2610 has the same settings and output. I'm thinking the point to point wireless link is a bit dodgy and dropping the voice UDP but am unable to prove this.
Basic network diagram is VoIPPBX <-> 1721 <-> WirelessAP <-> WirelessAP <-> 2610 <-> PoE switch with IP handsets.
Any ideas? I can see in the "sh pol int e0" that the link is getting congested and class-default traffic is getting dropped intentionally
!
!
class-map match-any VoiceTraffic
match access-group 100
!
!
policy-map VOIP
class VoiceTraffic
priority 2000 100000
class class-default
fair-queue
!
!
interface Ethernet0
ip address 10.0.8.4 255.255.255.248
half-duplex
service-policy output VOIP
!
interface FastEthernet0
ip address 10.0.2.1 255.255.255.0
speed auto
full-duplex
!
router eigrp 1
network 10.0.0.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.2.254
no ip http server
!
!
access-list 100 permit ip any any dscp af41
access-list 100 permit ip any any dscp ef
!
sh pol int e0
Ethernet0
Service-policy output: VOIP
Class-map: VoiceTraffic (match-any)
2346565 packets, 171280838 bytes
5 minute offered rate 5000 bps, drop rate 0 bps
Match: access-group 100
2346565 packets, 171280838 bytes
5 minute rate 5000 bps
Weighted Fair Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 2000 (kbps) Burst 100000 (Bytes)
(pkts matched/bytes matched) 8308/607390
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
9151587 packets, 7780780143 bytes
5 minute offered rate 27000 bps, drop rate 0 bps
Match: any
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/4277437/0