I’m trying to connect a server in a DMZ on the PIX and be able to have the local LAN reach it using a local address.
I setup the NAT to allow any communication from the local interface (192.168.0.x) destined for IP 192.168.0.11 to be mapped to the server in the DMZ (10.1.2.2). If I try to send any type of communication to IP address 192.168.0.11 I receive the following errors:
609002: Teardown local-host dmz_isa:10.1.2.2 duration 0:00:00
305006: portmap translation creation failed for icmp src local:192.168.0.28 dst dmz_isa:192.168.0.11 (type 8, code 0)
609001: Built local-host dmz_isa:10.1.2.2
609002: Teardown local-host dmz_isa:10.1.2.2 duration 0:00:00
305006: portmap translation creation failed for icmp src local:192.168.0.28 dst dmz_isa:192.168.0.11 (type 8, code 0)
609001: Built local-host dmz_isa:10.1.2.2
PIX Config (removed all unrelated items):
PIX Version 7.0(4)
!
interface Ethernet0
nameif internet
security-level 0
ip address 71.x.x.x 255.255.255.192
!
interface Ethernet1
nameif local
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet2
nameif dmz_servers
security-level 50
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet3
nameif dmz_isa
security-level 50
ip address 10.1.2.1 255.255.255.0
!
ftp mode passive
same-security-traffic permit intra-interface
access-list local_nat0_outbound extended permit ip any 192.168.0.0 255.255.255.0
access-list local_nat0_outbound extended permit ip any 172.30.0.0 255.255.255.0
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.1.0 255.255.255.252
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.0.0 255.255.255.252
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.1.0 255.255.255.248
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.1.0 255.255.255.0
ip local pool LOCAL 172.30.0.1-172.30.0.254 mask 255.255.255.0
ip verify reverse-path interface internet
ip verify reverse-path interface local
ip verify reverse-path interface dmz_servers
ip verify reverse-path interface dmz_isa
ip audit attack action alarm drop
monitor-interface internet
monitor-interface local
monitor-interface dmz_servers
monitor-interface dmz_isa
arp timeout 14400
global (internet) 1 interface
nat (local) 0 access-list local_nat0_outbound
nat (local) 1 0.0.0.0 0.0.0.0
nat (dmz_servers) 0 access-list dmz_servers_nat0_outbound
static (dmz_servers,internet) 71.x.x.x 10.1.1.2 netmask 255.255.255.255 tcp 1000 100 udp 1000
static (dmz_isa,local) 192.168.0.11 10.1.2.2 netmask 255.255.255.255
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
!
policy-map global_policy
class inspection_default
inspect dns maximum-length 512
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
I setup the NAT to allow any communication from the local interface (192.168.0.x) destined for IP 192.168.0.11 to be mapped to the server in the DMZ (10.1.2.2). If I try to send any type of communication to IP address 192.168.0.11 I receive the following errors:
609002: Teardown local-host dmz_isa:10.1.2.2 duration 0:00:00
305006: portmap translation creation failed for icmp src local:192.168.0.28 dst dmz_isa:192.168.0.11 (type 8, code 0)
609001: Built local-host dmz_isa:10.1.2.2
609002: Teardown local-host dmz_isa:10.1.2.2 duration 0:00:00
305006: portmap translation creation failed for icmp src local:192.168.0.28 dst dmz_isa:192.168.0.11 (type 8, code 0)
609001: Built local-host dmz_isa:10.1.2.2
PIX Config (removed all unrelated items):
PIX Version 7.0(4)
!
interface Ethernet0
nameif internet
security-level 0
ip address 71.x.x.x 255.255.255.192
!
interface Ethernet1
nameif local
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet2
nameif dmz_servers
security-level 50
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet3
nameif dmz_isa
security-level 50
ip address 10.1.2.1 255.255.255.0
!
ftp mode passive
same-security-traffic permit intra-interface
access-list local_nat0_outbound extended permit ip any 192.168.0.0 255.255.255.0
access-list local_nat0_outbound extended permit ip any 172.30.0.0 255.255.255.0
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.1.0 255.255.255.252
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.0.0 255.255.255.252
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.1.0 255.255.255.248
access-list local_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.29.1.0 255.255.255.0
ip local pool LOCAL 172.30.0.1-172.30.0.254 mask 255.255.255.0
ip verify reverse-path interface internet
ip verify reverse-path interface local
ip verify reverse-path interface dmz_servers
ip verify reverse-path interface dmz_isa
ip audit attack action alarm drop
monitor-interface internet
monitor-interface local
monitor-interface dmz_servers
monitor-interface dmz_isa
arp timeout 14400
global (internet) 1 interface
nat (local) 0 access-list local_nat0_outbound
nat (local) 1 0.0.0.0 0.0.0.0
nat (dmz_servers) 0 access-list dmz_servers_nat0_outbound
static (dmz_servers,internet) 71.x.x.x 10.1.1.2 netmask 255.255.255.255 tcp 1000 100 udp 1000
static (dmz_isa,local) 192.168.0.11 10.1.2.2 netmask 255.255.255.255
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
!
policy-map global_policy
class inspection_default
inspect dns maximum-length 512
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp