I am trying to limit traffic on a gigabit interface using policing. IOS version is 12.1(19)EA1c. The simplest configuration is:
policy-map Limit-Net
class class-default
police 12000000 65536 exceed-action drop
...
interface GigabitEthernet0/1
service-policy input Limit-Net
I see no reduction in traffic, either in the output of "show int Gi0/1" or in MRTG graphs for the interface.
Is this supposed to work? If policing limits the traffic, do the effects show up in the counters?
I have also tried this more complex configuration, to the same zero effect. What I am trying to do is limit traffic coming in on this Gi interface to about 1/2 the capacity of a T3 that is further "downstream", while still allowing traffic at full capacity to our local campus:
class-map match-all Internal-traffic
match access-group 102
policy-map Limit-Net
class Internal-traffic
police 1000000000 524288 exceed-action dscp 0
! exceed-action dscp 0 is default when no actions are specified.
! No traffic should exceed this limit anyway
class class-default
police 12000000 65536 exceed-action drop
interface GigabitEthernet0/1
...
service-policy input Limit-Net
! These are my internal IP addresses
access-list 102 permit ip 149.137.0.0 0.0.255.255 149.137.0.0 0.0.255.255
Thanks, any help is appreciated.
policy-map Limit-Net
class class-default
police 12000000 65536 exceed-action drop
...
interface GigabitEthernet0/1
service-policy input Limit-Net
I see no reduction in traffic, either in the output of "show int Gi0/1" or in MRTG graphs for the interface.
Is this supposed to work? If policing limits the traffic, do the effects show up in the counters?
I have also tried this more complex configuration, to the same zero effect. What I am trying to do is limit traffic coming in on this Gi interface to about 1/2 the capacity of a T3 that is further "downstream", while still allowing traffic at full capacity to our local campus:
class-map match-all Internal-traffic
match access-group 102
policy-map Limit-Net
class Internal-traffic
police 1000000000 524288 exceed-action dscp 0
! exceed-action dscp 0 is default when no actions are specified.
! No traffic should exceed this limit anyway
class class-default
police 12000000 65536 exceed-action drop
interface GigabitEthernet0/1
...
service-policy input Limit-Net
! These are my internal IP addresses
access-list 102 permit ip 149.137.0.0 0.0.255.255 149.137.0.0 0.0.255.255
Thanks, any help is appreciated.