Hi guru's
Been puzzling for a few days now, time to call in some support.
I've got the following network layout and want full traffic between internal LANS
192.168.50.0/24-pix501-xxx.xxx.9.85/20(dhcp) <- internet -> xxx.xxx.195.75-asa5505-10.32.10/24
my pix config :
#######################################################
<snip>
access-list inside_outbound_nat0_acl permit ip 192.168.50.0 255.255.255.0 10.32.1.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.50.0 255.255.255.0 10.32.1.0 255.255.255.0
access-list acl_outbound permit ip 192.168.50.0 255.255.255.0 any
<snip>
ip address outside dhcp setroute
ip address inside 192.168.50.1 255.255.255.0
<snip>
global (outside) 1 interface
global (inside) 10 interface
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set pfs group2
crypto map outside_map 20 set peer xxx.xxx.195.75
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address xxx.xxx.195.75 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp log 50
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
sh route
outside 0.0.0.0 0.0.0.0 xxx.xxx.8.1 1 DHCP static
outside xxx.xxx.8.0 255.255.248.0 xxx.xxx.9.85 1 CONNECT static
inside 192.168.50.0 255.255.255.0 192.168.50.1 1 CONNECT static
sh nat
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.50.0 255.255.255.0 0 0
##########################################################
my ASA config:
##########################################################
name 10.32.1.0 live_lan description live lan
name 192.168.50.0 jaap_lan description LAN Jaap thuis
name xxx.xxx.9.85 pix_jaap description pix Jaap thuis
!
interface Vlan2
nameif outside
security-level 0
ip address xxx.xxx.195.75 255.255.255.192
ospf cost 10
!
interface Vlan3
nameif live
security-level 0
ip address 10.32.1.75 255.255.255.0
ospf cost 10
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
switchport access vlan 3
<snip>
same-security-traffic permit intra-interface
access-list outside_20_cryptomap extended permit ip live_lan 255.255.255.0 jaap_lan 255.255.255.0
access-list live_nat0_outbound extended permit ip live_lan 255.255.255.0 jaap_lan 255.255.255.0
<snip>
global (outside) 1 interface
nat (live) 0 access-list live_nat0_outbound
route outside 0.0.0.0 0.0.0.0 xxx.xxx.195.75 1
group-policy DfltGrpPolicy attributes
banner none
wins-server none
dns-server none
dhcp-network-scope none
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout 30
vpn-session-timeout none
vpn-filter none
vpn-tunnel-protocol IPSec
password-storage disable
ip-comp disable
re-xauth enable
group-lock none
pfs disable
ipsec-udp disable
ipsec-udp-port 10000
split-tunnel-policy tunnelall
split-tunnel-network-list none
default-domain none
split-dns none
intercept-dhcp 255.255.255.255 disable
secure-unit-authentication disable
user-authentication disable
user-authentication-idle-timeout 30
ip-phone-bypass disable
leap-bypass disable
nem disable
backup-servers keep-client-config
msie-proxy server none
msie-proxy method no-modify
msie-proxy except-list none
msie-proxy local-bypass disable
nac disable
nac-sq-period 300
nac-reval-period 36000
nac-default-acl none
address-pools none
client-firewall none
client-access-rule none
webvpn
functions none
html-content-filter none
homepage none
keep-alive-ignore 4
http-comp gzip
filter none
url-list none
customization value DfltCustomization
port-forward none
port-forward-name value Application Access
sso-server none
deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
svc none
svc keep-installer installed
svc keepalive none
svc rekey time none
svc rekey method none
svc dpd-interval client none
svc dpd-interval gateway none
svc compression deflate
group-policy GroupPolicy1 internal
group-policy GroupPolicy1 attributes
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout 30
vpn-session-timeout none
vpn-filter none
vpn-tunnel-protocol IPSec l2tp-ipsec
ip-comp disable
re-xauth enable
group-lock value xxx.xxx.9.85
pfs enable
split-tunnel-network-list none
secure-unit-authentication disable
user-authentication disable
user-authentication-idle-timeout none
ip-phone-bypass disable
leap-bypass disable
nem enable
address-pools none
client-access-rule none
vpn-nac-exempt none
aaa authentication ssh console LOCAL
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer pix_jaap
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 set nat-t-disable
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
tunnel-group xxx.xxx.9.85 type ipsec-l2l
tunnel-group xxx.xxx.9.85 ipsec-attributes
pre-shared-key *
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
###########################################################
sh route
Gateway of last resort is xxx.xxx.195.75 to network 0.0.0.0
C xxx.xxx.195.64 255.255.255.192 is directly connected, outside
C 127.1.0.0 255.255.0.0 is directly connected, _internal_loopback
C live_lan 255.255.255.0 is directly connected, live
S* 0.0.0.0 0.0.0.0 [1/0] via xxx.xxx.195.75, outside
sh nat
NAT policies on Interface live:
match ip live live_lan 255.255.255.0 outside jaap_lan 255.255.255.0
NAT exempt
translate_hits = 0, untranslate_hits = 6
match ip live live_lan 255.255.255.0 live jaap_lan 255.255.255.0
NAT exempt
translate_hits = 0, untranslate_hits = 0
So the tunnel comes up, but it seems like no traffic returns from the ASA to the pix.
(RX but no TX, decrypt but no encrypt)
This is a test setup so I can change stuff around freely.
help is appreciated
Been puzzling for a few days now, time to call in some support.
I've got the following network layout and want full traffic between internal LANS
192.168.50.0/24-pix501-xxx.xxx.9.85/20(dhcp) <- internet -> xxx.xxx.195.75-asa5505-10.32.10/24
my pix config :
#######################################################
<snip>
access-list inside_outbound_nat0_acl permit ip 192.168.50.0 255.255.255.0 10.32.1.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.50.0 255.255.255.0 10.32.1.0 255.255.255.0
access-list acl_outbound permit ip 192.168.50.0 255.255.255.0 any
<snip>
ip address outside dhcp setroute
ip address inside 192.168.50.1 255.255.255.0
<snip>
global (outside) 1 interface
global (inside) 10 interface
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set pfs group2
crypto map outside_map 20 set peer xxx.xxx.195.75
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address xxx.xxx.195.75 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp log 50
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
sh route
outside 0.0.0.0 0.0.0.0 xxx.xxx.8.1 1 DHCP static
outside xxx.xxx.8.0 255.255.248.0 xxx.xxx.9.85 1 CONNECT static
inside 192.168.50.0 255.255.255.0 192.168.50.1 1 CONNECT static
sh nat
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 192.168.50.0 255.255.255.0 0 0
##########################################################
my ASA config:
##########################################################
name 10.32.1.0 live_lan description live lan
name 192.168.50.0 jaap_lan description LAN Jaap thuis
name xxx.xxx.9.85 pix_jaap description pix Jaap thuis
!
interface Vlan2
nameif outside
security-level 0
ip address xxx.xxx.195.75 255.255.255.192
ospf cost 10
!
interface Vlan3
nameif live
security-level 0
ip address 10.32.1.75 255.255.255.0
ospf cost 10
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
switchport access vlan 3
<snip>
same-security-traffic permit intra-interface
access-list outside_20_cryptomap extended permit ip live_lan 255.255.255.0 jaap_lan 255.255.255.0
access-list live_nat0_outbound extended permit ip live_lan 255.255.255.0 jaap_lan 255.255.255.0
<snip>
global (outside) 1 interface
nat (live) 0 access-list live_nat0_outbound
route outside 0.0.0.0 0.0.0.0 xxx.xxx.195.75 1
group-policy DfltGrpPolicy attributes
banner none
wins-server none
dns-server none
dhcp-network-scope none
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout 30
vpn-session-timeout none
vpn-filter none
vpn-tunnel-protocol IPSec
password-storage disable
ip-comp disable
re-xauth enable
group-lock none
pfs disable
ipsec-udp disable
ipsec-udp-port 10000
split-tunnel-policy tunnelall
split-tunnel-network-list none
default-domain none
split-dns none
intercept-dhcp 255.255.255.255 disable
secure-unit-authentication disable
user-authentication disable
user-authentication-idle-timeout 30
ip-phone-bypass disable
leap-bypass disable
nem disable
backup-servers keep-client-config
msie-proxy server none
msie-proxy method no-modify
msie-proxy except-list none
msie-proxy local-bypass disable
nac disable
nac-sq-period 300
nac-reval-period 36000
nac-default-acl none
address-pools none
client-firewall none
client-access-rule none
webvpn
functions none
html-content-filter none
homepage none
keep-alive-ignore 4
http-comp gzip
filter none
url-list none
customization value DfltCustomization
port-forward none
port-forward-name value Application Access
sso-server none
deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
svc none
svc keep-installer installed
svc keepalive none
svc rekey time none
svc rekey method none
svc dpd-interval client none
svc dpd-interval gateway none
svc compression deflate
group-policy GroupPolicy1 internal
group-policy GroupPolicy1 attributes
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout 30
vpn-session-timeout none
vpn-filter none
vpn-tunnel-protocol IPSec l2tp-ipsec
ip-comp disable
re-xauth enable
group-lock value xxx.xxx.9.85
pfs enable
split-tunnel-network-list none
secure-unit-authentication disable
user-authentication disable
user-authentication-idle-timeout none
ip-phone-bypass disable
leap-bypass disable
nem enable
address-pools none
client-access-rule none
vpn-nac-exempt none
aaa authentication ssh console LOCAL
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer pix_jaap
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 set nat-t-disable
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
tunnel-group xxx.xxx.9.85 type ipsec-l2l
tunnel-group xxx.xxx.9.85 ipsec-attributes
pre-shared-key *
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
###########################################################
sh route
Gateway of last resort is xxx.xxx.195.75 to network 0.0.0.0
C xxx.xxx.195.64 255.255.255.192 is directly connected, outside
C 127.1.0.0 255.255.0.0 is directly connected, _internal_loopback
C live_lan 255.255.255.0 is directly connected, live
S* 0.0.0.0 0.0.0.0 [1/0] via xxx.xxx.195.75, outside
sh nat
NAT policies on Interface live:
match ip live live_lan 255.255.255.0 outside jaap_lan 255.255.255.0
NAT exempt
translate_hits = 0, untranslate_hits = 6
match ip live live_lan 255.255.255.0 live jaap_lan 255.255.255.0
NAT exempt
translate_hits = 0, untranslate_hits = 0
So the tunnel comes up, but it seems like no traffic returns from the ASA to the pix.
(RX but no TX, decrypt but no encrypt)
This is a test setup so I can change stuff around freely.
help is appreciated