Hi all,
I'm having a problem with a site to site VPN between a PIX and a router. The layout is basically like this :
LAN A -- 192.168.20.1( PIX )192.168.50.1-- 192.168.50.3(Router1)192.200.200.13 ----- 192.200.200.14(Remote Router2)192.168.250.x --- LAN B
I've setup client to PIX VPNs successully before, but not site to site, so I would appreciate any help.
The 2 VPN peers are the PIX and Router2 and the problem basically is, after inputting configuration for VPN on the 2 peers, the traffic that's supposed to be using the VPN tunnel to go between LAN A and LAN B, just seems to be going through "normally".
Here are the vpn related config :
PIX (running os 7.0.1)
access-list l2l extended permit ip 192.168.20.0 255.255.255.0 192.168.250.0 255.255.255.0
crypto ipsec transform-set transform1 esp-3des esp-md5-hmac
crypto map crypto1 1 match address l2l
crypto map crypto1 1 set peer 192.168.250.200
crypto map crypto1 1 set transform-set transform1
crypto map crypto1 interface Remote
isakmp enable Remote
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 43200
tunnel-group 192.168.250.200 type ipsec-l2l
tunnel-group 192.168.250.200 ipsec-attributes
pre-shared-key *
sysopt connection permit-ipsec
Note: I also had a nat 0 access-list but it didn't seem to make a difference.
Config for remote router:
interface loopback 1
ip address 192.168.250.200 255.255.255.0
crypto map Crypto1
Crypto isakmp policy 10
authentication pre-share
crypto isakmp key * address 192.168.50.1
crypto ipsec transform-set transform1 esp-3des
crypto map Crypto1 local-address interface loopback 1
crypto map Crypto1 20 ipsec-isakmp
set peer 192.168.50.1
set transform-set encrypt_des
match address 100
access-list 100 permit ip 192.168.250.0 0.0.0.255 192.168.50.0 0.0.0.255
I am not sure where the problem is coming from. Router1 lets all traffic through. Is there anything wrong with the configs?
Appreciate any help.
Thanks,
Nick
I'm having a problem with a site to site VPN between a PIX and a router. The layout is basically like this :
LAN A -- 192.168.20.1( PIX )192.168.50.1-- 192.168.50.3(Router1)192.200.200.13 ----- 192.200.200.14(Remote Router2)192.168.250.x --- LAN B
I've setup client to PIX VPNs successully before, but not site to site, so I would appreciate any help.
The 2 VPN peers are the PIX and Router2 and the problem basically is, after inputting configuration for VPN on the 2 peers, the traffic that's supposed to be using the VPN tunnel to go between LAN A and LAN B, just seems to be going through "normally".
Here are the vpn related config :
PIX (running os 7.0.1)
access-list l2l extended permit ip 192.168.20.0 255.255.255.0 192.168.250.0 255.255.255.0
crypto ipsec transform-set transform1 esp-3des esp-md5-hmac
crypto map crypto1 1 match address l2l
crypto map crypto1 1 set peer 192.168.250.200
crypto map crypto1 1 set transform-set transform1
crypto map crypto1 interface Remote
isakmp enable Remote
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 43200
tunnel-group 192.168.250.200 type ipsec-l2l
tunnel-group 192.168.250.200 ipsec-attributes
pre-shared-key *
sysopt connection permit-ipsec
Note: I also had a nat 0 access-list but it didn't seem to make a difference.
Config for remote router:
interface loopback 1
ip address 192.168.250.200 255.255.255.0
crypto map Crypto1
Crypto isakmp policy 10
authentication pre-share
crypto isakmp key * address 192.168.50.1
crypto ipsec transform-set transform1 esp-3des
crypto map Crypto1 local-address interface loopback 1
crypto map Crypto1 20 ipsec-isakmp
set peer 192.168.50.1
set transform-set encrypt_des
match address 100
access-list 100 permit ip 192.168.250.0 0.0.0.255 192.168.50.0 0.0.0.255
I am not sure where the problem is coming from. Router1 lets all traffic through. Is there anything wrong with the configs?
Appreciate any help.
Thanks,
Nick