Challenge: I need the Public interface of the pix to allow traffic out, but at the same time, I need to be able to port forward/nat that address as well(to an internal server).
I only have 5 external IP addresses, one of which is the PIX. This system worked fine when I used a Netscreen FW(yea, I know, junk). I've configured my pix as below, but when I have the public interface set up to allow traffic back in, its not working. I've looked at this so many times I am sure I am missing something.
10.10.10.97 - public interface of the pix
10.10.10.100 - nat to internal servers working fine
10.10.10.101 - nat to internal servers working fine
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname xxx-pix
domain-name xxx.local
fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 115 permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.224
access-list split permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.224
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 permit tcp any host 10.10.10.101 eq smtp
access-list 101 permit tcp any host 10.10.10.101 eq www
access-list 101 permit tcp any host 10.10.10.101 eq 110
access-list 101 permit tcp any host 10.10.10.100 eq www
access-list 101 permit tcp any host 10.10.10.100 eq ftp
access-list 101 permit tcp any host 10.10.10.97 eq 5900
access-list 101 permit tcp any host 10.10.10.97 eq 5901
access-list 101 permit tcp any host 10.10.10.97 eq 3389
access-list 101 permit tcp any host 10.10.10.97 eq 443
access-list 101 permit tcp any host 10.10.10.97 eq 80
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 10.10.10.97 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 172.16.1.1-172.16.1.31
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 115
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 10.10.10.101 192.168.1.25 netmask 255.255.255.255 0 0
static (inside,outside) 10.10.10.100 192.168.1.24 netmask 255.255.255.255 0 0
static (inside,outside) 10.10.10.97 192.168.1.8 netmask 255.255.255.255 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 10.10.10.102 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth max-failed-attempts 3
aaa-server partnerauth deadtime 10
aaa-server partnerauth (inside) host 192.168.1.10 password timeout 5
http server enable
http 192.168.1.45 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map devmap 10 ipsec-isakmp dynamic dynmap
crypto map devmap client configuration address respond
crypto map devmap client authentication partnerauth
crypto map devmap interface outside
isakmp enable outside
isakmp key xxx73 address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp nat-traversal 10
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 10080
vpngroup xxxvpn address-pool ippool
vpngroup xxxvpn dns-server 192.168.1.10
vpngroup xxxvpn wins-server 192.168.1.11
vpngroup xxxvpn default-domain xxx.local
vpngroup xxxvpn split-tunnel split
vpngroup xxxvpn idle-time 1800
vpngroup xxxvpn password 123password
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 15
console timeout 0
terminal width 80
I only have 5 external IP addresses, one of which is the PIX. This system worked fine when I used a Netscreen FW(yea, I know, junk). I've configured my pix as below, but when I have the public interface set up to allow traffic back in, its not working. I've looked at this so many times I am sure I am missing something.
10.10.10.97 - public interface of the pix
10.10.10.100 - nat to internal servers working fine
10.10.10.101 - nat to internal servers working fine
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname xxx-pix
domain-name xxx.local
fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 115 permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.224
access-list split permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.224
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 permit tcp any host 10.10.10.101 eq smtp
access-list 101 permit tcp any host 10.10.10.101 eq www
access-list 101 permit tcp any host 10.10.10.101 eq 110
access-list 101 permit tcp any host 10.10.10.100 eq www
access-list 101 permit tcp any host 10.10.10.100 eq ftp
access-list 101 permit tcp any host 10.10.10.97 eq 5900
access-list 101 permit tcp any host 10.10.10.97 eq 5901
access-list 101 permit tcp any host 10.10.10.97 eq 3389
access-list 101 permit tcp any host 10.10.10.97 eq 443
access-list 101 permit tcp any host 10.10.10.97 eq 80
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 10.10.10.97 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 172.16.1.1-172.16.1.31
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 115
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 10.10.10.101 192.168.1.25 netmask 255.255.255.255 0 0
static (inside,outside) 10.10.10.100 192.168.1.24 netmask 255.255.255.255 0 0
static (inside,outside) 10.10.10.97 192.168.1.8 netmask 255.255.255.255 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 10.10.10.102 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server partnerauth protocol radius
aaa-server partnerauth max-failed-attempts 3
aaa-server partnerauth deadtime 10
aaa-server partnerauth (inside) host 192.168.1.10 password timeout 5
http server enable
http 192.168.1.45 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map devmap 10 ipsec-isakmp dynamic dynmap
crypto map devmap client configuration address respond
crypto map devmap client authentication partnerauth
crypto map devmap interface outside
isakmp enable outside
isakmp key xxx73 address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp nat-traversal 10
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 10080
vpngroup xxxvpn address-pool ippool
vpngroup xxxvpn dns-server 192.168.1.10
vpngroup xxxvpn wins-server 192.168.1.11
vpngroup xxxvpn default-domain xxx.local
vpngroup xxxvpn split-tunnel split
vpngroup xxxvpn idle-time 1800
vpngroup xxxvpn password 123password
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 15
console timeout 0
terminal width 80