I have a strange issue with my ACLs in my PIX 515e. I have names assigned:
names
name 192.168.0.100 bob
name 192.168.0.101 carol
name 192.168.0.102 ted
and I use these names for some static mappings:
static (inside,outside) xxx.xxx.xxx.20 bob netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.22 carol netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.24 ted netmask 255.255.255.255 0 0
That seems to work just fine. But in my ACLs, if I try this, it doesn't work:
access-list inbound permit tcp any host bob eq 8080
However, this works just fine:
access-list inbound permit tcp any host xxx.xxx.xxx.20 eq 8080
Anyone have any idea why that would be? It comes into particular effect when I'm using object-groups with the names...when the ACL's get expanded ("show access-list") and it uses the names, nothing works...so I'm stuck doing "longhand" with the IP addresses and making changes/edit that much more difficult.
Any ideas? Any help, of course, greatly appreciated.
Here's the full config in case it helps:
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxx encrypted
passwd xxx encrypted
hostname xxxhostnamexxx
domain-name xxxdomainnamexxx
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name 192.168.0.100 bob
name 192.168.0.101 carol
name 192.168.0.102 ted
object-group icmp-type icmp-allowed
icmp-object echo-reply
icmp-object source-quench
icmp-object time-exceeded
icmp-object unreachable
object-group network ma_servers
network-object host bob
network-object host carol
network-object host ted
access-list outbound permit ip any any
access-list inbound permit tcp any host xxx.xxx.xxx.20 eq 8080
access-list inbound permit tcp any host xxx.xxx.xxx.20 eq 80
access-list inbound permit tcp any host xxx.xxx.xxx.22 eq 8080
access-list inbound permit tcp any host xxx.xxx.xxx.24 eq 8080
access-list inbound permit icmp any host xxx.xxx.xxx.20 object-group icmp-allowed
access-list inbound permit icmp any host xxx.xxx.xxx.22 object-group icmp-allowed
access-list inbound permit icmp any host xxx.xxx.xxx.24 object-group icmp-allowed
pager lines 20
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.18 255.255.255.240
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
static (inside,outside) xxx.xxx.xxx.20 bob netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.22 carol netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.24 ted netmask 255.255.255.255 0 0
access-group inbound in interface outside
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.17 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:xxx
names
name 192.168.0.100 bob
name 192.168.0.101 carol
name 192.168.0.102 ted
and I use these names for some static mappings:
static (inside,outside) xxx.xxx.xxx.20 bob netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.22 carol netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.24 ted netmask 255.255.255.255 0 0
That seems to work just fine. But in my ACLs, if I try this, it doesn't work:
access-list inbound permit tcp any host bob eq 8080
However, this works just fine:
access-list inbound permit tcp any host xxx.xxx.xxx.20 eq 8080
Anyone have any idea why that would be? It comes into particular effect when I'm using object-groups with the names...when the ACL's get expanded ("show access-list") and it uses the names, nothing works...so I'm stuck doing "longhand" with the IP addresses and making changes/edit that much more difficult.
Any ideas? Any help, of course, greatly appreciated.
Here's the full config in case it helps:
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxx encrypted
passwd xxx encrypted
hostname xxxhostnamexxx
domain-name xxxdomainnamexxx
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name 192.168.0.100 bob
name 192.168.0.101 carol
name 192.168.0.102 ted
object-group icmp-type icmp-allowed
icmp-object echo-reply
icmp-object source-quench
icmp-object time-exceeded
icmp-object unreachable
object-group network ma_servers
network-object host bob
network-object host carol
network-object host ted
access-list outbound permit ip any any
access-list inbound permit tcp any host xxx.xxx.xxx.20 eq 8080
access-list inbound permit tcp any host xxx.xxx.xxx.20 eq 80
access-list inbound permit tcp any host xxx.xxx.xxx.22 eq 8080
access-list inbound permit tcp any host xxx.xxx.xxx.24 eq 8080
access-list inbound permit icmp any host xxx.xxx.xxx.20 object-group icmp-allowed
access-list inbound permit icmp any host xxx.xxx.xxx.22 object-group icmp-allowed
access-list inbound permit icmp any host xxx.xxx.xxx.24 object-group icmp-allowed
pager lines 20
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.18 255.255.255.240
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
static (inside,outside) xxx.xxx.xxx.20 bob netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.22 carol netmask 255.255.255.255 0 0
static (inside,outside) xxx.xxx.xxx.24 ted netmask 255.255.255.255 0 0
access-group inbound in interface outside
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.17 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:xxx