I am trying to setup a LAN to LAN VPN connection. I think I have everything right yet the connection will not work. Can anyone give me some pointers/tips.
Site 1 config:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname houston
domain-name test.com
no fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
no fixup protocol tftp 69
names
access-list 80 permit ip 192.168.5.0 255.255.255.0 192.168.1.0
255.255.255.0
access-list 80 permit ip 192.168.5.0 255.255.255.0 192.168.3.0
255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside <wan ip> 255.255.255.248
ip address inside 192.168.5.1 255.255.248.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.7.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 <gateway ip>
nat (inside) 0 access-list 80
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
access-group internet_deny in interface inside
route outside 0.0.0.0 0.0.0.0 <gateway ip> 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map abc 10 ipsec-isakmp
crypto map abc 10 match address 80
crypto map abc 10 set peer <peer ip>
crypto map abc 10 set transform-set strong
crypto map abc interface outside
isakmp enable outside
isakmp key <my key> address <peer ip> netmask 255.255.255.255
isakmp policy 8 authentication pre-share
isakmp policy 8 encryption 3des
isakmp policy 8 hash sha
isakmp policy 8 group 1
isakmp policy 8 lifetime 86400
telnet 192.168.5.1 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 80
: end
Site2:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname bleh
domain-name test.com
clock timezone CST -6
clock summer-time CDT recurring
no fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
no fixup protocol tftp 69
names
access-list 90 permit ip 192.168.1.0 255.255.255.0 192.168.5.0
255.255.255.0
access-list 90 permit ip 192.168.3.0 255.255.255.0 192.168.5.0
255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside <wan ip> 255.255.255.248
ip address inside 192.168.3.7 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.4.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 <gateway ip>
nat (inside) 0 access-list 90
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outbound_internet in interface inside
route outside 0.0.0.0 0.0.0.0 <gateway ip> 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map houston 20 ipsec-isakmp
crypto map houston 20 match address 90
crypto map houston 20 set peer <peer ip>
crypto map houston 20 set transform-set strong
crypto map houston interface outside
isakmp enable outside
isakmp key <my key> address <peer ip> netmask 255.255.255.255
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption 3des
isakmp policy 9 hash sha
isakmp policy 9 group 1
isakmp policy 9 lifetime 86400
telnet 192.168.3.7 255.255.255.255 inside
aaa-server LOCAL protocol local
telnet timeout 5
ssh 192.168.3.7 255.255.255.255 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 100
Site 1 config:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname houston
domain-name test.com
no fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
no fixup protocol tftp 69
names
access-list 80 permit ip 192.168.5.0 255.255.255.0 192.168.1.0
255.255.255.0
access-list 80 permit ip 192.168.5.0 255.255.255.0 192.168.3.0
255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside <wan ip> 255.255.255.248
ip address inside 192.168.5.1 255.255.248.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.7.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 <gateway ip>
nat (inside) 0 access-list 80
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
access-group internet_deny in interface inside
route outside 0.0.0.0 0.0.0.0 <gateway ip> 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map abc 10 ipsec-isakmp
crypto map abc 10 match address 80
crypto map abc 10 set peer <peer ip>
crypto map abc 10 set transform-set strong
crypto map abc interface outside
isakmp enable outside
isakmp key <my key> address <peer ip> netmask 255.255.255.255
isakmp policy 8 authentication pre-share
isakmp policy 8 encryption 3des
isakmp policy 8 hash sha
isakmp policy 8 group 1
isakmp policy 8 lifetime 86400
telnet 192.168.5.1 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 80
: end
Site2:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname bleh
domain-name test.com
clock timezone CST -6
clock summer-time CDT recurring
no fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
no fixup protocol tftp 69
names
access-list 90 permit ip 192.168.1.0 255.255.255.0 192.168.5.0
255.255.255.0
access-list 90 permit ip 192.168.3.0 255.255.255.0 192.168.5.0
255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside <wan ip> 255.255.255.248
ip address inside 192.168.3.7 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.4.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 <gateway ip>
nat (inside) 0 access-list 90
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outbound_internet in interface inside
route outside 0.0.0.0 0.0.0.0 <gateway ip> 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map houston 20 ipsec-isakmp
crypto map houston 20 match address 90
crypto map houston 20 set peer <peer ip>
crypto map houston 20 set transform-set strong
crypto map houston interface outside
isakmp enable outside
isakmp key <my key> address <peer ip> netmask 255.255.255.255
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption 3des
isakmp policy 9 hash sha
isakmp policy 9 group 1
isakmp policy 9 lifetime 86400
telnet 192.168.3.7 255.255.255.255 inside
aaa-server LOCAL protocol local
telnet timeout 5
ssh 192.168.3.7 255.255.255.255 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 100