Hi everyone,
I'm a newb to multicasting and trying to setup a single 3750 to stop flooding multicast. I upgraded the devices IOS with advanced IP services and ready to configure the unit.
Here's some background info on my setup:
I have 5 multicast video encoders flooding vlan 100 on my 3750 with 3 clients that require the traffic. The 5 encoders and 3 clients are all plugged into the same switch [VLAN100].
I've been following this link for the setup:
Which led to this lab configuration:
Switch#sh run
Building configuration...
*Mar 5 18:58:44.693: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 2401 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip subnet-zero
!
!
ip multicast-routing distributed
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
switchport access vlan 100
!
interface GigabitEthernet1/0/2
switchport access vlan 100
!
interface GigabitEthernet1/0/3
switchport access vlan 100
!
interface GigabitEthernet1/0/4
switchport access vlan 100
!
interface GigabitEthernet1/0/5
switchport access vlan 100
!
interface GigabitEthernet1/0/6
switchport access vlan 100
!
interface GigabitEthernet1/0/7
switchport access vlan 100
!
interface GigabitEthernet1/0/8
switchport access vlan 100
!
interface GigabitEthernet1/0/9
switchport access vlan 100
!
interface GigabitEthernet1/0/10
switchport access vlan 100
!
interface GigabitEthernet1/0/11
switchport access vlan 100
!
interface GigabitEthernet1/0/12
switchport access vlan 100
!
interface GigabitEthernet1/0/13
switchport access vlan 100
!
interface GigabitEthernet1/0/14
switchport access vlan 100
!
interface GigabitEthernet1/0/15
switchport access vlan 100
!
interface GigabitEthernet1/0/16
switchport access vlan 100
!
interface GigabitEthernet1/0/17
switchport access vlan 100
!
interface GigabitEthernet1/0/18
switchport access vlan 100
!
interface GigabitEthernet1/0/19
switchport access vlan 100
!
interface GigabitEthernet1/0/20
switchport access vlan 100
!
interface GigabitEthernet1/0/21
switchport access vlan 100
!
interface GigabitEthernet1/0/22
switchport access vlan 100
!
interface GigabitEthernet1/0/23
switchport access vlan 100
!
interface GigabitEthernet1/0/24
switchport access vlan 100
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip pim sparse-mode
!
ip classless
ip http server
ip http secure-server
ip pim rp-address 192.168.100.1 1 override
!
!
access-list 1 permit 230.0.0.1
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end
Switch#
Mcast still seems to be flooding the LAN so I obviously missed something. Another thing I noticed is that I can't specify PIM v2.
Switch(config)#int vlan 100
Switch(config-if)#ip pim version 2
% Invalid input detected at '^' marker.
Did I get the wrong IOS version? I also noticed that the "ip igmp snooping" command I issued does not show up in "sh run".
For now I'm just testing with a single stream 230.0.0.1.
Thanks in advance,
I'm a newb to multicasting and trying to setup a single 3750 to stop flooding multicast. I upgraded the devices IOS with advanced IP services and ready to configure the unit.
Here's some background info on my setup:
I have 5 multicast video encoders flooding vlan 100 on my 3750 with 3 clients that require the traffic. The 5 encoders and 3 clients are all plugged into the same switch [VLAN100].
I've been following this link for the setup:
Which led to this lab configuration:
Switch#sh run
Building configuration...
*Mar 5 18:58:44.693: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 2401 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip subnet-zero
!
!
ip multicast-routing distributed
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
switchport access vlan 100
!
interface GigabitEthernet1/0/2
switchport access vlan 100
!
interface GigabitEthernet1/0/3
switchport access vlan 100
!
interface GigabitEthernet1/0/4
switchport access vlan 100
!
interface GigabitEthernet1/0/5
switchport access vlan 100
!
interface GigabitEthernet1/0/6
switchport access vlan 100
!
interface GigabitEthernet1/0/7
switchport access vlan 100
!
interface GigabitEthernet1/0/8
switchport access vlan 100
!
interface GigabitEthernet1/0/9
switchport access vlan 100
!
interface GigabitEthernet1/0/10
switchport access vlan 100
!
interface GigabitEthernet1/0/11
switchport access vlan 100
!
interface GigabitEthernet1/0/12
switchport access vlan 100
!
interface GigabitEthernet1/0/13
switchport access vlan 100
!
interface GigabitEthernet1/0/14
switchport access vlan 100
!
interface GigabitEthernet1/0/15
switchport access vlan 100
!
interface GigabitEthernet1/0/16
switchport access vlan 100
!
interface GigabitEthernet1/0/17
switchport access vlan 100
!
interface GigabitEthernet1/0/18
switchport access vlan 100
!
interface GigabitEthernet1/0/19
switchport access vlan 100
!
interface GigabitEthernet1/0/20
switchport access vlan 100
!
interface GigabitEthernet1/0/21
switchport access vlan 100
!
interface GigabitEthernet1/0/22
switchport access vlan 100
!
interface GigabitEthernet1/0/23
switchport access vlan 100
!
interface GigabitEthernet1/0/24
switchport access vlan 100
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip pim sparse-mode
!
ip classless
ip http server
ip http secure-server
ip pim rp-address 192.168.100.1 1 override
!
!
access-list 1 permit 230.0.0.1
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end
Switch#
Mcast still seems to be flooding the LAN so I obviously missed something. Another thing I noticed is that I can't specify PIM v2.
Switch(config)#int vlan 100
Switch(config-if)#ip pim version 2
% Invalid input detected at '^' marker.
Did I get the wrong IOS version? I also noticed that the "ip igmp snooping" command I issued does not show up in "sh run".
For now I'm just testing with a single stream 230.0.0.1.
Thanks in advance,