Hello,
My apologies if this has been answered elsewhere...
we have a cisco 5510 that is our border router/firewall.
My vpn client is connected to the inside interface, and I can connect and authenticate (correctly) to the remote network, with the exception: all remote resources are unable to be contacted via ping or other ip protocol. Browsing the forums, I have the inkling that I'm supposed to define the ip pool of the source or destination to permit the traffic through the device, only that seems sort of weird- every time someone wants to vpn out from this network I have to define the external ip range so the router 'knows' what traffic to pass?
doesn't seem right. Any help much appreciated- here's my config:
: Saved
:
ASA Version 7.2(3)
!
hostname xxxxx
domain-name xxxx.local
enable password ***** encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 99.x.x.x 255.255.255.248
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0/2
shutdown
nameif dmz
security-level 50
ip address 192.x.x.1 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd ****** encrypted
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 68.94.156.1
name-server 68.94.157.1
name-server 192.168.10.7
domain-name ********.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service ****.com tcp
description http and https for ****.com
port-object eq www
port-object eq https
object-group service ****.com tcp
description http and https for ***
port-object eq www
port-object eq https
object-group service tcp
description http and https for ***.com
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
object-group service UDPforVPN udp
port-object range 4500 4500
port-object eq echo
port-object eq isakmp
access-list vpnusers_splitTunnelAcl standard permit any
access-list inside_access_in extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list inside_access_in remark udp for vpn
access-list inside_access_in extended permit udp any any
access-list inside_access_in remark udp for vpn
access-list outside_access_in remark incoming from outside everyone to ***.com on the inside 192.168.10.6
access-list outside_access_in extended permit tcp any object-group ***.com host 192.168.10.6 object-group ***.com inactive
access-list outside_access_in remark incoming from outside everyone to ***.com on the inside 192.x.x.20
access-list outside_access_in extended permit tcp any object-group ****.com host 192.x.x.20 object-group ****.com inactive
access-list outside_access_in extended permit tcp any host 192.x.x.x inactive
access-list outside_access_in remark incoming udp for vpn
access-list outside_access_in extended permit udp any object-group UDPforVPN any object-group UDPforVPN inactive
access-list vpnusergroup_splitTunnelAcl standard permit any
access-list dmz_access_in remark access rule for ***.com TCP FTP and FTP-data outside-->dmz
access-list dmz_access_in extended permit tcp any object-group ***.com host 192.x.x.x object-group ***.com inactive
access-list outside extended permit tcp any any eq pptp
access-list outside extended permit gre any any
access-list outside extended permit udp any any
access-list inside extended permit tcp any any eq pptp
access-list inside extended permit gre any any
access-list inside extended permit udp any any
access-list inside_access_out extended permit ip any any
pager lines 24
logging enable
logging asdm debugging
logging class ip asdm emergencies
mtu management 1500
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 101 interface
nat (inside) 101 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 99.165.4.134 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server radiuservergrp protocol radius
aaa-server radiuservergrp host 192.x.x.x
timeout 5
key ****
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
http server enable
http 192.x.x.x 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec fragmentation after-encryption management
crypto ipsec fragmentation after-encryption dmz
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 3600
telnet 192.168.1.0 255.255.255.0 management
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 management
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ctiqbe
inspect dcerpc
inspect http
inspect icmp
inspect icmp error
inspect ils
inspect ipsec-pass-thru
inspect mgcp
inspect pptp
inspect snmp
inspect waas
!
service-policy global_policy global
username **** password **** encrypted privilege 15
prompt hostname context
Cryptochecksum:07e23bba27bc7eb6ebafa33537ef6c76
: end
My apologies if this has been answered elsewhere...
we have a cisco 5510 that is our border router/firewall.
My vpn client is connected to the inside interface, and I can connect and authenticate (correctly) to the remote network, with the exception: all remote resources are unable to be contacted via ping or other ip protocol. Browsing the forums, I have the inkling that I'm supposed to define the ip pool of the source or destination to permit the traffic through the device, only that seems sort of weird- every time someone wants to vpn out from this network I have to define the external ip range so the router 'knows' what traffic to pass?
doesn't seem right. Any help much appreciated- here's my config:
: Saved
:
ASA Version 7.2(3)
!
hostname xxxxx
domain-name xxxx.local
enable password ***** encrypted
names
!
interface Ethernet0/0
nameif outside
security-level 0
ip address 99.x.x.x 255.255.255.248
!
interface Ethernet0/1
nameif inside
security-level 100
ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0/2
shutdown
nameif dmz
security-level 50
ip address 192.x.x.1 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd ****** encrypted
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 68.94.156.1
name-server 68.94.157.1
name-server 192.168.10.7
domain-name ********.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service ****.com tcp
description http and https for ****.com
port-object eq www
port-object eq https
object-group service ****.com tcp
description http and https for ***
port-object eq www
port-object eq https
object-group service tcp
description http and https for ***.com
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
object-group service UDPforVPN udp
port-object range 4500 4500
port-object eq echo
port-object eq isakmp
access-list vpnusers_splitTunnelAcl standard permit any
access-list inside_access_in extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list inside_access_in remark udp for vpn
access-list inside_access_in extended permit udp any any
access-list inside_access_in remark udp for vpn
access-list outside_access_in remark incoming from outside everyone to ***.com on the inside 192.168.10.6
access-list outside_access_in extended permit tcp any object-group ***.com host 192.168.10.6 object-group ***.com inactive
access-list outside_access_in remark incoming from outside everyone to ***.com on the inside 192.x.x.20
access-list outside_access_in extended permit tcp any object-group ****.com host 192.x.x.20 object-group ****.com inactive
access-list outside_access_in extended permit tcp any host 192.x.x.x inactive
access-list outside_access_in remark incoming udp for vpn
access-list outside_access_in extended permit udp any object-group UDPforVPN any object-group UDPforVPN inactive
access-list vpnusergroup_splitTunnelAcl standard permit any
access-list dmz_access_in remark access rule for ***.com TCP FTP and FTP-data outside-->dmz
access-list dmz_access_in extended permit tcp any object-group ***.com host 192.x.x.x object-group ***.com inactive
access-list outside extended permit tcp any any eq pptp
access-list outside extended permit gre any any
access-list outside extended permit udp any any
access-list inside extended permit tcp any any eq pptp
access-list inside extended permit gre any any
access-list inside extended permit udp any any
access-list inside_access_out extended permit ip any any
pager lines 24
logging enable
logging asdm debugging
logging class ip asdm emergencies
mtu management 1500
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 101 interface
nat (inside) 101 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 99.165.4.134 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server radiuservergrp protocol radius
aaa-server radiuservergrp host 192.x.x.x
timeout 5
key ****
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
http server enable
http 192.x.x.x 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec fragmentation after-encryption management
crypto ipsec fragmentation after-encryption dmz
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 3600
telnet 192.168.1.0 255.255.255.0 management
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 management
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ctiqbe
inspect dcerpc
inspect http
inspect icmp
inspect icmp error
inspect ils
inspect ipsec-pass-thru
inspect mgcp
inspect pptp
inspect snmp
inspect waas
!
service-policy global_policy global
username **** password **** encrypted privilege 15
prompt hostname context
Cryptochecksum:07e23bba27bc7eb6ebafa33537ef6c76
: end