zizoudevinci
IS-IT--Management
i have some trouble with my vpn client configuration
first the router is cisco 3725 with the ios
c3725-advsecurityk9-mz.124-25.bin
i made a test platform in GNS3 as follows using cisco SDM to perform the configuration as I did with my customer
PC1--------------------ISPRouter--------------------VpnRouter------------------PC2
PC1 to ISPRouter : 10.0.0.0/24
ISPRouter to VpnRouter : 61.24.178.0/24
ISPRouter to PC2 : 126.217.16.0/24
The configuration files
ISPRouter :
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPRouter
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
ip address 61.24.178.37 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial1/0
ip unnumbered Loopback0
encapsulation ppp
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip route 0.0.0.0 0.0.0.0 61.24.178.76
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 120 0
line aux 0
line vty 0 4
login
!
End
--------------------------------------
VpnRouter:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GW
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
aaa authentication login default local
aaa authentication login sdm_vpn_xauth_ml_1 local
aaa authorization exec default local
aaa authorization network sdm_vpn_group_ml_1 local
!
aaa session-id common
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
username cisco privilege 15 password 0 cisco
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group group-mc
key cisco123
pool SDM_POOL_1
acl 100
netmask 255.255.255.0
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map SDM_DYNMAP_1 1
set transform-set ESP-3DES-SHA
reverse-route
!
crypto map SDM_CMAP_1 client authentication list sdm_vpn_xauth_ml_1
crypto map SDM_CMAP_1 isakmp authorization list sdm_vpn_group_ml_1
crypto map SDM_CMAP_1 client configuration address respond
crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1
!
interface Loopback0
ip address 61.24.178.76 255.255.255.255
!
interface FastEthernet0/0
ip address 126.217.16.150 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip unnumbered loopback 0
ip nat outside
ip virtual-reassembly
encapsulation ppp
serial restart-delay 0
crypto map SDM_CMAP_1
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip local pool SDM_POOL_1 172.16.0.1 172.16.0.254
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial1/0
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source route-map SDM_RMAP_1 interface Serial1/0 overload
!
ip access-list standard ACL1
remark SDM_ACL Category=16
permit 126.217.16.0 0.0.0.255
!
access-list 100 remark SDM_ACL Category=4
access-list 100 permit ip 126.217.16.0 0.0.0.255 any
access-list 101 remark SDM_ACL Category=2
access-list 101 deny ip 126.217.16.0 0.0.0.255 172.16.0.0 0.0.0.255
access-list 101 permit ip 126.217.16.0 0.0.0.255 any
route-map SDM_RMAP_1 permit 1
match ip address 101
!
control-plane
!
line con 0
exec-timeout 120 0
line aux 0
line vty 0 4
!
End
--------------------------------------------------
With this configuration the VPN client can connect and the tunnel is up, I can ping the PC2 from PC1 but I cannot use any other protocol as FTP or HTTP or even windows share
So what I did I changed the configuration of the interface serial 1/0 like that and I deleted the loopbak0 interface
--------------------------------------------------
interface Serial1/0
ip address 61.24.178.76 255.255.255.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
serial restart-delay 0
crypto map SDM_CMAP_1
--------------------------------------------------
With this change everything is ok, I can ping the PC2 from PC1 and access all the protocol I want
But the problem is when I went to the apply it on the customer’s router the problem is still there, only ping is working , I don’t know where is the problem
Thanks for all the helping hand
first the router is cisco 3725 with the ios
c3725-advsecurityk9-mz.124-25.bin
i made a test platform in GNS3 as follows using cisco SDM to perform the configuration as I did with my customer
PC1--------------------ISPRouter--------------------VpnRouter------------------PC2
PC1 to ISPRouter : 10.0.0.0/24
ISPRouter to VpnRouter : 61.24.178.0/24
ISPRouter to PC2 : 126.217.16.0/24
The configuration files
ISPRouter :
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPRouter
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
interface Loopback0
ip address 61.24.178.37 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial1/0
ip unnumbered Loopback0
encapsulation ppp
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip route 0.0.0.0 0.0.0.0 61.24.178.76
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 120 0
line aux 0
line vty 0 4
login
!
End
--------------------------------------
VpnRouter:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GW
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
aaa authentication login default local
aaa authentication login sdm_vpn_xauth_ml_1 local
aaa authorization exec default local
aaa authorization network sdm_vpn_group_ml_1 local
!
aaa session-id common
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
username cisco privilege 15 password 0 cisco
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group group-mc
key cisco123
pool SDM_POOL_1
acl 100
netmask 255.255.255.0
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map SDM_DYNMAP_1 1
set transform-set ESP-3DES-SHA
reverse-route
!
crypto map SDM_CMAP_1 client authentication list sdm_vpn_xauth_ml_1
crypto map SDM_CMAP_1 isakmp authorization list sdm_vpn_group_ml_1
crypto map SDM_CMAP_1 client configuration address respond
crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1
!
interface Loopback0
ip address 61.24.178.76 255.255.255.255
!
interface FastEthernet0/0
ip address 126.217.16.150 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip unnumbered loopback 0
ip nat outside
ip virtual-reassembly
encapsulation ppp
serial restart-delay 0
crypto map SDM_CMAP_1
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip local pool SDM_POOL_1 172.16.0.1 172.16.0.254
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial1/0
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source route-map SDM_RMAP_1 interface Serial1/0 overload
!
ip access-list standard ACL1
remark SDM_ACL Category=16
permit 126.217.16.0 0.0.0.255
!
access-list 100 remark SDM_ACL Category=4
access-list 100 permit ip 126.217.16.0 0.0.0.255 any
access-list 101 remark SDM_ACL Category=2
access-list 101 deny ip 126.217.16.0 0.0.0.255 172.16.0.0 0.0.0.255
access-list 101 permit ip 126.217.16.0 0.0.0.255 any
route-map SDM_RMAP_1 permit 1
match ip address 101
!
control-plane
!
line con 0
exec-timeout 120 0
line aux 0
line vty 0 4
!
End
--------------------------------------------------
With this configuration the VPN client can connect and the tunnel is up, I can ping the PC2 from PC1 but I cannot use any other protocol as FTP or HTTP or even windows share
So what I did I changed the configuration of the interface serial 1/0 like that and I deleted the loopbak0 interface
--------------------------------------------------
interface Serial1/0
ip address 61.24.178.76 255.255.255.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
serial restart-delay 0
crypto map SDM_CMAP_1
--------------------------------------------------
With this change everything is ok, I can ping the PC2 from PC1 and access all the protocol I want
But the problem is when I went to the apply it on the customer’s router the problem is still there, only ping is working , I don’t know where is the problem
Thanks for all the helping hand