cable modem should come with an ethernet port. plug router ethernet into cable modem ethernet0 with a cross over (most likely) patch cable. then plug the other ethernet1 on your router into the switch with a straight through patch cable.
then on the router
conf t
interface ethernet 0
ip address dhcp
no shutdown
ip nat outside *
ip access-group 101 in *
exit
interface ethernet 1
ip address 192.168.1.1 255.255.255.0
ip nat inside *
no shut
exit
ip nat inside source list 102 interface ethernet0 overload *
access-list 102 permit ip 192.168.1.0 0.0.0.255 any *
access-list 101 deny ip 192.168.1.0 0.0.0.255 any *
access-list 101 permit tcp any any gt 1023 established *
ip route 0.0.0.0 0.0.0.0 <insert ip address of cable modem here> (this command may not be necessary since you should get this information through dhcp)
the commands with the * are optional but provide a quick pseudo security solution and access to the internet from internal hosts.
Erik Rudnick, CCIE No. 9545
mailto:erik@kuriosity.com
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.