Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Westi on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

nating using route-maps?

Status
Not open for further replies.

imbadatthis

Technical User
Aug 16, 2009
404
CA
Howdy,

can anyone be kind enough to give me an example NAT manipulation using route-maps? the beuk im reading suggets it can be done, but doesn't tell me how...



We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.
 
dual-homing an internet connection:
Code:
interface Serial1
  ip address 1.1.1.2 255.255.255.0
  ip nat outside

interface Serial2
  ip address 2.2.2.2 255.255.255.0
  ip nat outside

interface FastEthernet1
  ip address 192.168.151.254 255.255.255.0
  ip nat inside

ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route 0.0.0.0 0.0.0.0 2.2.2.2

access-list 100 permit ip 192.168.151.0 0.0.0.255 any

route-map OUT_S1 permit 10
  match ip address 100
  match interface s1

route-map OUT_S2 permit 10
  match ip address 100
  match interface s1

ip nat inside source route-map OUT_S1 interface s1 overload
ip nat inside source route-map OUT_S2 interface s2 overload

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 

route-map OUT_S2 permit 10
match ip address 100
match interface s2

,

thanks, can you please explain how it works as well please.
does it alternate the out interface?


We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.
 
in this case, yes. because i have two equal cost default routes it will do per destination load balancing (sharing).

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top