Hi,
We're having an issue with DNS on our DMZ. Basically users on say phones on the Wifi network connect to our DMZ. When they lookup our mail server, they are getting the internal IP and not the public IP.
The strange thing is it appears, using a laptop to test, like the DNS server is actually returning our internal IP. For example, using nslookup on a Windows laptop on this same Wifi network returns the provider DNS (public) and our internal 10.x.x.x IP.
I'm wondering if I don't need a static NAT for my mail server on the (inside,dmz) but I still can't figure out why the DNS server appears to be returning the wrong IP.
Here are I think the relevant parts of my config. If anyone can help, I would greatly appreciate it.
Thanks
interface Ethernet0
nameif outside
security-level 0
ip address 10.20.0.10 255.255.255.192
ospf cost 10
!
interface Ethernet1
speed 100
duplex full
nameif inside
security-level 100
ip address 10.0.0.1 255.255.255.252
ospf cost 10
!
interface Ethernet2
nameif dmz
security-level 4
ip address 192.168.2.1 255.255.255.0
ospf cost 10
dns domain-lookup outside
dns server-group DefaultDNS
name-server 64.71.0.34
name-server 64.71.0.60
name-server 64.105.172.26
name-server 64.105.172.27
domain-name default.domain.invalid
access-list dmz_nat0_outbound extended permit ip dmz-net 255.255.255.0 10.20.0.0 255.255.255.192
nat (inside) 0 access-list inside_nat0_outbound outside
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 0 access-list dmz_nat0_outbound
nat (dmz) 1 0.0.0.0 0.0.0.0
static (inside,outside) mail-ext mail-int netmask 255.255.255.255
access-group outside in interface outside
access-group INSIDE-ACL in interface inside
access-group DMZ-ACL in interface dmz
We're having an issue with DNS on our DMZ. Basically users on say phones on the Wifi network connect to our DMZ. When they lookup our mail server, they are getting the internal IP and not the public IP.
The strange thing is it appears, using a laptop to test, like the DNS server is actually returning our internal IP. For example, using nslookup on a Windows laptop on this same Wifi network returns the provider DNS (public) and our internal 10.x.x.x IP.
I'm wondering if I don't need a static NAT for my mail server on the (inside,dmz) but I still can't figure out why the DNS server appears to be returning the wrong IP.
Here are I think the relevant parts of my config. If anyone can help, I would greatly appreciate it.
Thanks
interface Ethernet0
nameif outside
security-level 0
ip address 10.20.0.10 255.255.255.192
ospf cost 10
!
interface Ethernet1
speed 100
duplex full
nameif inside
security-level 100
ip address 10.0.0.1 255.255.255.252
ospf cost 10
!
interface Ethernet2
nameif dmz
security-level 4
ip address 192.168.2.1 255.255.255.0
ospf cost 10
dns domain-lookup outside
dns server-group DefaultDNS
name-server 64.71.0.34
name-server 64.71.0.60
name-server 64.105.172.26
name-server 64.105.172.27
domain-name default.domain.invalid
access-list dmz_nat0_outbound extended permit ip dmz-net 255.255.255.0 10.20.0.0 255.255.255.192
nat (inside) 0 access-list inside_nat0_outbound outside
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 0 access-list dmz_nat0_outbound
nat (dmz) 1 0.0.0.0 0.0.0.0
static (inside,outside) mail-ext mail-int netmask 255.255.255.255
access-group outside in interface outside
access-group INSIDE-ACL in interface inside
access-group DMZ-ACL in interface dmz