imbadatthis
Technical User
Network setup :
PC / voip phone / wireless router --> C3550 -->(fa0/1-vlans) 2621xm -->(fa0/0) internet
the vonage box responsible for voip takes around 25kB (i have a fxs on order.... but for now thats the bandwidth i need) .
the wirless users are just http services, and dont really use alot of bandwidth.
I wanted my PC to be able to download / upload as much as it can, unless there is a voice call which in that case voice should get the priority bandwidth. Same with if a wireless user need bandwidth they would get priority over my PC.
PC wise, I wanted to cut the traffic to two classes:
1) HTTP / HTTPs
2) torrent traffic
where option 1 has higher priority over option 2.
I tackled the task using priority command for the voice class. And figured if i assigned precedent values to PC traffic (3 and 4 ) I could then use random detect to drop the torrent traffic.
This was my first attempt at QoS and I believed I have boshed it badly .
as always I appreciate your input and assistance.
a quick note to ISPKing - if you are going to be rude kindly keep in mind that i didn't actually ask you to click this link,
Below are the configs:
class maps:
class-map match-all WIRELESS
match dscp cs1
class-map match-all DATA-prec-fa0/1-http
match protocol http
class-map match-all DATA-prec-fa0/1-torr
match protocol fasttrack
class-map match-all DATA
match access-group 2
class-map match-all DATA-prec-fa0/1
match dscp af11
policy-maps:
policy-map masterv4
class voice
priority 200 160000
class WIRELESS
priority 100 160000
class DATA
bandwidth remaining percent 75
random-detect
random-detect precedence 3 80 200 150
random-detect precedence 4 30 80 40
policy-map DATA-prec-fa0/1v2
class DATA-prec-fa0/1-http
set precedence 4
class DATA
set precedence 3
policy-map DATA-prec-fa0/0-in-v3
class DATA-prec-fa0/1-http
set precedence 4
class DATA-prec-fa0/1-torr
set precedence 3
interfaces:
interface FastEthernet0/0
description $FW_OUTSIDE$
bandwidth 400
ip address dhcp hostname ISEEDEADPACKETS
ip access-group 101 in
no ip proxy-arp
ip accounting precedence input
ip nbar protocol-discovery
ip nat outside
ip nat enable
ip ips sdm_ips_rule in
ip ips sdm_ips_rule out
ip virtual-reassembly
duplex auto
speed auto
no keepalive
service-policy input DATA-prec-fa0/0-in-v3
service-policy output masterv4
!
!
interface FastEthernet0/1.3
description $FW_DMZ$
encapsulation dot1Q 3
ip address 10.100.100.1 255.255.255.252
ip accounting precedence input
ip accounting precedence output
ip nbar protocol-discovery
ip nat inside
ip nat enable
ip ips sdm_ips_rule in
ip virtual-reassembly
service-policy input DATA-prec-fa0/0-in-v3
service-policy output DATA-prec-fa0/0-in-v3
==============================
access-list 2 permit 10.100.100.2
==============================
show policy-map fa0/0
Elgrey-Hot#sh policy-map interface fa0/0
FastEthernet0/0
Service-policy input: DATA-prec-fa0/0-in-v3
Class-map: DATA-prec-fa0/1-http (match-all)
118474 packets, 154810200 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol http
QoS Set
precedence 4
Packets marked 118474
Class-map: DATA-prec-fa0/1-torr (match-all)
3932424 packets, 1520401920 bytes
5 minute offered rate 6000 bps, drop rate 0 bps
Match: protocol fasttrack
QoS Set
precedence 3
Packets marked 3932424
Class-map: class-default (match-any)
1776823 packets, 477157475 bytes
5 minute offered rate 2000 bps, drop rate 0 bps
Match: any
Service-policy output: masterv4
Class-map: voice (match-all)
31428 packets, 9031916 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp ef (46)
Queueing
Strict Priority
Output Queue: Conversation 136
Bandwidth 200 (kbps) Burst 160000 (Bytes)
(pkts matched/bytes matched) 4540/3286996
(total drops/bytes drops) 0/0
Class-map: WIRELESS (match-all)
58860 packets, 12733119 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp cs1 (8)
Queueing
Strict Priority
Output Queue: Conversation 136
Bandwidth 100 (kbps) Burst 160000 (Bytes)
(pkts matched/bytes matched) 14607/2270046
(total drops/bytes drops) 23/30786
Class-map: DATA (match-all)
12101 packets, 13302957 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 2
Queueing
Output Queue: Conversation 137
Bandwidth remaining 75 (%)
(pkts matched/bytes matched) 1679/2083571
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 0/0 0/0 0/0 20 40 1/10
1 12101/13302957 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 80 200 1/150
4 0/0 0/0 0/0 30 80 1/40
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: class-default (match-any)
7013301 packets, 4277801946 bytes
5 minute offered rate 182000 bps, drop rate 0 bps
Match: any
=============================================
I see that the packets are being marked.
but what I dont see under the sh policy-map interface command is anything under the 3 and 4 columns...
We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.
PC / voip phone / wireless router --> C3550 -->(fa0/1-vlans) 2621xm -->(fa0/0) internet
the vonage box responsible for voip takes around 25kB (i have a fxs on order.... but for now thats the bandwidth i need) .
the wirless users are just http services, and dont really use alot of bandwidth.
I wanted my PC to be able to download / upload as much as it can, unless there is a voice call which in that case voice should get the priority bandwidth. Same with if a wireless user need bandwidth they would get priority over my PC.
PC wise, I wanted to cut the traffic to two classes:
1) HTTP / HTTPs
2) torrent traffic
where option 1 has higher priority over option 2.
I tackled the task using priority command for the voice class. And figured if i assigned precedent values to PC traffic (3 and 4 ) I could then use random detect to drop the torrent traffic.
This was my first attempt at QoS and I believed I have boshed it badly .
as always I appreciate your input and assistance.
a quick note to ISPKing - if you are going to be rude kindly keep in mind that i didn't actually ask you to click this link,
Below are the configs:
class maps:
class-map match-all WIRELESS
match dscp cs1
class-map match-all DATA-prec-fa0/1-http
match protocol http
class-map match-all DATA-prec-fa0/1-torr
match protocol fasttrack
class-map match-all DATA
match access-group 2
class-map match-all DATA-prec-fa0/1
match dscp af11
policy-maps:
policy-map masterv4
class voice
priority 200 160000
class WIRELESS
priority 100 160000
class DATA
bandwidth remaining percent 75
random-detect
random-detect precedence 3 80 200 150
random-detect precedence 4 30 80 40
policy-map DATA-prec-fa0/1v2
class DATA-prec-fa0/1-http
set precedence 4
class DATA
set precedence 3
policy-map DATA-prec-fa0/0-in-v3
class DATA-prec-fa0/1-http
set precedence 4
class DATA-prec-fa0/1-torr
set precedence 3
interfaces:
interface FastEthernet0/0
description $FW_OUTSIDE$
bandwidth 400
ip address dhcp hostname ISEEDEADPACKETS
ip access-group 101 in
no ip proxy-arp
ip accounting precedence input
ip nbar protocol-discovery
ip nat outside
ip nat enable
ip ips sdm_ips_rule in
ip ips sdm_ips_rule out
ip virtual-reassembly
duplex auto
speed auto
no keepalive
service-policy input DATA-prec-fa0/0-in-v3
service-policy output masterv4
!
!
interface FastEthernet0/1.3
description $FW_DMZ$
encapsulation dot1Q 3
ip address 10.100.100.1 255.255.255.252
ip accounting precedence input
ip accounting precedence output
ip nbar protocol-discovery
ip nat inside
ip nat enable
ip ips sdm_ips_rule in
ip virtual-reassembly
service-policy input DATA-prec-fa0/0-in-v3
service-policy output DATA-prec-fa0/0-in-v3
==============================
access-list 2 permit 10.100.100.2
==============================
show policy-map fa0/0
Elgrey-Hot#sh policy-map interface fa0/0
FastEthernet0/0
Service-policy input: DATA-prec-fa0/0-in-v3
Class-map: DATA-prec-fa0/1-http (match-all)
118474 packets, 154810200 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol http
QoS Set
precedence 4
Packets marked 118474
Class-map: DATA-prec-fa0/1-torr (match-all)
3932424 packets, 1520401920 bytes
5 minute offered rate 6000 bps, drop rate 0 bps
Match: protocol fasttrack
QoS Set
precedence 3
Packets marked 3932424
Class-map: class-default (match-any)
1776823 packets, 477157475 bytes
5 minute offered rate 2000 bps, drop rate 0 bps
Match: any
Service-policy output: masterv4
Class-map: voice (match-all)
31428 packets, 9031916 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp ef (46)
Queueing
Strict Priority
Output Queue: Conversation 136
Bandwidth 200 (kbps) Burst 160000 (Bytes)
(pkts matched/bytes matched) 4540/3286996
(total drops/bytes drops) 0/0
Class-map: WIRELESS (match-all)
58860 packets, 12733119 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp cs1 (8)
Queueing
Strict Priority
Output Queue: Conversation 136
Bandwidth 100 (kbps) Burst 160000 (Bytes)
(pkts matched/bytes matched) 14607/2270046
(total drops/bytes drops) 23/30786
Class-map: DATA (match-all)
12101 packets, 13302957 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 2
Queueing
Output Queue: Conversation 137
Bandwidth remaining 75 (%)
(pkts matched/bytes matched) 1679/2083571
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
class Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
0 0/0 0/0 0/0 20 40 1/10
1 12101/13302957 0/0 0/0 22 40 1/10
2 0/0 0/0 0/0 24 40 1/10
3 0/0 0/0 0/0 80 200 1/150
4 0/0 0/0 0/0 30 80 1/40
5 0/0 0/0 0/0 30 40 1/10
6 0/0 0/0 0/0 32 40 1/10
7 0/0 0/0 0/0 34 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
Class-map: class-default (match-any)
7013301 packets, 4277801946 bytes
5 minute offered rate 182000 bps, drop rate 0 bps
Match: any
=============================================
I see that the packets are being marked.
but what I dont see under the sh policy-map interface command is anything under the 3 and 4 columns...
We must go always forward, not backward
always up, not down and always twirling twirling towards infinity.