jondoe0069
Programmer
After going back and forth with AT&T and having them keep passing the buck, I thought maybe someone might be able to see what is going on with our multilink set up:
We order 4 T1's bonded from AT&T and have confirmed that they have a multilink set up on their end and all 4 T1s connect to the same router on their end. Our multilink configuration is pretty basic and our router is putting traffic out onto each T1 as if it is one interface. Pings and NSLookups work fine, etc., but web pages do not display all the way. It seems that with each T1 I disconnect, more of a web page displays. I tried debug ppp multilink events and fragments and I only see fragments, but no events. From what it looks like, it is utilizing all 4 serial interfaces:
Sending 5, 100-byte ICMP Echos to 12.127.17.71, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/54/56 ms
Camelot_Rtr#
1d02h: Se0/0 MLP-FS: I seq C0001E30 size 110
1d02h: Se0/1 MLP-FS: I seq C0001E31 size 110
1d02h: Se1/1 MLP-FS: I seq C0001E32 size 110
1d02h: Se1/0 MLP-FS: I seq C0001E33 size 110
1d02h: Se0/0 MLP-FS: I seq C0001E34 size 110
Here is my config:
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Camelot_Rtr
!
!
!
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool Camelot
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server x.x.x.x x.x.x.x
!
!
!
!
!
!
!
!
!
!
!
!
interface Multilink1
ip address x.x.x.x 255.255.255.248
ip nat outside
no cdp enable
ppp multilink
no ppp multilink fragmentation
multilink-group 1
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed 100
full-duplex
!
interface Serial0/0
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
no fair-queue
ppp multilink
multilink-group 1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp multilink
multilink-group 1
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp multilink
multilink-group 1
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/1
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp multilink
multilink-group 1
!
ip nat inside source list 1 interface Multilink1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
Any help will be greatly appreciated! Thanks!!
We order 4 T1's bonded from AT&T and have confirmed that they have a multilink set up on their end and all 4 T1s connect to the same router on their end. Our multilink configuration is pretty basic and our router is putting traffic out onto each T1 as if it is one interface. Pings and NSLookups work fine, etc., but web pages do not display all the way. It seems that with each T1 I disconnect, more of a web page displays. I tried debug ppp multilink events and fragments and I only see fragments, but no events. From what it looks like, it is utilizing all 4 serial interfaces:
Sending 5, 100-byte ICMP Echos to 12.127.17.71, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/54/56 ms
Camelot_Rtr#
1d02h: Se0/0 MLP-FS: I seq C0001E30 size 110
1d02h: Se0/1 MLP-FS: I seq C0001E31 size 110
1d02h: Se1/1 MLP-FS: I seq C0001E32 size 110
1d02h: Se1/0 MLP-FS: I seq C0001E33 size 110
1d02h: Se0/0 MLP-FS: I seq C0001E34 size 110
Here is my config:
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Camelot_Rtr
!
!
!
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool Camelot
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server x.x.x.x x.x.x.x
!
!
!
!
!
!
!
!
!
!
!
!
interface Multilink1
ip address x.x.x.x 255.255.255.248
ip nat outside
no cdp enable
ppp multilink
no ppp multilink fragmentation
multilink-group 1
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
speed 100
full-duplex
!
interface Serial0/0
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
no fair-queue
ppp multilink
multilink-group 1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp multilink
multilink-group 1
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp multilink
multilink-group 1
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/1
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp multilink
multilink-group 1
!
ip nat inside source list 1 interface Multilink1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
Any help will be greatly appreciated! Thanks!!