jbrotschul
Technical User
[blue]I'm a newbie, so any feedback is greatly appreciated. I'm trying to incorporate a Verizon MPLS network to our current infrastructure.
We use eigrp as our routing protocol on our internal network. How can I make this work using the mpls connections with bgp?
So we have the mpls circuit in Rotterdam and Phila turned up...[/blue]
PHILADELPHIA (Cisco 4506 - Brain1 Ia.Ia.Ia.Ia):
interface Vlan28
description Verizon Business MPLS Ethernet Access
ip address Ea.Ea.Ea.Ea 255.255.255.252
no ip redirects
ip pim dense-mode
interface FastEthernet5/6
description Verizon Business MPLS Ethernet Access
switchport access vlan 28
switchport mode access
router bgp 11111
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor Eb.Eb.Eb.Eb remote-as 22222
no auto-summary
************************************************************
ROTTERDAM (Cisco 2811 - BDP_Rotterdam_MPLS Ic.Ic.Ic.Ic):
interface Serial0/2/0:1
no ip address
encapsulation frame-relay IETF
! point-to-point
description Verizon Business MPLS Circuit rotterdam-nl
ip address Ec.Ec.Ec.Ec 255.255.255.252
frame-relay interface-dlci 100 IETF
!
router bgp 11111
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor Ed.Ed.Ed.Ed remote-as 22222
no auto-summary
[blue]And I can communicate accross the mpls network to each other...[/blue]
PHILADELPHIA (Cisco 4506 - Brain1 Ia.Ia.Ia.Ia):
BDP_Brain1# ping Ic.Ic.Ic.Ic
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Ic.Ic.Ic.Ic, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/94/96 ms
BDP_Brain1#trace Ic.Ic.Ic.Ic
Type escape sequence to abort.
Tracing the route to Ic.Ic.Ic.Ic
1 Eb.Eb.Eb.Eb 0 msec 4 msec 4 msec
2 Ed.Ed.Ed.Ed [AS 22222] 88 msec 92 msec 88 msec
3 Ec.Ec.Ec.Ec [AS 22222] 92 msec * 92 msec
BDP_Brain1#
************************************************************
ROTTERDAM (Cisco 2811 - BDP_Rotterdam_MPLS Ic.Ic.Ic.Ic):
BDP_Rotterdam_MPLS#ping Ia.Ia.Ia.Ia
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Ia.Ia.Ia.Ia, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/95/96 ms
BDP_Rotterdam_MPLS# trace Ia.Ia.Ia.Ia
Type escape sequence to abort.
Tracing the route to Ia.Ia.Ia.Ia
1 Ed.Ed.Ed.Ed 4 msec 4 msec 4 msec
2 Ea.Ea.Ea.Ea [AS 22222] 96 msec 96 msec *
BDP_Rotterdam_MPLS#
[blue]But i can't communicate beyond the 2 end points...[/blue]
PHILADELPHIA (Cisco 4506 - Brain1 Ia.Ia.Ia.Ia):
BDP_Brain1#ping Id.Id.Id.Id
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Id.Id.Id.Id, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
BDP_Brain1#trace Id.Id.Id.Id
Type escape sequence to abort.
Tracing the route to Id.Id.Id.Id
1 Eb.Eb.Eb.Eb 4 msec 4 msec 0 msec
2 Ed.Ed.Ed.Ed [AS 22222] 88 msec 88 msec 88 msec
3 Ec.Ec.Ec.Ec [AS 22222] 96 msec 96 msec 96 msec
4 * * *
************************************************************
ROTTERDAM (Cisco 2811 - BDP_Rotterdam_MPLS Ic.Ic.Ic.Ic):
BDP_Rotterdam_MPLS#ping Ib.Ib.Ib.Ib
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Ib.Ib.Ib.Ib, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
BDP_Rotterdam_MPLS#trace Ib.Ib.Ib.Ib
Type escape sequence to abort.
Tracing the route to Ib.Ib.Ib.Ib
1 Ed.Ed.Ed.Ed 4 msec 4 msec 4 msec
2 Ea.Ea.Ea.Ea [AS 22222] 96 msec 92 msec 96 msec
3 * * *
We use eigrp as our routing protocol on our internal network. How can I make this work using the mpls connections with bgp?
So we have the mpls circuit in Rotterdam and Phila turned up...[/blue]
PHILADELPHIA (Cisco 4506 - Brain1 Ia.Ia.Ia.Ia):
interface Vlan28
description Verizon Business MPLS Ethernet Access
ip address Ea.Ea.Ea.Ea 255.255.255.252
no ip redirects
ip pim dense-mode
interface FastEthernet5/6
description Verizon Business MPLS Ethernet Access
switchport access vlan 28
switchport mode access
router bgp 11111
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor Eb.Eb.Eb.Eb remote-as 22222
no auto-summary
************************************************************
ROTTERDAM (Cisco 2811 - BDP_Rotterdam_MPLS Ic.Ic.Ic.Ic):
interface Serial0/2/0:1
no ip address
encapsulation frame-relay IETF
! point-to-point
description Verizon Business MPLS Circuit rotterdam-nl
ip address Ec.Ec.Ec.Ec 255.255.255.252
frame-relay interface-dlci 100 IETF
!
router bgp 11111
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor Ed.Ed.Ed.Ed remote-as 22222
no auto-summary
[blue]And I can communicate accross the mpls network to each other...[/blue]
PHILADELPHIA (Cisco 4506 - Brain1 Ia.Ia.Ia.Ia):
BDP_Brain1# ping Ic.Ic.Ic.Ic
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Ic.Ic.Ic.Ic, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/94/96 ms
BDP_Brain1#trace Ic.Ic.Ic.Ic
Type escape sequence to abort.
Tracing the route to Ic.Ic.Ic.Ic
1 Eb.Eb.Eb.Eb 0 msec 4 msec 4 msec
2 Ed.Ed.Ed.Ed [AS 22222] 88 msec 92 msec 88 msec
3 Ec.Ec.Ec.Ec [AS 22222] 92 msec * 92 msec
BDP_Brain1#
************************************************************
ROTTERDAM (Cisco 2811 - BDP_Rotterdam_MPLS Ic.Ic.Ic.Ic):
BDP_Rotterdam_MPLS#ping Ia.Ia.Ia.Ia
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Ia.Ia.Ia.Ia, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/95/96 ms
BDP_Rotterdam_MPLS# trace Ia.Ia.Ia.Ia
Type escape sequence to abort.
Tracing the route to Ia.Ia.Ia.Ia
1 Ed.Ed.Ed.Ed 4 msec 4 msec 4 msec
2 Ea.Ea.Ea.Ea [AS 22222] 96 msec 96 msec *
BDP_Rotterdam_MPLS#
[blue]But i can't communicate beyond the 2 end points...[/blue]
PHILADELPHIA (Cisco 4506 - Brain1 Ia.Ia.Ia.Ia):
BDP_Brain1#ping Id.Id.Id.Id
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Id.Id.Id.Id, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
BDP_Brain1#trace Id.Id.Id.Id
Type escape sequence to abort.
Tracing the route to Id.Id.Id.Id
1 Eb.Eb.Eb.Eb 4 msec 4 msec 0 msec
2 Ed.Ed.Ed.Ed [AS 22222] 88 msec 88 msec 88 msec
3 Ec.Ec.Ec.Ec [AS 22222] 96 msec 96 msec 96 msec
4 * * *
************************************************************
ROTTERDAM (Cisco 2811 - BDP_Rotterdam_MPLS Ic.Ic.Ic.Ic):
BDP_Rotterdam_MPLS#ping Ib.Ib.Ib.Ib
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to Ib.Ib.Ib.Ib, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
BDP_Rotterdam_MPLS#trace Ib.Ib.Ib.Ib
Type escape sequence to abort.
Tracing the route to Ib.Ib.Ib.Ib
1 Ed.Ed.Ed.Ed 4 msec 4 msec 4 msec
2 Ea.Ea.Ea.Ea [AS 22222] 96 msec 92 msec 96 msec
3 * * *