DanieleMessina
IS-IT--Management
Hello,
I have a network infrastructure as shown in the attached picture.
I'm working with Boson Netsim as I don't have access to the hardware.
The Gateway is a MLS, the two switches on the left are managed and the one on the bottom is unmanaged.
I have two VLANs: 20 and 99.
On the MLS I have the following config:
!
Version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Gateway_1
ip cef
!
!
!
!
!
ip subnet-zero
ip routing
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
interface FastEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,24,31
!
interface FastEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,24,31
!
interface FastEthernet0/3
switchport mode access
switchport access vlan 99
!
interface FastEthernet0/4
switchport mode access
switchport access vlan 99
!
interface FastEthernet0/5
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/6
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/7
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/8
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/9
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/11
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/12
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
vtp mode Server
vtp domain NULL
!
interface Vlan 1
no ip address
no ip route-cache
!
interface Vlan0099
ip address 10.0.0.1 255.0.0.0
no ip route-cache
no shutdown
!
interface Vlan0020
ip address 172.20.4.111 255.255.0.0
no ip route-cache
no shutdown
!
vlan 99 name RM
vlan 20 name HMI_MELTSHOP
!
router rip
network 10.0.0.0
network 172.20.0.0
!
!
!
ip classless
no ip http server
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end
Now, I can ping interface Vlan 99 from PC 4, directly connected to the MLS, but not from PC 3 which is connected through the unmanaged switch.
What am I missing here?
Thanks in advance for your help.
I have a network infrastructure as shown in the attached picture.
I'm working with Boson Netsim as I don't have access to the hardware.
The Gateway is a MLS, the two switches on the left are managed and the one on the bottom is unmanaged.
I have two VLANs: 20 and 99.
On the MLS I have the following config:
!
Version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Gateway_1
ip cef
!
!
!
!
!
ip subnet-zero
ip routing
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
interface FastEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,24,31
!
interface FastEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20,24,31
!
interface FastEthernet0/3
switchport mode access
switchport access vlan 99
!
interface FastEthernet0/4
switchport mode access
switchport access vlan 99
!
interface FastEthernet0/5
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/6
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/7
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/8
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/9
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/11
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface FastEthernet0/12
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
!
vtp mode Server
vtp domain NULL
!
interface Vlan 1
no ip address
no ip route-cache
!
interface Vlan0099
ip address 10.0.0.1 255.0.0.0
no ip route-cache
no shutdown
!
interface Vlan0020
ip address 172.20.4.111 255.255.0.0
no ip route-cache
no shutdown
!
vlan 99 name RM
vlan 20 name HMI_MELTSHOP
!
router rip
network 10.0.0.0
network 172.20.0.0
!
!
!
ip classless
no ip http server
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end
Now, I can ping interface Vlan 99 from PC 4, directly connected to the MLS, but not from PC 3 which is connected through the unmanaged switch.
What am I missing here?
Thanks in advance for your help.