Hey all, I am studying for my CCNA right now. Since this is a lab area and not a production network I chose to stick my issue here as opposed to the Router/Switch forums.
I currenly have the following equipment:
3 switches
- C2950C-24 (c2950-i6k2l2q4-mz.121-22.EA11.bin)
- 2 x C2924-XL (c2900xl-c3h2s-mz.120-5.WC17.bin)
3 routers
- 3640 (c3640-jk9o3s-mz.124-7a.bin)
- 2620XM (c2600-ipbasek9-mz.124-19.bin)
- 2610XM (c2600-advsecurityk9-mz.124-15.T4.bin)
Here's my issue
Using the 3640, 2950, one 2924, and two PC's I have configured a Router on a Stick. My setup is like so:
3640
| (trunk f0/0 to f0/24)
2950 - PC1 on f0/10
| (trunk f0/1 to f0/1)
2924 - PC2 on f0/21
When I have f0/21 configured as a member of VLAN 10 I am experiencing severe latency when pinging any other device on the network from PC2.
3640
2950
2924
Like I said above, this is only a lab environment so it's not a big deal, but I'm still wondering nevertheless. Thanks.
I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
I currenly have the following equipment:
3 switches
- C2950C-24 (c2950-i6k2l2q4-mz.121-22.EA11.bin)
- 2 x C2924-XL (c2900xl-c3h2s-mz.120-5.WC17.bin)
3 routers
- 3640 (c3640-jk9o3s-mz.124-7a.bin)
- 2620XM (c2600-ipbasek9-mz.124-19.bin)
- 2610XM (c2600-advsecurityk9-mz.124-15.T4.bin)
Here's my issue
Using the 3640, 2950, one 2924, and two PC's I have configured a Router on a Stick. My setup is like so:
3640
| (trunk f0/0 to f0/24)
2950 - PC1 on f0/10
| (trunk f0/1 to f0/1)
2924 - PC2 on f0/21
When I have f0/21 configured as a member of VLAN 10 I am experiencing severe latency when pinging any other device on the network from PC2.
f0/10 is configured as a member of VLAN 20 and response times are <1ms when pinging from PC1. The wierd thing is if I configure f0/21 as a member of VLAN 20 ping times go to <1ms. Here are the config's from the devicesC:\>ping 172.20.20.5
Pinging 172.20.20.5 with 32 bytes of data:
Reply from 172.20.20.5: bytes=32 time=642ms TTL=127
Reply from 172.20.20.5: bytes=32 time=141ms TTL=127
Reply from 172.20.20.5: bytes=32 time=249ms TTL=127
Reply from 172.20.20.5: bytes=32 time=10ms TTL=127
Ping statistics for 172.20.20.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 10ms, Maximum = 642ms, Average = 260ms
3640
Code:
Current configuration : 1662 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3640
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1
ip address 192.168.10.254 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.20.10.254 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 172.20.20.254 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.920
encapsulation dot1Q 920 native
no snmp trap link-status
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/4
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/5
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/6
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/7
no ip address
shutdown
no dce-terminal-timing-enable
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
!
!
Code:
Current configuration : 1615 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW2950
!
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
description SW2950 to SW2924 trunk
switchport trunk native vlan 910
switchport trunk allowed vlan 1,10,20
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 20
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
description SW2950 to R3640 trunk
switchport trunk native vlan 920
switchport trunk allowed vlan 1,10,20
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface Vlan1
ip address 192.168.10.29 255.255.255.0
no ip route-cache
!
ip http server
!
line con 0
logging synchronous
line vty 0 4
login
line vty 5 15
login
!
!
Code:
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW2924
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
description SW2924 to SW2950 trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 910
switchport trunk allowed vlan 1,10,20,1002-1005
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface VLAN1
ip address 192.168.10.30 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
!
line con 0
logging synchronous
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)