Saeed42
ISP
- Jul 4, 2001
- 147
I'm trying to set up an ISDN callback, but I have this little problem that is doing my head in, I can make a connection from the callback router (Callback-Server) to the client, but every time the client dials into the callback server it can't establish a connection, I've tried everything and I can't seem to figure out what is missing, I can see the line coming in but nothing else, I've tried debuging the authentication, negotiation, ISDN events, q921 and q931, so your help would be nice and greatly appreciated as usual. The 2 configs are shown below
hostname Callback-Server
!
!
username Callback-Server password 0 password
username callback-client password 0 password
!
ip subnet-zero
!
isdn switch-type basic-net3
!
!
process-max-time 200
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer callback-secure
dialer enable-timeout 2
dialer map ip 192.168.2.5 name bsg class dial1 02087859999
dialer-group 1
ppp callback accept
ppp authentication chap
!
no ip http server
no ip classless
ip route 192.168.2.0 255.255.255.0 192.168.2.5
!
!
map-class dialer dial1
dialer-list 1 protocol ip permit
~~~~~~~~~~~~~~~~~~~~Client Router~~~~~~~~~~~~~~~~~~~~~~~~~~~
username Callback-Server password 0 password
username callback-client password 0 password
ip subnet-zero
!
no ip finger
no ip dhcp-client network-discovery
isdn switch-type basic-net3
!
!
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
!
interface BRI0
ip address 192.168.2.5 255.255.255.0
encapsulation ppp
dialer map ip 192.168.2.1 name cpe 02087851234
dialer-group 1
isdn switch-type basic-net3
ppp callback request
ppp authentication chap
!
no ip http server
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.2.1
!
dialer-list 1 protocol ip permit
!
hostname Callback-Server
!
!
username Callback-Server password 0 password
username callback-client password 0 password
!
ip subnet-zero
!
isdn switch-type basic-net3
!
!
process-max-time 200
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer callback-secure
dialer enable-timeout 2
dialer map ip 192.168.2.5 name bsg class dial1 02087859999
dialer-group 1
ppp callback accept
ppp authentication chap
!
no ip http server
no ip classless
ip route 192.168.2.0 255.255.255.0 192.168.2.5
!
!
map-class dialer dial1
dialer-list 1 protocol ip permit
~~~~~~~~~~~~~~~~~~~~Client Router~~~~~~~~~~~~~~~~~~~~~~~~~~~
username Callback-Server password 0 password
username callback-client password 0 password
ip subnet-zero
!
no ip finger
no ip dhcp-client network-discovery
isdn switch-type basic-net3
!
!
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
!
interface BRI0
ip address 192.168.2.5 255.255.255.0
encapsulation ppp
dialer map ip 192.168.2.1 name cpe 02087851234
dialer-group 1
isdn switch-type basic-net3
ppp callback request
ppp authentication chap
!
no ip http server
ip classless
ip route 192.168.2.0 255.255.255.0 192.168.2.1
!
dialer-list 1 protocol ip permit
!