Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

IPSec VPN Issues

Status
Not open for further replies.

jbober14

IS-IT--Management
Sep 28, 2011
8
0
0
US
I was hoping someone could look over my configuration and shed some light on the issues i am having. Once I establish a tunnel my ability to use the internet on client machines goes away. I thought this was a split tunneling issue but everything looks okay to me. The other issue I am having is communicating with servers and NAS devices on the internal network. Any help would be appreciated!

Code:
ASA Version 8.3(1)
!
hostname ArgentASA
domain-name argent.local
enable password ######## encrypted
passwd ############# encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 172.30.1.5 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address *.*.*.194 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa831-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
 domain-name argent.local
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object service Passive_FTP
 service tcp source range 5010 5030
object network OutsideIP
 host *.*.*.195
object network FTP_Server
 host 172.30.1.250
object service FTP
 service tcp source eq ftp
object network vpnpool
 subnet 172.30.2.0 255.255.255.0
object network inside_network
 subnet 172.30.1.0 255.255.255.0
object-group network group-inside-vpnclient
 description all inside accessible networks
 network-object 172.30.1.0 255.255.255.0
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list outside_access_in extended permit tcp any object FTP_Server eq ftp
access-list outside_access_in extended permit tcp any object FTP_Server range 5010 5030
access-list outside_access_in extended permit ip 172.30.2.0 255.255.255.0 172.30.1.0 255.255.255.0
access-list acl-vpnclient extended permit ip object-group group-inside-vpnclient any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool ippool-vpnclient 172.30.2.10-172.30.2.30 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static FTP_Server OutsideIP service Passive_FTP Passive_FTP
nat (inside,outside) source static FTP_Server OutsideIP service FTP FTP
nat (inside,any) source static inside_network inside_network destination static vpnpool vpnpool
!
object network obj_any
 nat (inside,outside) dynamic interface
object network inside_network
 nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 *.*.*.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 172.30.1.0 255.255.255.0 inside
http 172.30.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set xform-3des-md5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dcmap-vpnclient 1 set pfs group1
crypto dynamic-map dcmap-vpnclient 1 set transform-set xform-3des-md5
crypto map cmap-vpncient 65535 ipsec-isakmp dynamic dcmap-vpnclient
crypto map cmap-vpncient interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal 3600
telnet timeout 5
ssh 172.30.1.0 255.255.255.0 inside
ssh 172.30.2.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
management-access inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy group-policy-default internal
group-policy group-policy-default attributes
 banner value Welcome to Argent's VPN
 dns-server value 8.8.8.8
 vpn-tunnel-protocol IPSec
 password-storage disable
 re-xauth disable
 pfs disable
 ipsec-udp enable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value acl-vpnclient
 default-domain value argent.LOCAL
username jbober password ###### encrypted
tunnel-group vpnclient type remote-access
tunnel-group vpnclient general-attributes
 address-pool ippool-vpnclient
 default-group-policy group-policy-default
tunnel-group vpnclient ipsec-attributes
 pre-shared-key *****
!
class-map ftp-class
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
 class ftp-class
  inspect ftp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http [URL unfurl="true"]https://tools.cisco.com/its/service/oddce/services/DDCEService[/URL]
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:-
: end
 
Try changing your acl-vpngroup to a standard ACL as opposed to extended as it is now.

 
Thanks for the heads up I will give that a try.

If you dont mind me asking why would changing the acl to standard help this issue?
 
I ended up getting this to work. The problem was not the firewall but the gateways.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top