Hi,
I am running into an issue where a laptop connected to a switch that has ip-helper configured is not able to get an IP from the dhcp server.
The switch can ping the DHCP server and vice versa. I also tried to setup a separate DHCP server to rule out the dhcp server being the cause but no luck.
Config:
VLan 2 is the vlan for the laptop.
#sho conf
version 12.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname
!
!
clock timezone EST -5
clock summer-time EST recurring
ip subnet-zero
ip routing
!
!
!
!
interface FastEthernet0/1
switchport access vlan 19
switchport mode access
***OMITTED****
!
interface FastEthernet0/42
switchport access vlan 2
switchport mode access
speed 100
duplex full
spanning-tree portfast
!
interface GigabitEthernet0/1
description fiber to cltsw02
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,5,119
switchport mode trunk
!
interface Vlan1
ip address 10.71.1.1 255.255.0.0
!
interface Vlan2
description
ip address 10.16.11.1 255.255.255.0
ip helper-address 10.11.44.3
router ospf 1
log-adjacency-changes
network 10.71.0.0 0.0.255.255 area 3
network 10.72.0.0 0.0.255.255 area 3
network 10.73.0.0 0.0.255.255 area 3
network 10.75.0.0 0.0.255.255 area 3
network 10.76.0.0 0.0.255.255 area 3
network 10.16.11.0 0.0.0.255 area 3
ip classless
no ip http server
!
!
!
control-plane
line con 0
line vty 0 4
exec-timeout 0 0
login
line vty 5 15
exec-timeout 0 0
login
!
!
monitor session 1 source interface Fa0/35
monitor session 1 destination interface Fa0/34
ntp clock-period 36029285
ntp server 10.111.51.1
end
UDP Debug:
Sep 29 13:15:58: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=310
Sep 29 13:15:58: UDP: sent src=10.16.11.1(67), dst=10.11.44.3(67), length=310
Sep 29 13:16:02: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=310
Sep 29 13:16:02: UDP: sent src=10.16.11.1(67), dst=10.11.44.3(67), length=310
Sep 29 13:16:09: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=310
Sep 29 13:16:09: UDP: sent src=10.16.11.1(67), dst=10.11.44.3(67), length=310
I am running into an issue where a laptop connected to a switch that has ip-helper configured is not able to get an IP from the dhcp server.
The switch can ping the DHCP server and vice versa. I also tried to setup a separate DHCP server to rule out the dhcp server being the cause but no luck.
Config:
VLan 2 is the vlan for the laptop.
#sho conf
version 12.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname
!
!
clock timezone EST -5
clock summer-time EST recurring
ip subnet-zero
ip routing
!
!
!
!
interface FastEthernet0/1
switchport access vlan 19
switchport mode access
***OMITTED****
!
interface FastEthernet0/42
switchport access vlan 2
switchport mode access
speed 100
duplex full
spanning-tree portfast
!
interface GigabitEthernet0/1
description fiber to cltsw02
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,5,119
switchport mode trunk
!
interface Vlan1
ip address 10.71.1.1 255.255.0.0
!
interface Vlan2
description
ip address 10.16.11.1 255.255.255.0
ip helper-address 10.11.44.3
router ospf 1
log-adjacency-changes
network 10.71.0.0 0.0.255.255 area 3
network 10.72.0.0 0.0.255.255 area 3
network 10.73.0.0 0.0.255.255 area 3
network 10.75.0.0 0.0.255.255 area 3
network 10.76.0.0 0.0.255.255 area 3
network 10.16.11.0 0.0.0.255 area 3
ip classless
no ip http server
!
!
!
control-plane
line con 0
line vty 0 4
exec-timeout 0 0
login
line vty 5 15
exec-timeout 0 0
login
!
!
monitor session 1 source interface Fa0/35
monitor session 1 destination interface Fa0/34
ntp clock-period 36029285
ntp server 10.111.51.1
end
UDP Debug:
Sep 29 13:15:58: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=310
Sep 29 13:15:58: UDP: sent src=10.16.11.1(67), dst=10.11.44.3(67), length=310
Sep 29 13:16:02: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=310
Sep 29 13:16:02: UDP: sent src=10.16.11.1(67), dst=10.11.44.3(67), length=310
Sep 29 13:16:09: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=310
Sep 29 13:16:09: UDP: sent src=10.16.11.1(67), dst=10.11.44.3(67), length=310