I need help configuring a Cisco 1750 Modular router to allow connection to my web/ftp sites.
My WAN connection is via DSL on the Fastethernet 0 interface, and the LAN [Network address 192.168.0.0]on the second ethernet interface.
How do I configure my router to allow connection from the outside into both my web server with static ip address 192.168.0.8 and the ftp site 192.168.0.9? The following is the router's current configuration.
!
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname SAMPLE
!
enable password pass
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface Dialer 1
description connected to Internet
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer-group 2
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname user@sample.net
ppp chap password tester
ppp pap sent-username user@sample.net password tester
!
interface FastEthernet 0
no shutdown
description connected to LAN
ip address 192.168.0.10 255.255.255.0
ip nat inside
keepalive 10
ip tcp adjust-mss 1452
!
interface Ethernet 0
no shutdown
description connected to Internet
no ip address
no keepalive
pppoe enable
pppoe-client dial-pool-number 1
!
interface Serial 0
no description
no ip address
shutdown
!
! Access Control List 1
!
no access-list 1
access-list 1 permit 192.168.0.0 0.0.0.255
!
! Dialer Control List 2
!
no dialer-list 2
dialer-list 2 protocol ip permit
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Dialer 1 overload
!
router rip
version 2
network 192.168.0.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
no ip http server
snmp-server community public RO
snmp-server location SAMPLELAB
snmp-server contact NOC
!
line console 0
exec-timeout 0 0
password $netw0rk$
login
!
line vty 0 4
password $netw0rk$
login
!
end
My WAN connection is via DSL on the Fastethernet 0 interface, and the LAN [Network address 192.168.0.0]on the second ethernet interface.
How do I configure my router to allow connection from the outside into both my web server with static ip address 192.168.0.8 and the ftp site 192.168.0.9? The following is the router's current configuration.
!
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname SAMPLE
!
enable password pass
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface Dialer 1
description connected to Internet
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer-group 2
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname user@sample.net
ppp chap password tester
ppp pap sent-username user@sample.net password tester
!
interface FastEthernet 0
no shutdown
description connected to LAN
ip address 192.168.0.10 255.255.255.0
ip nat inside
keepalive 10
ip tcp adjust-mss 1452
!
interface Ethernet 0
no shutdown
description connected to Internet
no ip address
no keepalive
pppoe enable
pppoe-client dial-pool-number 1
!
interface Serial 0
no description
no ip address
shutdown
!
! Access Control List 1
!
no access-list 1
access-list 1 permit 192.168.0.0 0.0.0.255
!
! Dialer Control List 2
!
no dialer-list 2
dialer-list 2 protocol ip permit
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Dialer 1 overload
!
router rip
version 2
network 192.168.0.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
no ip http server
snmp-server community public RO
snmp-server location SAMPLELAB
snmp-server contact NOC
!
line console 0
exec-timeout 0 0
password $netw0rk$
login
!
line vty 0 4
password $netw0rk$
login
!
end