Bedrock1977
Technical User
I am almost finished with setting up my Cisco home lab. I have five 2520 routers and two 2950-24 switches.
The underlying frame relay network is as follows:
R1, R2, & R3 are connected in a hub-and-spoke network with R1 setup as the hub with a multi-point interface on their own subnet. R4 is connected to R1 with a point-to-point interface on there own subnet.
R1: Int S0 172.16.123.1/24 DLCI 102 --> R2 DLCI 103 --> R3
Int S0.14 172.16.14.1/24 DLCI 104 --> R4
R2: Int S0 172.16.123.2/24 DLCI 201 --> R1
R3: Int S0 172.16.123.3/24 DLCI 301 --> R1
R4: Int S0 172.16.14.2/24 DLCI 401 --> R1
I have a 2509 Access Server connected to all devices for ease of moving back and forth between devices.
My home computer and Linksys Wireless Router for internet access is in the 192.168.1.0 network.
On R1, I have the E0 interface set with a 192.168.1.2 address, since the Linksys Router is 192.168.1.1. I have SW1 connected to E0 on R1. Also connected to SW1 is the tFTP server 192.168.1.150, the Linksys Router itself, and R2. SW1 and SW2 share two trunk connections with SW2 having connections to both R3 and R4. My hopes are that I can setup two VLANs 10 & 20 with R1 & R4 in VLAN10 and R2 & R3 in VLAN 20.
The part where I am confused is how to properly address the switch network. My intial guess was to stick all E0 interfaces on R1, R2, R3, and R4 on the 192.168.1.0 network. When I did that, all routers could talk to each other but only through the switches and not over the frame relay network. I'm trying to figure out a proper way to incorporate the two switches so I can utilize VLANs, STP, trunks, etc.
Here are the configs for each of the Routers.
R1:
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
interface Serial0
ip address 172.16.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ip 172.16.123.3 103 broadcast
no frame-relay inverse-arp
interface Serial0.14 point-to-point
ip address 172.16.14.1 255.255.255.0
frame-relay interface-dlci 104
interface Serial1
no ip address
shutdown
router eigrp 10
redistribute static
network 172.16.0.0
network 192.168.1.0
no auto-summary
ip default-gateway 192.168.1.1
ip route 0.0.0.0 0.0.0.0 Ethernet0
R2:
interface Ethernet0
ip address 192.168.1.3 255.255.255.0
interface Serial0
ip address 172.16.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ip 172.16.123.3 201 broadcast
no frame-relay inverse-arp
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
R3:
interface Ethernet0
ip address 192.168.1.4 255.255.255.0
no keepalive
interface Serial0
ip address 172.16.123.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.123.1 301 broadcast
frame-relay map ip 172.16.123.2 301 broadcast
no frame-relay inverse-arp
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
R4:
interface Ethernet0
ip address 192.168.1.5 255.255.255.0
no keepalive
interface Serial0.14 point-to-point
ip address 172.16.14.2 255.255.255.0
frame-relay interface-dlci 401
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
I hope this is clear as to what I intend to do here. If you need further configs, please let me know.
Thanks,
Chris
The underlying frame relay network is as follows:
R1, R2, & R3 are connected in a hub-and-spoke network with R1 setup as the hub with a multi-point interface on their own subnet. R4 is connected to R1 with a point-to-point interface on there own subnet.
R1: Int S0 172.16.123.1/24 DLCI 102 --> R2 DLCI 103 --> R3
Int S0.14 172.16.14.1/24 DLCI 104 --> R4
R2: Int S0 172.16.123.2/24 DLCI 201 --> R1
R3: Int S0 172.16.123.3/24 DLCI 301 --> R1
R4: Int S0 172.16.14.2/24 DLCI 401 --> R1
I have a 2509 Access Server connected to all devices for ease of moving back and forth between devices.
My home computer and Linksys Wireless Router for internet access is in the 192.168.1.0 network.
On R1, I have the E0 interface set with a 192.168.1.2 address, since the Linksys Router is 192.168.1.1. I have SW1 connected to E0 on R1. Also connected to SW1 is the tFTP server 192.168.1.150, the Linksys Router itself, and R2. SW1 and SW2 share two trunk connections with SW2 having connections to both R3 and R4. My hopes are that I can setup two VLANs 10 & 20 with R1 & R4 in VLAN10 and R2 & R3 in VLAN 20.
The part where I am confused is how to properly address the switch network. My intial guess was to stick all E0 interfaces on R1, R2, R3, and R4 on the 192.168.1.0 network. When I did that, all routers could talk to each other but only through the switches and not over the frame relay network. I'm trying to figure out a proper way to incorporate the two switches so I can utilize VLANs, STP, trunks, etc.
Here are the configs for each of the Routers.
R1:
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
interface Serial0
ip address 172.16.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ip 172.16.123.3 103 broadcast
no frame-relay inverse-arp
interface Serial0.14 point-to-point
ip address 172.16.14.1 255.255.255.0
frame-relay interface-dlci 104
interface Serial1
no ip address
shutdown
router eigrp 10
redistribute static
network 172.16.0.0
network 192.168.1.0
no auto-summary
ip default-gateway 192.168.1.1
ip route 0.0.0.0 0.0.0.0 Ethernet0
R2:
interface Ethernet0
ip address 192.168.1.3 255.255.255.0
interface Serial0
ip address 172.16.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ip 172.16.123.3 201 broadcast
no frame-relay inverse-arp
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
R3:
interface Ethernet0
ip address 192.168.1.4 255.255.255.0
no keepalive
interface Serial0
ip address 172.16.123.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.123.1 301 broadcast
frame-relay map ip 172.16.123.2 301 broadcast
no frame-relay inverse-arp
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
R4:
interface Ethernet0
ip address 192.168.1.5 255.255.255.0
no keepalive
interface Serial0.14 point-to-point
ip address 172.16.14.2 255.255.255.0
frame-relay interface-dlci 401
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
I hope this is clear as to what I intend to do here. If you need further configs, please let me know.
Thanks,
Chris