heatstreak20
MIS
Hello, I am currently trying to configure a cisco router for my company to allow VPN sessions. The VPN is handled on the server and employees use their AD login information to VPN. I believe it won't work right now because of NAT.
With a $100 linksys router they can VPN fine, but with the cisco router they cannot. The only thing I thought might work is adding an access group 101 that allows any tcp communication on port 1723 and gre on all addresses, but this did not help.
Here is the current configuration:
Current configuration : 1531 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Shaftdrillers
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$WoI/$chsvq1pDwKPpgiKm827Xx.
!
no aaa new-model
!
resource policy
!
!
ip cef
no ip domain lookup
ip name-server 63.66.160.10
ip name-server 63.66.160.11
!
!
username admin privilege 15 password 0 admin
!
interface Ethernet0/0
description WAN
ip address 63.86.xx.203 255.255.255.0
ip access-group 101 in
ip nat outside
ip virtual-reassembly max-fragments 16 max-reassemblies 64 timeout 5
half-duplex
!
interface Ethernet0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
full-duplex
!
router rip
network 192.168.1.0
!
ip http server
ip http authentication local
!
ip route 0.0.0.0 0.0.0.0 63.86.xx.xx
ip route 63.86.xx.0 255.255.255.0 0.0.0.0
ip route 192.168.1.0 255.255.255.0 0.0.0.0
ip route 192.168.3.0 255.255.255.0 192.168.1.254
!
ip nat translation tcp-timeout 600
ip nat translation udp-timeout 600
ip nat translation max-entries 25000
ip nat inside source list 7 interface Ethernet0/0 overload
!
logging 192.168.1.12
access-list 7 permit 192.168.1.0 0.0.0.255
access-list 101 permit tcp any any eq 1723
access-list 101 permit gre any any
access-list 101 permit ip any any
How can I configure the router to allow VPN and allow the user to use their AD login information to validate the VPN?
Thank you again for your help
With a $100 linksys router they can VPN fine, but with the cisco router they cannot. The only thing I thought might work is adding an access group 101 that allows any tcp communication on port 1723 and gre on all addresses, but this did not help.
Here is the current configuration:
Current configuration : 1531 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Shaftdrillers
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$WoI/$chsvq1pDwKPpgiKm827Xx.
!
no aaa new-model
!
resource policy
!
!
ip cef
no ip domain lookup
ip name-server 63.66.160.10
ip name-server 63.66.160.11
!
!
username admin privilege 15 password 0 admin
!
interface Ethernet0/0
description WAN
ip address 63.86.xx.203 255.255.255.0
ip access-group 101 in
ip nat outside
ip virtual-reassembly max-fragments 16 max-reassemblies 64 timeout 5
half-duplex
!
interface Ethernet0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
full-duplex
!
router rip
network 192.168.1.0
!
ip http server
ip http authentication local
!
ip route 0.0.0.0 0.0.0.0 63.86.xx.xx
ip route 63.86.xx.0 255.255.255.0 0.0.0.0
ip route 192.168.1.0 255.255.255.0 0.0.0.0
ip route 192.168.3.0 255.255.255.0 192.168.1.254
!
ip nat translation tcp-timeout 600
ip nat translation udp-timeout 600
ip nat translation max-entries 25000
ip nat inside source list 7 interface Ethernet0/0 overload
!
logging 192.168.1.12
access-list 7 permit 192.168.1.0 0.0.0.255
access-list 101 permit tcp any any eq 1723
access-list 101 permit gre any any
access-list 101 permit ip any any
How can I configure the router to allow VPN and allow the user to use their AD login information to validate the VPN?
Thank you again for your help