Hi,
I am in the process of configuring a DMVPN between 3 x Cisco 1841's. I have never previously done this so I am not 100% that what I have configured will work. My config's are below. My main questions are:
1. Do the config's below look like they will work?
2. Ideally I would like to put an ACL on the External interface. However, I am not sure what ports or protocols I need to allow through for the DMVPN to work correctly (if any at all). Also, do I need to put an ACL on the Tunnel interface?
3. At the SPOKE end I would like to configure QOS to prioritize the VPN traffic. I am concerned that if users are downloading large files over the internet that the users that access data over the VPN tunnel will slow down so I would like a way of guaranteeing bandwidth for the VPN. I believe that QOS is the way to do this but I have never done this before so would like a few pointers.
-----------------------------------------------------
Here is the HUB config:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname hq
!
boot-start-marker
boot system flash c1841-advipservicesk9-mz.124-17.bin
boot-end-marker
!
logging buffered 52000 debugging
!
no aaa new-model
ip cef
!
!
!
ip domain name domain.com
!
!
crypto pki trustpoint TP-self-signed-3122676952
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3122676952
revocation-check none
rsakeypair TP-self-signed-3122676952
!
!
crypto pki certificate chain TP-self-signed-3122676952
certificate self-signed 01
3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33313232 36373639 3532301E 170D3038 30353132 31393334
32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31323236
37363935 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100BDB9 3E42673A DF17FDC5 D536AD7F 5218AE46 5C25ACD3 9861C183 ED2A7A49
A9FB63A5 09A657C7 85AF8B8F 75EE6117 5B29DAAB 8342E31B 0AC360BC 500EF20E
C71FF5CD 345C76F0 60CADF06 AB7D8371 4C447147 F5F698F9 969918C6 2A9389A1
73B87CF0 D021FCEC E44F4AB7 7675C59F F45E8548 B34C70CA 4E0EF4E5 89EB7FF3
FC330203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 30210603
551D1104 1A301882 16796F75 726E616D 652E7061 726B616D 646F6D2E 636F6D30
1F060355 1D230418 30168014 B1A7EE1B B6ABBA71 7D013AA9 D3100591 1C03FA14
301D0603 551D0E04 160414B1 A7EE1BB6 ABBA717D 013AA9D3 1005911C 03FA1430
0D06092A 864886F7 0D010104 05000381 810046CC 42C02981 3C0C597A 3880A249
D8958940 1D679B3C 0DDC46C0 E1E1E11E CF195DE6 40CD9448 2B888564 7E0889A1
83B741CE 967997C6 8A864F46 EF80BAC0 0936D4D1 FE55B2A3 04DF52D2 3A240456
4D39BB84 3895286C 2E0568E6 ED2E9AFC 18740F02 0E90FA14 D8D4FC85 701D13EC
2D491F9B AC0E89AD 8C6F0249 D2578B59 16CD
quit
username admin privilege 15 secret 5 $1$7Kr5$cC6pTLWjL98pU0Oeemrk42
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key 12345678 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set SET1 esp-des esp-md5-hmac
!
crypto ipsec profile SDM_Profile1
set transform-set SET1
!
!
!
interface Tunnel0
bandwidth 1000
ip address 192.168.250.254 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 1
ip nhrp authentication DMVPN_NW
ip nhrp map multicast dynamic
ip nhrp network-id 100000
ip nhrp holdtime 360
ip tcp adjust-mss 1360
no ip split-horizon eigrp 1
delay 1000
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0/0
description Internal
ip address 192.168.27.3 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description External
ip address 62.xxx.xxx.xxx 255.255.255.248
ip nat outside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
router eigrp 1
network 192.168.27.0
network 192.168.250.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 62.xxx.xxx.xxx permanent
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet0/1 overload
!
!
access-list 100 permit ip 192.168.27.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end
----------------------------------------------------
Here is the SPOKE config:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname branch1
!
boot-start-marker
boot-end-marker
!
logging buffered 52000 debugging
!
no aaa new-model
ip cef
!
!
!
!
ip domain name domain.com
!
!
crypto pki trustpoint TP-self-signed-3159821177
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3159821177
revocation-check none
rsakeypair TP-self-signed-3159821177
!
!
crypto pki certificate chain TP-self-signed-3159821177
certificate self-signed 01
3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33313539 38323131 3737301E 170D3038 30353134 31393435
32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31353938
32313137 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100DB37 B39DAC6D 3B001EBA 226E519A 71FB1EF6 EE2C4A8C 658BDAAF C656F91D
91D1EFF0 2D6CCE8D 00B04DB2 C564ECBF 207E6AFA 13C0415E CDE101FF 1B1191F5
1815DD96 AF6923D8 B6A27EE8 726538C0 45613CCB 0902BCB3 CD589AE5 49A2F7D2
A5EE7BD5 2C127789 D30BAC81 2210E5CD C88729AD 8B8B2B48 292CD1BC 37D4E52F
DE7D0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
301F0603 551D2304 18301680 14D70215 737489DA 7BABAC77 B4664145 D46E0C52
EE301D06 03551D0E 04160414 D7021573 7489DA7B ABAC77B4 664145D4 6E0C52EE
300D0609 2A864886 F70D0101 04050003 8181001D 4189F95C DB9D5D87 3AB3D18C
EDF4A1A6 8D0D699A EB82D9ED 7704FC85 AE23594B 72E20121 5246E1C3 CC0E9AB1
F639E760 4B0408D5 08F3CE55 9B1DD4A7 55F1B767 123ADFD7 A5F3A49C 05F02095
998AFC4C 9B4AC8D4 76C5B535 AD24FEF3 C813E568 BAD1C06E 78FDE4B5 8FB59DC7
72CE1812 F5F91286 7A445177 C22573A3 79F030
quit
username admin privilege 15 secret 5 $1$bmKy$MfqixXUNdxcB.iwTAj1Tp0
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key 12345678 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set SET1 esp-des esp-md5-hmac
!
crypto ipsec profile SDM_Profile1
set transform-set SET1
!
!
!
interface Tunnel0
bandwidth 1000
ip address 192.168.250.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication DMVPN_NW
ip nhrp map 192.168.250.254 62.xxx.xxx.xxx
ip nhrp map multicast 62.xxx.xxx.xxx
ip nhrp network-id 100000
ip nhrp holdtime 360
ip nhrp nhs 192.168.250.254
ip tcp adjust-mss 1360
delay 1000
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0/0
description Internal
ip address 192.168.26.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description External$ETH-WAN$
ip address 62.xxx.xxx.xxx 255.255.255.240
ip nat outside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
router eigrp 1
network 192.168.26.0
network 192.168.250.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 62.xxx.xxx.xxx permanent
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.26.7 21 interface FastEthernet0/1 21
ip nat inside source static tcp 192.168.26.7 5081 interface FastEthernet0/1 5081
ip nat inside source static tcp 192.168.26.7 5080 interface FastEthernet0/1 5080
!
access-list 100 permit ip 192.168.26.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end
Any help will be greatly appreciated.
I am in the process of configuring a DMVPN between 3 x Cisco 1841's. I have never previously done this so I am not 100% that what I have configured will work. My config's are below. My main questions are:
1. Do the config's below look like they will work?
2. Ideally I would like to put an ACL on the External interface. However, I am not sure what ports or protocols I need to allow through for the DMVPN to work correctly (if any at all). Also, do I need to put an ACL on the Tunnel interface?
3. At the SPOKE end I would like to configure QOS to prioritize the VPN traffic. I am concerned that if users are downloading large files over the internet that the users that access data over the VPN tunnel will slow down so I would like a way of guaranteeing bandwidth for the VPN. I believe that QOS is the way to do this but I have never done this before so would like a few pointers.
-----------------------------------------------------
Here is the HUB config:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname hq
!
boot-start-marker
boot system flash c1841-advipservicesk9-mz.124-17.bin
boot-end-marker
!
logging buffered 52000 debugging
!
no aaa new-model
ip cef
!
!
!
ip domain name domain.com
!
!
crypto pki trustpoint TP-self-signed-3122676952
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3122676952
revocation-check none
rsakeypair TP-self-signed-3122676952
!
!
crypto pki certificate chain TP-self-signed-3122676952
certificate self-signed 01
3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33313232 36373639 3532301E 170D3038 30353132 31393334
32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31323236
37363935 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100BDB9 3E42673A DF17FDC5 D536AD7F 5218AE46 5C25ACD3 9861C183 ED2A7A49
A9FB63A5 09A657C7 85AF8B8F 75EE6117 5B29DAAB 8342E31B 0AC360BC 500EF20E
C71FF5CD 345C76F0 60CADF06 AB7D8371 4C447147 F5F698F9 969918C6 2A9389A1
73B87CF0 D021FCEC E44F4AB7 7675C59F F45E8548 B34C70CA 4E0EF4E5 89EB7FF3
FC330203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 30210603
551D1104 1A301882 16796F75 726E616D 652E7061 726B616D 646F6D2E 636F6D30
1F060355 1D230418 30168014 B1A7EE1B B6ABBA71 7D013AA9 D3100591 1C03FA14
301D0603 551D0E04 160414B1 A7EE1BB6 ABBA717D 013AA9D3 1005911C 03FA1430
0D06092A 864886F7 0D010104 05000381 810046CC 42C02981 3C0C597A 3880A249
D8958940 1D679B3C 0DDC46C0 E1E1E11E CF195DE6 40CD9448 2B888564 7E0889A1
83B741CE 967997C6 8A864F46 EF80BAC0 0936D4D1 FE55B2A3 04DF52D2 3A240456
4D39BB84 3895286C 2E0568E6 ED2E9AFC 18740F02 0E90FA14 D8D4FC85 701D13EC
2D491F9B AC0E89AD 8C6F0249 D2578B59 16CD
quit
username admin privilege 15 secret 5 $1$7Kr5$cC6pTLWjL98pU0Oeemrk42
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key 12345678 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set SET1 esp-des esp-md5-hmac
!
crypto ipsec profile SDM_Profile1
set transform-set SET1
!
!
!
interface Tunnel0
bandwidth 1000
ip address 192.168.250.254 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 1
ip nhrp authentication DMVPN_NW
ip nhrp map multicast dynamic
ip nhrp network-id 100000
ip nhrp holdtime 360
ip tcp adjust-mss 1360
no ip split-horizon eigrp 1
delay 1000
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0/0
description Internal
ip address 192.168.27.3 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description External
ip address 62.xxx.xxx.xxx 255.255.255.248
ip nat outside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
router eigrp 1
network 192.168.27.0
network 192.168.250.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 62.xxx.xxx.xxx permanent
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet0/1 overload
!
!
access-list 100 permit ip 192.168.27.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end
----------------------------------------------------
Here is the SPOKE config:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname branch1
!
boot-start-marker
boot-end-marker
!
logging buffered 52000 debugging
!
no aaa new-model
ip cef
!
!
!
!
ip domain name domain.com
!
!
crypto pki trustpoint TP-self-signed-3159821177
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3159821177
revocation-check none
rsakeypair TP-self-signed-3159821177
!
!
crypto pki certificate chain TP-self-signed-3159821177
certificate self-signed 01
3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33313539 38323131 3737301E 170D3038 30353134 31393435
32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31353938
32313137 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100DB37 B39DAC6D 3B001EBA 226E519A 71FB1EF6 EE2C4A8C 658BDAAF C656F91D
91D1EFF0 2D6CCE8D 00B04DB2 C564ECBF 207E6AFA 13C0415E CDE101FF 1B1191F5
1815DD96 AF6923D8 B6A27EE8 726538C0 45613CCB 0902BCB3 CD589AE5 49A2F7D2
A5EE7BD5 2C127789 D30BAC81 2210E5CD C88729AD 8B8B2B48 292CD1BC 37D4E52F
DE7D0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
301F0603 551D2304 18301680 14D70215 737489DA 7BABAC77 B4664145 D46E0C52
EE301D06 03551D0E 04160414 D7021573 7489DA7B ABAC77B4 664145D4 6E0C52EE
300D0609 2A864886 F70D0101 04050003 8181001D 4189F95C DB9D5D87 3AB3D18C
EDF4A1A6 8D0D699A EB82D9ED 7704FC85 AE23594B 72E20121 5246E1C3 CC0E9AB1
F639E760 4B0408D5 08F3CE55 9B1DD4A7 55F1B767 123ADFD7 A5F3A49C 05F02095
998AFC4C 9B4AC8D4 76C5B535 AD24FEF3 C813E568 BAD1C06E 78FDE4B5 8FB59DC7
72CE1812 F5F91286 7A445177 C22573A3 79F030
quit
username admin privilege 15 secret 5 $1$bmKy$MfqixXUNdxcB.iwTAj1Tp0
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key 12345678 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set SET1 esp-des esp-md5-hmac
!
crypto ipsec profile SDM_Profile1
set transform-set SET1
!
!
!
interface Tunnel0
bandwidth 1000
ip address 192.168.250.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication DMVPN_NW
ip nhrp map 192.168.250.254 62.xxx.xxx.xxx
ip nhrp map multicast 62.xxx.xxx.xxx
ip nhrp network-id 100000
ip nhrp holdtime 360
ip nhrp nhs 192.168.250.254
ip tcp adjust-mss 1360
delay 1000
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 100000
tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0/0
description Internal
ip address 192.168.26.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description External$ETH-WAN$
ip address 62.xxx.xxx.xxx 255.255.255.240
ip nat outside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
router eigrp 1
network 192.168.26.0
network 192.168.250.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 62.xxx.xxx.xxx permanent
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.26.7 21 interface FastEthernet0/1 21
ip nat inside source static tcp 192.168.26.7 5081 interface FastEthernet0/1 5081
ip nat inside source static tcp 192.168.26.7 5080 interface FastEthernet0/1 5080
!
access-list 100 permit ip 192.168.26.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end
Any help will be greatly appreciated.