Need a little help with getting the routes set up properly. Refer to the pic for explanation
Like it says in the pic, I can ping everything from router 1, but am unable to ping past the first router from router 2. Any help would be greatly appreciated
First thing I would check would be to check to make sure that the server has the proper gateway set and that the switch port it is connected to is a member of VLAN10.
I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
The server gateway is fine, and as I said the switch is pingable from Router 1. The switch is also in vlan 10. I believe its just a route I'm missing, any ideas on what it is?
Your ip scheme behind Router 1 is 10.4.0.x - 10.4.15.255. Your IP on the VLAN10 interface is 10.4.8.241 which is in the same range as what is behind Router 1. See if you can change it to something outside of the range mentioned above. In the end you should have a route on Router 1 for whatever is behind Router 2 and vice versa. I'm confused as to how Router 2 could even ping Router 1's VLAN10 IP. Can you post configs??
I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
So you think that it probably has something to with the vlan 10 Ip addresses?
Here is the port configuration for Router 2:
!
!
interface FastEthernet0
switchport access vlan 10
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address 10.10.13.2 255.255.255.252
ip pim dense-mode
duplex auto
speed auto
interface Vlan10
ip address 10.4.8.241 255.255.240.0
ip helper-address 10.4.0.1
ip pim dense-mode
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.10.13.1
ip route 10.4.8.0 255.255.255.0 10.10.13.1
!
And Here is Port Config for Router 1
interface FastEthernet0
switchport access vlan 10
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address 10.10.13.1 255.255.255.252
ip pim dense-mode
duplex auto
speed auto
!
interface Vlan10
ip address 10.4.8.240 255.255.240.0
!
ip forward-protocol nd
ip route profile
ip route 0.0.0.0 0.0.0.0 10.4.15.254
ip route 10.4.8.0 255.255.255.0 10.10.13.2
ip route 10.4.14.0 255.255.255.0 10.4.8.241
I was able to ping the Vlan 10 Ip address of Router 1 From Router 2 by setting up a route to it
It's the fact that you're trying to bridge vlan 10 across routed links. All routed interfaces need to ALL be different subnets---if you want to propagate vlan info across those links, you'll have to trunk.
For example---you have a route in this router telling it (or trying to) how to route to one of it's directly connected links...
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.